aboutsummaryrefslogtreecommitdiffstats
path: root/community/thunar-vcs-plugin
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2018-04-23 19:44:46 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2018-04-23 19:44:46 +0000
commit27d1e194717b1696b3169ad43df027876247b91a (patch)
tree8416dc507bc2aed5f47588d345abe1ef22a6c60f /community/thunar-vcs-plugin
parent0090cfe5db52bd764631d9b1d55e6e74c7cf2ae8 (diff)
downloadaports-27d1e194717b1696b3169ad43df027876247b91a.tar.bz2
aports-27d1e194717b1696b3169ad43df027876247b91a.tar.xz
main/{xfce*} => community/
Move everything xfce to community
Diffstat (limited to 'community/thunar-vcs-plugin')
-rw-r--r--community/thunar-vcs-plugin/APKBUILD75
1 files changed, 75 insertions, 0 deletions
diff --git a/community/thunar-vcs-plugin/APKBUILD b/community/thunar-vcs-plugin/APKBUILD
new file mode 100644
index 0000000000..a98afcea8f
--- /dev/null
+++ b/community/thunar-vcs-plugin/APKBUILD
@@ -0,0 +1,75 @@
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=thunar-vcs-plugin
+pkgver=0.1.4
+pkgrel=6
+pkgdesc="Version Contol System plugin for the Thunar filemanager"
+url="http://goodies.xfce.org/projects/thunar-plugins/thunar-vcs-plugin"
+arch="all"
+license="GPL-2.0-or-later"
+depends=
+makedepends="thunar-dev subversion-dev apr-dev util-linux-dev"
+install=""
+subpackages="$pkgname-git:_git $pkgname-svn:_svn $pkgname-lang"
+source="http://archive.xfce.org/src/thunar-plugins/thunar-vcs-plugin/0.1/thunar-vcs-plugin-$pkgver.tar.bz2"
+
+_builddir="$srcdir"/thunar-vcs-plugin-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ update_config_sub || return 1
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+ # quick and dirty fix for apr linking
+ sed -i -e 's/APR_LDFLAGS/APR_LIBS/' thunar-vcs-plugin/Makefile.in
+}
+
+build() {
+ cd "$_builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --libexecdir=/usr/lib/xfce4 \
+ --disable-static \
+ --enable-subversion \
+ --enable-git \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+_mv_files() {
+ local i
+ for i in "$@"; do
+ mkdir -p "$subpkgdir"/${i%/*}
+ mv "$pkgdir"/$i "$subpkgdir"/$i || return 1
+ done
+}
+
+_git() {
+ pkgdesc="Git support for thunar-vcs-plugin"
+ depends=
+ install_if="$pkgname=$pkgver-r$pkgrel git"
+ cd "$pkgdir"
+ _mv_files usr/lib/xfce4/tvp-git-helper \
+ usr/share/icons/hicolor/*/apps/git.png
+}
+
+_svn() {
+ pkgdesc="Subversion support for thunar-vcs-plugin"
+ depends=
+ install_if="$pkgname=$pkgver-r$pkgrel subversion"
+ cd "$pkgdir"
+ _mv_files usr/lib/xfce4/tvp-svn-helper \
+ usr/share/icons/hicolor/*/apps/subversion.png
+}
+
+sha512sums="037ca986ab9030146fc409d78d235a157b956b202449ef8e68de77dfce29ba2dd9a2dabc793215dd9ce455f97d8c5400ba51c8254b3c07b3e0d87572df672151 thunar-vcs-plugin-0.1.4.tar.bz2"