aboutsummaryrefslogtreecommitdiffstats
path: root/community/torsocks
diff options
context:
space:
mode:
authorScrumpyJack <scrumpyjack@st.ilet.to>2016-06-27 10:17:05 +0000
committerCarlo Landmeter <clandmeter@gmail.com>2016-07-04 11:42:28 +0200
commit2ff62bbb9f7b2c82a826d7b159c1bc482aa8f0bd (patch)
tree97c60fb3221dfe78cd7ccfda5db6125c81d5f676 /community/torsocks
parent00e8ff605f1c4f6386596f35f2a5287ff9b8bc55 (diff)
downloadaports-2ff62bbb9f7b2c82a826d7b159c1bc482aa8f0bd.tar.bz2
aports-2ff62bbb9f7b2c82a826d7b159c1bc482aa8f0bd.tar.xz
testing/[various]: move packages to community
Moves the packages listed below from the testing to the community repository after successfully testing of said packages. asciinema at calcurse cmus compton cpio dvd+rw-tools fortune fvwm geary h2o heirloom-mailx leafpad nedit nmh rover tor torsocks urlview vdesk w3m wbar xcalc xclock xeyes xkill
Diffstat (limited to 'community/torsocks')
-rw-r--r--community/torsocks/APKBUILD50
-rw-r--r--community/torsocks/musl-fix.patch84
2 files changed, 134 insertions, 0 deletions
diff --git a/community/torsocks/APKBUILD b/community/torsocks/APKBUILD
new file mode 100644
index 0000000000..e8c12601cd
--- /dev/null
+++ b/community/torsocks/APKBUILD
@@ -0,0 +1,50 @@
+# Maintainer: Christian Kampka <christian@kampka.net>
+pkgname=torsocks
+pkgver=2.1.0
+pkgrel=0
+pkgdesc="Wrapper to safely torify applications"
+url="https://gitweb.torproject.org/torsocks.git"
+arch="all"
+license="GPLv2"
+depends="tor"
+depends_dev=""
+makedepends="$depends_dev autoconf automake libtool"
+subpackages="$pkgname-doc"
+source="https://people.torproject.org/~dgoulet/${pkgname}/${pkgname}-${pkgver}.tar.bz2
+ musl-fix.patch
+"
+
+_builddir="${srcdir}/${pkgname}-${pkgver}"
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+md5sums="cced40ded9a0c7335050b778677fbd60 torsocks-2.1.0.tar.bz2
+e51d92eed27488e66e348fa3a1c0e11c musl-fix.patch"
+sha256sums="3c3831cb751ff477d97fb826c79cb2cfedc514e5eb89a3b10f341fb3abdf87db torsocks-2.1.0.tar.bz2
+e2298a13a5131d53c0bf878501a980880faff8b378ea250c9935522477e66b31 musl-fix.patch"
+sha512sums="bd273ce124abb288aea1d01eac773074c5e5bb7a363a7cb9957aac24ebcfdc647475dc9d90d5b189ac9537a84e3646e3cc50fa5a961c22fce38df93707e9b6a5 torsocks-2.1.0.tar.bz2
+df5c9d380d505aa42bd150614b48eb55e07a0b3af676886477153923a594c7cc475e467d64d2bd7780201f0c0f6bf9894cdbd7b3b15898c5cde8ba9166f6db3f musl-fix.patch"
diff --git a/community/torsocks/musl-fix.patch b/community/torsocks/musl-fix.patch
new file mode 100644
index 0000000000..a394aaea85
--- /dev/null
+++ b/community/torsocks/musl-fix.patch
@@ -0,0 +1,84 @@
+diff -u -r torsocks-2.1.0.orig/src/common/compat.c torsocks-2.1.0/src/common/compat.c
+--- torsocks-2.1.0.orig/src/common/compat.c 2015-12-06 19:44:47.251991190 +0100
++++ torsocks-2.1.0/src/common/compat.c 2015-12-06 19:44:58.871959984 +0100
+@@ -19,8 +19,6 @@
+
+ #include "compat.h"
+
+-#if (defined(__GLIBC__) || defined(__FreeBSD__) || defined(__darwin__) || defined(__NetBSD__))
+-
+ /*
+ * Initialize a pthread mutex. This never fails.
+ */
+@@ -95,5 +93,3 @@
+ }
+ tsocks_mutex_unlock(&o->mutex);
+ }
+-
+-#endif /* __GLIBC__, __darwin__, __FreeBSD__, __NetBSD__ */
+diff -u -r torsocks-2.1.0.orig/src/common/compat.h torsocks-2.1.0/src/common/compat.h
+--- torsocks-2.1.0.orig/src/common/compat.h 2015-12-06 19:44:47.251991190 +0100
++++ torsocks-2.1.0/src/common/compat.h 2015-12-06 19:44:51.538646345 +0100
+@@ -22,8 +22,6 @@
+ #define __darwin__ 1
+ #endif
+
+-#if (defined(__GLIBC__) || defined(__FreeBSD__) || defined(__darwin__) || defined(__NetBSD__))
+-
+ #define RTLD_NEXT ((void *) -1)
+
+ #include <pthread.h>
+@@ -53,10 +51,6 @@
+
+ void tsocks_once(tsocks_once_t *o, void (*init_routine)(void));
+
+-#else
+-#error "OS not supported."
+-#endif /* __GLIBC__, __darwin__, __FreeBSD__, __NetBSD__ */
+-
+ #if defined(__linux__)
+ #include <unistd.h>
+ #include <sys/syscall.h>
+diff -u -r torsocks-2.1.0.orig/src/common/ref.h torsocks-2.1.0/src/common/ref.h
+--- torsocks-2.1.0.orig/src/common/ref.h 2015-12-06 19:44:47.251991190 +0100
++++ torsocks-2.1.0/src/common/ref.h 2015-12-06 19:44:51.538646345 +0100
+@@ -26,8 +26,6 @@
+ long count;
+ };
+
+-#if (defined(__GLIBC__) || defined(__FreeBSD__) || defined(__darwin__) || defined(__NetBSD__))
+-
+ /*
+ * Get a reference by incrementing the refcount.
+ */
+@@ -55,8 +53,4 @@
+ }
+ }
+
+-#else
+-#error "OS not supported"
+-#endif /* __GLIBC__, __FreeBSD__, __darwin__ */
+-
+ #endif /* TORSOCKS_REF_H */
+diff -u -r torsocks-2.1.0.orig/src/lib/torsocks.h torsocks-2.1.0/src/lib/torsocks.h
+--- torsocks-2.1.0.orig/src/lib/torsocks.h 2015-12-06 19:44:47.251991190 +0100
++++ torsocks-2.1.0/src/lib/torsocks.h 2015-12-06 19:44:51.538646345 +0100
+@@ -33,8 +33,6 @@
+ #define TSOCKS_DECL(name, type, sig) \
+ extern type tsocks_##name(sig);
+
+-#if (defined(__GLIBC__) || defined(__FreeBSD__) || defined(__darwin__) || defined(__NetBSD__))
+-
+ /* connect(2) */
+ #include <sys/types.h>
+ #include <sys/socket.h>
+@@ -205,9 +203,6 @@
+ int sockfd, int backlog
+ #define LIBC_LISTEN_ARGS sockfd, backlog
+
+-#else
+-#error "OS not supported."
+-#endif /* __GLIBC__ , __FreeBSD__, __darwin__, __NetBSD__ */
+
+ #if (defined(__linux__))
+