aboutsummaryrefslogtreecommitdiffstats
path: root/community/unarj
diff options
context:
space:
mode:
authorRoberto Oliveira <robertoguimaraes8@gmail.com>2017-07-23 18:39:50 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2017-07-24 13:21:11 +0000
commit75fa2ebc2867ca3eb043024527f23330c666d254 (patch)
tree74ac4124d90ed229119112f73573ffd3baac1841 /community/unarj
parent0b1e3068cbe30dda2e0d9b8d2681ae7ff2b04882 (diff)
downloadaports-75fa2ebc2867ca3eb043024527f23330c666d254.tar.bz2
aports-75fa2ebc2867ca3eb043024527f23330c666d254.tar.xz
community/unarj: modernize APKBUILD
Diffstat (limited to 'community/unarj')
-rw-r--r--community/unarj/APKBUILD27
1 files changed, 5 insertions, 22 deletions
diff --git a/community/unarj/APKBUILD b/community/unarj/APKBUILD
index 0ca884ac4e..e03e216d6b 100644
--- a/community/unarj/APKBUILD
+++ b/community/unarj/APKBUILD
@@ -6,37 +6,20 @@ pkgdesc="Extracting, testing and viewing the contents of archives created with
url="http://www.arjsoftware.com"
arch="all"
license="custom"
-subpackages=""
-depends=""
-makedepends=""
-install=""
source="http://ibiblio.org/pub/Linux/utils/compress/$pkgname-$pkgver.tar.gz
format.patch"
-_builddir="$srcdir"/$pkgname-$pkgver
-prepare() {
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
- return 0
-}
+builddir="$srcdir"/$pkgname-$pkgver
build() {
- cd "$_builddir"
- make || return 1
+ cd "$builddir"
+ make
}
package() {
- cd "$_builddir"
- install -D -m755 unarj $pkgdir/usr/bin/unarj || return 1
+ cd "$builddir"
+ install -D -m755 unarj $pkgdir/usr/bin/unarj
}
-md5sums="a83d139c245f911f22cb1b611ec9768f unarj-2.63a.tar.gz
-b64f3a5cd4f023f5904e38d7cb3d07b0 format.patch"
-sha256sums="33f8297aa28911eb684ca83e9e00de04a360ea35603282d91de20aec4eb19a48 unarj-2.63a.tar.gz
-5ca423e7e3d505125c09843c624efe5735a178326ddc41e32c486bf8154c8a11 format.patch"
sha512sums="4f8aed311b8626f6bbefc7ad3296c1e69e8c89e79e4b853124502939ca83e2eb0352b64a5b71b2572e948a97a31416e678bc4ce30519631732001cfe7bb983d2 unarj-2.63a.tar.gz
078cb5f300bb1022589b6a79d0022a992e92baec0015af33d158a44e5c97970e7fa5e975c965cd0897c6da316a461a503dae7d310f89660271175285ba06a6ff format.patch"