aboutsummaryrefslogtreecommitdiffstats
path: root/community/upx
diff options
context:
space:
mode:
authorMitch Tishmack <mitch.tishmack@gmail.com>2017-06-18 12:37:29 -0500
committerTimo Teräs <timo.teras@iki.fi>2017-06-20 07:34:37 +0000
commit1c6163a8ec00b55fd7cbcd716c7c3fb6924481b7 (patch)
tree78b2b5ac9dd57a28b89d693dc507f41365605cdf /community/upx
parentdec8f6392429a85b5e229a8002628222c5e86bba (diff)
downloadaports-1c6163a8ec00b55fd7cbcd716c7c3fb6924481b7.tar.bz2
aports-1c6163a8ec00b55fd7cbcd716c7c3fb6924481b7.tar.xz
community/upx: moved from testing
Diffstat (limited to 'community/upx')
-rw-r--r--community/upx/0001-rm-broken-whitespace-check.patch16
-rw-r--r--community/upx/APKBUILD38
2 files changed, 54 insertions, 0 deletions
diff --git a/community/upx/0001-rm-broken-whitespace-check.patch b/community/upx/0001-rm-broken-whitespace-check.patch
new file mode 100644
index 0000000000..b245a4fb29
--- /dev/null
+++ b/community/upx/0001-rm-broken-whitespace-check.patch
@@ -0,0 +1,16 @@
+--- a/src/Makefile
++++ b/src/Makefile
+@@ -104,13 +104,6 @@
+ endif
+
+ CHECK_WHITESPACE =
+-ifeq ($(shell uname),Linux)
+-CHECK_WHITESPACE = $(top_srcdir)/src/stub/scripts/check_whitespace.sh $(top_srcdir)
+-ifneq ($(wildcard $(top_srcdir)/.git/.),)
+-CHECK_WHITESPACE = $(top_srcdir)/src/stub/scripts/check_whitespace_git.sh $(top_srcdir)
+-endif
+-check-whitespace : ; $(CHECK_WHITESPACE)
+-endif
+ .PHONY: check-whitespace
+
+ mostlyclean clean distclean maintainer-clean:
diff --git a/community/upx/APKBUILD b/community/upx/APKBUILD
new file mode 100644
index 0000000000..72f4424401
--- /dev/null
+++ b/community/upx/APKBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Mitch Tishmack <mitch.tishmack@gmail.com>
+# TODO: unbundle lzma-sdk
+pkgname=upx
+pkgver=3.94
+pkgrel=0
+pkgdesc="The Ultimate Packer for eXecutables"
+url="https://upx.github.io"
+arch="all"
+license="GPL2 public-domain"
+# perl-dev is used to generate man pages
+makedepends="bash perl-dev ucl-dev zlib-dev"
+subpackages="$pkgname-doc"
+source="https://github.com/upx/$pkgname/releases/download/v$pkgver/$pkgname-$pkgver-src.tar.xz
+ 0001-rm-broken-whitespace-check.patch"
+builddir="$srcdir/$pkgname-$pkgver-src"
+
+prepare() {
+ default_prepare || return 1
+
+ cd "$builddir"
+ sed -i 's/ -O2/ /' src/Makefile
+}
+
+build() {
+ cd "$builddir"
+
+ make UPX_LZMADIR="$srcdir" all
+}
+
+package() {
+ cd "$builddir"
+
+ install -D -m 0755 src/upx.out "$pkgdir"/usr/bin/upx
+ install -D -m 0644 doc/upx.1 "$pkgdir"/usr/share/man/man1/upx.1
+}
+
+sha512sums="b9e8e6e13b2a267a30a9c4e572243c4ebeff9600044193de38c84e8943e3cd30c9cdd7b270cc0bdf14c1078ac15250906238f8272cd97a7eb40f2588965c6151 upx-3.94-src.tar.xz
+a41dd8b8e9e884c78c410a49b4486963f6dd90759ba49eb05123e81b8e4fbe3d23af2ba5c2acf64218b7edeec7df0793b4030d1375c167a183a4d70d21addf50 0001-rm-broken-whitespace-check.patch"