aboutsummaryrefslogtreecommitdiffstats
path: root/community/vorbis-tools
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2016-08-24 16:12:13 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2016-08-24 16:12:13 +0000
commitf4cd16190abf6e474236aa2912ba677babac1ee2 (patch)
treef73d08e2f5fd3b3ddaf0f63937460a457251a8a7 /community/vorbis-tools
parent2cee3eb7292fdb00d80899eecd615785e1d30184 (diff)
downloadaports-f4cd16190abf6e474236aa2912ba677babac1ee2.tar.bz2
aports-f4cd16190abf6e474236aa2912ba677babac1ee2.tar.xz
community/vorbis-tools: moved from testing
Diffstat (limited to 'community/vorbis-tools')
-rw-r--r--community/vorbis-tools/APKBUILD51
-rw-r--r--community/vorbis-tools/vorbis-tools-CVE-2015-6749.patch41
-rw-r--r--community/vorbis-tools/vorbis-tools-cve9638-cve9639.patch77
-rw-r--r--community/vorbis-tools/vorbis-tools-cve9640.patch29
4 files changed, 198 insertions, 0 deletions
diff --git a/community/vorbis-tools/APKBUILD b/community/vorbis-tools/APKBUILD
new file mode 100644
index 0000000000..32f46107cb
--- /dev/null
+++ b/community/vorbis-tools/APKBUILD
@@ -0,0 +1,51 @@
+# Contributor: Francesco Colista <fcolista@alpinelinux.org>
+# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
+pkgname=vorbis-tools
+pkgver=1.4.0
+pkgrel=0
+pkgdesc="Extra tools for Ogg-Vorbis"
+url="http://www.xiph.org/vorbis/"
+arch="all"
+license="GPL2"
+depends=""
+makedepends="curl-dev flac-dev libvorbis-dev libao-dev speex-dev"
+install=""
+subpackages="$pkgname-doc $pkgname-lang"
+source="http://downloads.xiph.org/releases/vorbis/$pkgname-$pkgver.tar.gz
+ vorbis-tools-CVE-2015-6749.patch
+ vorbis-tools-cve9638-cve9639.patch
+ vorbis-tools-cve9640.patch"
+
+builddir="$srcdir"/$pkgname-$pkgver
+
+prepare() {
+ default_prepare || return 1
+ update_config_guess || return 1
+}
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --prefix=/usr \
+ --enable-vcut
+ make || return 1
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+ rm "$pkgdir"/usr/lib/charset.alias
+}
+
+md5sums="567e0fb8d321b2cd7124f8208b8b90e6 vorbis-tools-1.4.0.tar.gz
+8ec105f0c7d0aeac783d5e6425e556aa vorbis-tools-CVE-2015-6749.patch
+e24cf979e33fbce4e62091f2576c6012 vorbis-tools-cve9638-cve9639.patch
+3ee3a1f9a738766d7e94e38925f4a336 vorbis-tools-cve9640.patch"
+sha256sums="a389395baa43f8e5a796c99daf62397e435a7e73531c9f44d9084055a05d22bc vorbis-tools-1.4.0.tar.gz
+52f1d083c16b9caa2bc7bd5315210bac810dd6a0565e4c270650177a4c815fa7 vorbis-tools-CVE-2015-6749.patch
+5a6d74de56e67613c4887e3fe9102aadfce4cd4a9a477fb2c1ed1a26f11fdff6 vorbis-tools-cve9638-cve9639.patch
+d4030b23a6a5017083aecd266c475198eebcdc48fd6bed3d8739cda031c10fa8 vorbis-tools-cve9640.patch"
+sha512sums="d2473f2e8e6726b5a5083f567797ae42bbb7fa3f26aec3f7b83e641e028c64726299f71a9d75258595a53cf29c18acb84841bcbc39509258d2c8df859e4e3b99 vorbis-tools-1.4.0.tar.gz
+c1faa062e7035770db533383ebb3ae18efaf167f7a103c12cef81418da4be43545e368eab2915c243c03354c3bf0b8dbb198da90e7eaa59c8e00f1461c65b601 vorbis-tools-CVE-2015-6749.patch
+bcf5ae147de547f6463f3000e06398a8b4db326b44eab02bf314ca8ae3b90c45bd25481fb76ccbf39d9a2798a6c9fadb48600f393b6436f01f95ce2a20c04fe8 vorbis-tools-cve9638-cve9639.patch
+3bb8a50309f2657a99662039818040abf345d540915543cf35c3e5855d865fd33bf4bbaf296882662e6b11570199a054c7d34cfdd44ef69f9d3c9f45f4d8671f vorbis-tools-cve9640.patch"
diff --git a/community/vorbis-tools/vorbis-tools-CVE-2015-6749.patch b/community/vorbis-tools/vorbis-tools-CVE-2015-6749.patch
new file mode 100644
index 0000000000..78e3c810e6
--- /dev/null
+++ b/community/vorbis-tools/vorbis-tools-CVE-2015-6749.patch
@@ -0,0 +1,41 @@
+From 04815d3e1bfae3a6cdfb2c25358a5a72b61299f7 Mon Sep 17 00:00:00 2001
+From: Mark Harris <mark.hsj@gmail.com>
+Date: Sun, 30 Aug 2015 05:54:46 -0700
+Subject: [PATCH] oggenc: Fix large alloca on bad AIFF input
+
+Fixes #2212
+---
+ oggenc/audio.c | 10 +++++-----
+ 1 file changed, 5 insertions(+), 5 deletions(-)
+
+diff --git a/oggenc/audio.c b/oggenc/audio.c
+index 477da8c..4921fb9 100644
+--- a/oggenc/audio.c
++++ b/oggenc/audio.c
+@@ -245,8 +245,8 @@ static int aiff_permute_matrix[6][6] =
+ int aiff_open(FILE *in, oe_enc_opt *opt, unsigned char *buf, int buflen)
+ {
+ int aifc; /* AIFC or AIFF? */
+- unsigned int len;
+- unsigned char *buffer;
++ unsigned int len, readlen;
++ unsigned char buffer[22];
+ unsigned char buf2[8];
+ aiff_fmt format;
+ aifffile *aiff = malloc(sizeof(aifffile));
+@@ -269,9 +269,9 @@ int aiff_open(FILE *in, oe_enc_opt *opt, unsigned char *buf, int buflen)
+ return 0; /* Weird common chunk */
+ }
+
+- buffer = alloca(len);
+-
+- if(fread(buffer,1,len,in) < len)
++ readlen = len < sizeof(buffer) ? len : sizeof(buffer);
++ if(fread(buffer,1,readlen,in) < readlen ||
++ (len > readlen && !seek_forward(in, len-readlen)))
+ {
+ fprintf(stderr, _("Warning: Unexpected EOF in reading AIFF header\n"));
+ return 0;
+--
+2.5.0
+
diff --git a/community/vorbis-tools/vorbis-tools-cve9638-cve9639.patch b/community/vorbis-tools/vorbis-tools-cve9638-cve9639.patch
new file mode 100644
index 0000000000..80238b7412
--- /dev/null
+++ b/community/vorbis-tools/vorbis-tools-cve9638-cve9639.patch
@@ -0,0 +1,77 @@
+... in order to prevent a division by zero (CVE-2014-9638) and integer
+overflow (CVE-2014-9639).
+
+Bug: https://trac.xiph.org/ticket/2136
+Bug: https://trac.xiph.org/ticket/2137
+---
+ oggenc/audio.c | 19 +++++++++++++++++--
+ 1 file changed, 17 insertions(+), 2 deletions(-)
+
+diff --git a/oggenc/audio.c b/oggenc/audio.c
+index 477da8c..1167f1b 100644
+--- a/oggenc/audio.c
++++ b/oggenc/audio.c
+@@ -13,6 +13,7 @@
+ #include <config.h>
+ #endif
+
++#include <limits.h>
+ #include <stdlib.h>
+ #include <stdio.h>
+ #include <string.h>
+@@ -251,6 +252,7 @@ int aiff_open(FILE *in, oe_enc_opt *opt, unsigned char *buf, int buflen)
+ aiff_fmt format;
+ aifffile *aiff = malloc(sizeof(aifffile));
+ int i;
++ long channels;
+
+ if(buf[11]=='C')
+ aifc=1;
+@@ -277,11 +279,17 @@ int aiff_open(FILE *in, oe_enc_opt *opt, unsigned char *buf, int buflen)
+ return 0;
+ }
+
+- format.channels = READ_U16_BE(buffer);
++ format.channels = channels = READ_U16_BE(buffer);
+ format.totalframes = READ_U32_BE(buffer+2);
+ format.samplesize = READ_U16_BE(buffer+6);
+ format.rate = (int)read_IEEE80(buffer+8);
+
++ if(channels <= 0L || SHRT_MAX < channels)
++ {
++ fprintf(stderr, _("Warning: Unsupported count of channels in AIFF header\n"));
++ return 0;
++ }
++
+ aiff->bigendian = 1;
+
+ if(aifc)
+@@ -416,6 +424,7 @@ int wav_open(FILE *in, oe_enc_opt *opt, unsigned char *oldbuf, int buflen)
+ wav_fmt format;
+ wavfile *wav = malloc(sizeof(wavfile));
+ int i;
++ long channels;
+
+ /* Ok. At this point, we know we have a WAV file. Now we have to detect
+ * whether we support the subtype, and we have to find the actual data
+@@ -453,12 +462,18 @@ int wav_open(FILE *in, oe_enc_opt *opt, unsigned char *oldbuf, int buflen)
+ }
+
+ format.format = READ_U16_LE(buf);
+- format.channels = READ_U16_LE(buf+2);
++ format.channels = channels = READ_U16_LE(buf+2);
+ format.samplerate = READ_U32_LE(buf+4);
+ format.bytespersec = READ_U32_LE(buf+8);
+ format.align = READ_U16_LE(buf+12);
+ format.samplesize = READ_U16_LE(buf+14);
+
++ if(channels <= 0L || SHRT_MAX < channels)
++ {
++ fprintf(stderr, _("Warning: Unsupported count of channels in WAV header\n"));
++ return 0;
++ }
++
+ if(format.format == -2) /* WAVE_FORMAT_EXTENSIBLE */
+ {
+ if(len<40)
+--
diff --git a/community/vorbis-tools/vorbis-tools-cve9640.patch b/community/vorbis-tools/vorbis-tools-cve9640.patch
new file mode 100644
index 0000000000..97d18e0db7
--- /dev/null
+++ b/community/vorbis-tools/vorbis-tools-cve9640.patch
@@ -0,0 +1,29 @@
+Index: vorbis-tools/oggenc/oggenc.c
+===================================================================
+--- vorbis-tools/oggenc/oggenc.c (revision 19116)
++++ vorbis-tools/oggenc/oggenc.c (revision 19117)
+@@ -98,4 +98,6 @@
+ 0,0,0.f,
+ 0, 0, 0, 0, 0};
++ input_format raw_format = {NULL, 0, raw_open, wav_close, "raw",
++ N_("RAW file reader")};
+
+ int i;
+@@ -240,6 +242,4 @@
+ if(opt.rawmode)
+ {
+- input_format raw_format = {NULL, 0, raw_open, wav_close, "raw",
+- N_("RAW file reader")};
+
+ enc_opts.rate=opt.raw_samplerate;
+Index: vorbis-tools/oggenc/skeleton.h
+===================================================================
+--- vorbis-tools/oggenc/skeleton.h (revision 19116)
++++ vorbis-tools/oggenc/skeleton.h (revision 19117)
+@@ -42,5 +42,5 @@
+ ogg_int64_t start_granule; /* start granule value */
+ ogg_uint32_t preroll; /* preroll */
+- unsigned char granule_shift; // a 8-bit field /* 1 byte value holding the granule shift */
++ unsigned char granule_shift; /* 1 byte value holding the granule shift */
+ char *message_header_fields; /* holds all the message header fields */
+ /* current total size of the message header fields, for realloc purpose, initially zero */