aboutsummaryrefslogtreecommitdiffstats
path: root/community/w3m
diff options
context:
space:
mode:
authorDaniel Sabogal <dsabogalcc@gmail.com>2018-02-03 19:18:09 -0500
committerDaniel Sabogal <dsabogalcc@gmail.com>2018-02-03 19:21:25 -0500
commitd1ee0e35c7f16cff46b6d64b4667d9cc38842051 (patch)
tree47e80f69fb8b3872013d246a9a9369bb0c15a80c /community/w3m
parent9ad9db36d1eea73fa311b03717bc6c249301b591 (diff)
downloadaports-d1ee0e35c7f16cff46b6d64b4667d9cc38842051.tar.bz2
aports-d1ee0e35c7f16cff46b6d64b4667d9cc38842051.tar.xz
community/w3m: upgrade to 0.5.3+git20180125
Diffstat (limited to 'community/w3m')
-rw-r--r--community/w3m/APKBUILD30
1 files changed, 17 insertions, 13 deletions
diff --git a/community/w3m/APKBUILD b/community/w3m/APKBUILD
index cd3c0dcffb..2d7900e924 100644
--- a/community/w3m/APKBUILD
+++ b/community/w3m/APKBUILD
@@ -1,11 +1,10 @@
# Contributor: ScrumpyJack <scrumpyjack@st.ilet.to>
# Maintainer: ScrumpyJack <scrumpyjack@st.ilet.to>
pkgname=w3m
-_pkgver=0.5.3+git20161120
+_pkgver=0.5.3+git20180125
pkgver=${_pkgver/+git/.}
-pkgrel=2
+pkgrel=0
pkgdesc='Text-based Web browser, as well as pager'
-# http://w3m.sourceforge.net/
url='https://github.com/tats/w3m'
license='MIT UCD'
arch='all'
@@ -15,6 +14,12 @@ source="$pkgname-$pkgver.tar.gz::https://github.com/tats/$pkgname/archive/v$_pkg
https.patch"
builddir="$srcdir/$pkgname-${_pkgver/+/-}"
+# secfixes:
+# 0.5.3.20180125-r0:
+# - CVE-2018-6196
+# - CVE-2018-6197
+# - CVE-2018-6198
+
build() {
cd "$builddir"
./configure \
@@ -28,28 +33,27 @@ build() {
--with-imagelib=imlib2 \
--with-termlib=ncurses \
--disable-w3mmailer \
- --disable-mouse \
- || return 1
+ --disable-mouse
make -j1
}
+check() {
+ cd "$builddir"
+ ./w3m -version
+}
+
package() {
cd "$builddir"
- make DESTDIR="$pkgdir" install || return 1
+ make DESTDIR="$pkgdir" install
install -d "$pkgdir"/usr/share/doc/"$pkgname"
install -d "$pkgdir"/usr/share/licenses/"$pkgname"
local i; for i in doc/*; do
- install -m644 "$i" \
- "$pkgdir"/usr/share/doc/"$pkgname" || return 1
+ install -m644 "$i" "$pkgdir"/usr/share/doc/"$pkgname"
done
ln -s /usr/share/doc/"$pkgname"/README \
"$pkgdir"/usr/share/licenses/"$pkgname"
}
-md5sums="5c53b7744ec5a89c8bf26325bf0f1541 w3m-0.5.3.20161120.tar.gz
-a5e1038b5fb36ac1465700433ae00d0b https.patch"
-sha256sums="62a5b066aaf5e23afec6decd962b966f333352150f8072193cba98320676f060 w3m-0.5.3.20161120.tar.gz
-ab8f2b6c7e1cf2d8485fa9928784c8dbd2f0d8cd26a5c32384543eea173de986 https.patch"
-sha512sums="81ecf9e5d9067a82efa5464e5f9396327a6333f9e414458a972b2b7bff138bd17c490b5258e34cb1e338c7a6c0dd6105a1bfd1e0d02edfadead79caa39106a5c w3m-0.5.3.20161120.tar.gz
+sha512sums="61b8498b927569937c509460e291eeba6eb302d34ccd6e1bf4d1eb07ac73a3ac5a477161727d310324625be04b907f8c3e970382d08c9fa0846b371699f04e14 w3m-0.5.3.20180125.tar.gz
3844b3a079524ad403da7fe03461210a433ff1cd562862c4df55c3be250ccba0c34eb61bcc8df1973d70e2ef034edaf1804bb2fa682b01723322f108f523932a https.patch"