aboutsummaryrefslogtreecommitdiffstats
path: root/community/wait4ports
diff options
context:
space:
mode:
authorErik Ogan <erik@ogan.net>2018-09-01 20:10:45 -0700
committerNatanael Copa <ncopa@alpinelinux.org>2018-09-04 10:10:36 +0000
commit40dbc07c3cd450edd86fef7e1d181d734a1889c8 (patch)
tree1bf385767a6ae26767a047600227b6d3fdc09fe7 /community/wait4ports
parentca6cac1db76409a8446b50cb990a1cc03af9c21d (diff)
downloadaports-40dbc07c3cd450edd86fef7e1d181d734a1889c8.tar.bz2
aports-40dbc07c3cd450edd86fef7e1d181d734a1889c8.tar.xz
community/wait4ports: upgrade to 0.2.2
Adds: * IPv6 support * Hostname resolution (necessary for docker-compose > v1) * Verbosity and sleep interval configuration via environment and command-line
Diffstat (limited to 'community/wait4ports')
-rw-r--r--community/wait4ports/APKBUILD14
1 files changed, 8 insertions, 6 deletions
diff --git a/community/wait4ports/APKBUILD b/community/wait4ports/APKBUILD
index cd4bbe0eb5..fbfc250b24 100644
--- a/community/wait4ports/APKBUILD
+++ b/community/wait4ports/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Erik Ogan <erik@stealthymonkeys.com>
# Maintainer: Erik Ogan <erik@stealthymonkeys.com>
pkgname=wait4ports
-pkgver=0.0.4
+pkgver=0.2.2
pkgrel=0
pkgdesc="A small utility to wait for network peer availability."
url="https://github.com/erikogan/wait4ports"
@@ -15,14 +15,16 @@ builddir="$srcdir/$pkgname-$pkgver"
build() {
cd "$builddir"
- make || return 1
+ make
}
package() {
cd "$builddir"
- make PREFIX="$pkgdir" install || return 1
+ make PREFIX="$pkgdir" install
}
-md5sums="540262422fc204037bb2315bcfb438e5 wait4ports-0.0.4.tar.gz"
-sha256sums="c94789f1c353c87d0a14fea88ef565cef8807bde2903e5020565f86c656e2597 wait4ports-0.0.4.tar.gz"
-sha512sums="a3f0df9fcfde0c49626327f19a5ba71d8c59311f04a874f3470d92503d577a4eedcc46f4432ddf9386b966ce5bee522f3c9a2c4d88b037ffd0caf7022358a461 wait4ports-0.0.4.tar.gz"
+check() {
+ $builddir/wait4ports -v
+}
+
+sha512sums="a375bd8b7a4d1523221e227d726c1672413627ca485a3279bce21186e958c989de6b99584ffa173ff804484e23f29c18fae5e5d2c088efbd5bbeffb1eeb5a824 wait4ports-0.2.2.tar.gz"