aboutsummaryrefslogtreecommitdiffstats
path: root/community/webkit2gtk
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2018-09-27 10:36:36 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2018-09-27 10:37:24 +0000
commit609fbb0235cf6440f5d502885c4e0531c835aed7 (patch)
treef33a0a723bba05aeb8c1df2946d51166547fb989 /community/webkit2gtk
parentbb3bc00f304cb4f0611d45555d124221d365bdce (diff)
downloadaports-609fbb0235cf6440f5d502885c4e0531c835aed7.tar.bz2
aports-609fbb0235cf6440f5d502885c4e0531c835aed7.tar.xz
community/webkit2gtk: upgrade to 2.22.2
fixes #9473 fixes #9452
Diffstat (limited to 'community/webkit2gtk')
-rw-r--r--community/webkit2gtk/APKBUILD10
-rw-r--r--community/webkit2gtk/musl-fixes.patch (renamed from community/webkit2gtk/musl-fix-javascriptcore.patch)75
2 files changed, 44 insertions, 41 deletions
diff --git a/community/webkit2gtk/APKBUILD b/community/webkit2gtk/APKBUILD
index af0f381faf..defd0ce311 100644
--- a/community/webkit2gtk/APKBUILD
+++ b/community/webkit2gtk/APKBUILD
@@ -2,8 +2,8 @@
# Contributor: Jiri Horner <laeqten@gmail.com>
# Maintainer: Jiri Horner <laeqten@gmail.com>
pkgname=webkit2gtk
-pkgver=2.20.3
-pkgrel=1
+pkgver=2.22.2
+pkgrel=0
pkgdesc="Portable web rendering engine WebKit for GTK+"
url="https://webkitgtk.org/"
arch="all"
@@ -45,7 +45,7 @@ subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
source="https://webkitgtk.org/releases/webkitgtk-$pkgver.tar.xz
fix-fast-memory-disabled.patch
fix_armv6l.patch
- musl-fix-javascriptcore.patch
+ musl-fixes.patch
"
builddir="$srcdir/webkitgtk-$pkgver"
@@ -111,7 +111,7 @@ package() {
paxmark -m "$pkgdir"/usr/lib/webkit2gtk-4.0/WebKitWebProcess
}
-sha512sums="69a7b27e294de6fd43240ce1d314cd1ccdbf29674c97967674459fd02720b31fa53e5412efbd93dc1e805d38e38feb7fe9a12cdd9c472471676b8db3c11734de webkitgtk-2.20.3.tar.xz
+sha512sums="0bb885726872f128a0e0d71cbc75ba076e5c0c928c40e71e030c87444a7068568c568587514407d6549c27d0bfe121dc33f96f0c516d2ae1c6801e005ad52756 webkitgtk-2.22.2.tar.xz
9d7de4755c21d2573103dde326bb86ba37d54032627cb1bd362138906ac1d6a1dc48d4e548f29e29dc507831bae833ac5a8d2cf7fdb3d6a9d5bd5fb06f222b00 fix-fast-memory-disabled.patch
f8fad1450d87f1cb195818cddb8a2307616916612e4676a4d71a20d58864d1c153550e4465a128e04f136c437518a4b90f1fa685ef6519fa8054637760635c72 fix_armv6l.patch
-73b8edae6b8f7f989f74b932214ccc405f0a2459c3abcdfa410ef7438308a2d9fa3057319a3e48a0e6768d6144ed00744a8f2b39b8ef83dd2b77b516bea3a1ba musl-fix-javascriptcore.patch"
+922957ae400853bcfd5bff2c4e5b98a8351227a0b3b759dc34913ea5c8437e852899467a293cd2fb7a67f65022c4e99506f2be3c54fbcd74f038eb98ac02189e musl-fixes.patch"
diff --git a/community/webkit2gtk/musl-fix-javascriptcore.patch b/community/webkit2gtk/musl-fixes.patch
index 34a93af779..b5fd0bbbf1 100644
--- a/community/webkit2gtk/musl-fix-javascriptcore.patch
+++ b/community/webkit2gtk/musl-fixes.patch
@@ -1,59 +1,57 @@
-Fixes JavaScriptCore on musl platforms, taken and reformatted from the Gentoo
-musl overlay:
-
-https://gitweb.gentoo.org/proj/musl.git/tree/net-libs/webkit-gtk/files/webkit-gtk-2.18.1-musl.patch
-
+diff --git a/Source/JavaScriptCore/runtime/MachineContext.h b/Source/JavaScriptCore/runtime/MachineContext.h
+index 836d755..4a0518a 100644
--- a/Source/JavaScriptCore/runtime/MachineContext.h
+++ b/Source/JavaScriptCore/runtime/MachineContext.h
-@@ -146,7 +146,7 @@ inline void*& stackPointer(mcontext_t& machineContext)
+@@ -188,7 +188,7 @@ static inline void*& stackPointerImpl(mcontext_t& machineContext)
#error Unknown Architecture
#endif
--#elif defined(__GLIBC__) || defined(__BIONIC__)
-+#elif defined(__linux__)
+-#elif OS(FUCHSIA) || defined(__GLIBC__) || defined(__BIONIC__)
++#elif OS(FUCHSIA) || defined(__linux__)
#if CPU(X86)
return reinterpret_cast<void*&>((uintptr_t&) machineContext.gregs[REG_ESP]);
-@@ -251,7 +251,7 @@ inline void*& framePointer(mcontext_t& machineContext)
+@@ -335,7 +335,7 @@ static inline void*& framePointerImpl(mcontext_t& machineContext)
#error Unknown Architecture
#endif
--#elif defined(__GLIBC__) || defined(__BIONIC__)
-+#elif defined(__linux__)
+-#elif OS(FUCHSIA) || defined(__GLIBC__) || defined(__BIONIC__)
++#elif OS(FUCHSIA) || defined(__linux__)
// The following sequence depends on glibc's sys/ucontext.h.
#if CPU(X86)
-@@ -354,7 +354,7 @@ inline void*& instructionPointer(mcontext_t& machineContext)
+@@ -482,7 +482,7 @@ static inline void*& instructionPointerImpl(mcontext_t& machineContext)
#error Unknown Architecture
#endif
--#elif defined(__GLIBC__) || defined(__BIONIC__)
-+#elif defined(__linux__)
+-#elif OS(FUCHSIA) || defined(__GLIBC__) || defined(__BIONIC__)
++#elif OS(FUCHSIA) || defined(__linux__)
// The following sequence depends on glibc's sys/ucontext.h.
#if CPU(X86)
-@@ -466,7 +466,7 @@ inline void*& argumentPointer<1>(mcontext_t& machineContext)
+@@ -639,7 +639,7 @@ inline void*& argumentPointer<1>(mcontext_t& machineContext)
#error Unknown Architecture
#endif
--#elif defined(__GLIBC__) || defined(__BIONIC__)
-+#elif defined(__linux__)
+-#elif OS(FUCHSIA) || defined(__GLIBC__) || defined(__BIONIC__)
++#elif OS(FUCHSIA) || defined(__linux__)
// The following sequence depends on glibc's sys/ucontext.h.
#if CPU(X86)
-@@ -583,7 +583,7 @@ inline void*& llintInstructionPointer(mcontext_t& machineContext)
+@@ -756,7 +756,7 @@ inline void*& llintInstructionPointer(mcontext_t& machineContext)
#error Unknown Architecture
#endif
--#elif defined(__GLIBC__) || defined(__BIONIC__)
-+#elif defined(__linux__)
+-#elif OS(FUCHSIA) || defined(__GLIBC__) || defined(__BIONIC__)
++#elif OS(FUCHSIA) || defined(__linux__)
// The following sequence depends on glibc's sys/ucontext.h.
#if CPU(X86)
-
+diff --git a/Source/JavaScriptCore/runtime/Options.h b/Source/JavaScriptCore/runtime/Options.h
+index 27396d2..23a7b9e 100644
--- a/Source/JavaScriptCore/runtime/Options.h
+++ b/Source/JavaScriptCore/runtime/Options.h
-@@ -126,9 +126,9 @@
+@@ -144,9 +144,9 @@ constexpr bool enableWebAssemblyStreamingApi = false;
\
v(bool, reportMustSucceedExecutableAllocations, false, Normal, nullptr) \
\
@@ -66,10 +64,11 @@ https://gitweb.gentoo.org/proj/musl.git/tree/net-libs/webkit-gtk/files/webkit-gt
\
v(bool, crashIfCantAllocateJITMemory, false, Normal, nullptr) \
v(unsigned, jitMemoryReservationSize, 0, Normal, "Set this number to change the executable allocation size in ExecutableAllocatorFixedVMPool. (In bytes.)") \
-
+diff --git a/Source/ThirdParty/ANGLE/src/compiler/preprocessor/ExpressionParser.cpp b/Source/ThirdParty/ANGLE/src/compiler/preprocessor/ExpressionParser.cpp
+index c0f8b9c..1074cce 100644
--- a/Source/ThirdParty/ANGLE/src/compiler/preprocessor/ExpressionParser.cpp
+++ b/Source/ThirdParty/ANGLE/src/compiler/preprocessor/ExpressionParser.cpp
-@@ -836,7 +836,7 @@
+@@ -836,7 +836,7 @@ int yydebug;
#if YYERROR_VERBOSE
# ifndef yystrlen
@@ -78,7 +77,7 @@ https://gitweb.gentoo.org/proj/musl.git/tree/net-libs/webkit-gtk/files/webkit-gt
# define yystrlen strlen
# else
/* Return the length of YYSTR. */
-@@ -852,7 +852,7 @@
+@@ -852,7 +852,7 @@ yystrlen (const char *yystr)
# endif
# ifndef yystpcpy
@@ -87,10 +86,11 @@ https://gitweb.gentoo.org/proj/musl.git/tree/net-libs/webkit-gtk/files/webkit-gt
# define yystpcpy stpcpy
# else
/* Copy YYSRC to YYDEST, returning the address of the terminating '\0' in
-
+diff --git a/Source/ThirdParty/ANGLE/src/compiler/translator/glslang_tab.cpp b/Source/ThirdParty/ANGLE/src/compiler/translator/glslang_tab.cpp
+index 14cd536..6084d64 100644
--- a/Source/ThirdParty/ANGLE/src/compiler/translator/glslang_tab.cpp
+++ b/Source/ThirdParty/ANGLE/src/compiler/translator/glslang_tab.cpp
-@@ -1975,7 +1975,7 @@
+@@ -1975,7 +1975,7 @@ int yydebug;
#if YYERROR_VERBOSE
# ifndef yystrlen
@@ -99,7 +99,7 @@ https://gitweb.gentoo.org/proj/musl.git/tree/net-libs/webkit-gtk/files/webkit-gt
# define yystrlen strlen
# else
/* Return the length of YYSTR. */
-@@ -1991,7 +1991,7 @@
+@@ -1991,7 +1991,7 @@ yystrlen (const char *yystr)
# endif
# ifndef yystpcpy
@@ -108,21 +108,24 @@ https://gitweb.gentoo.org/proj/musl.git/tree/net-libs/webkit-gtk/files/webkit-gt
# define yystpcpy stpcpy
# else
/* Copy YYSRC to YYDEST, returning the address of the terminating '\0' in
-
+diff --git a/Source/WTF/wtf/Platform.h b/Source/WTF/wtf/Platform.h
+index 67cfa93..341a9f5 100644
--- a/Source/WTF/wtf/Platform.h
+++ b/Source/WTF/wtf/Platform.h
-@@ -679,7 +679,7 @@
+@@ -697,7 +697,7 @@
#define HAVE_CFNETWORK_STORAGE_PARTITIONING 1
#endif
--#if OS(DARWIN) || ((OS(FREEBSD) || defined(__GLIBC__) || defined(__BIONIC__)) && (CPU(X86) || CPU(X86_64) || CPU(ARM) || CPU(ARM64) || CPU(MIPS)))
-+#if OS(DARWIN) || ((OS(FREEBSD) || defined(__linux__)) && (CPU(X86) || CPU(X86_64) || CPU(ARM) || CPU(ARM64) || CPU(MIPS)))
+-#if OS(DARWIN) || OS(FUCHSIA) || ((OS(FREEBSD) || defined(__GLIBC__) || defined(__BIONIC__)) && (CPU(X86) || CPU(X86_64) || CPU(ARM) || CPU(ARM64) || CPU(MIPS)))
++#if OS(DARWIN) || OS(FUCHSIA) || ((OS(FREEBSD) || defined(__linux__)) && (CPU(X86) || CPU(X86_64) || CPU(ARM) || CPU(ARM64) || CPU(MIPS)))
#define HAVE_MACHINE_CONTEXT 1
#endif
-
+
+diff --git a/Source/WebCore/xml/XPathGrammar.cpp b/Source/WebCore/xml/XPathGrammar.cpp
+index 31df1c0..bc569c1 100644
--- a/Source/WebCore/xml/XPathGrammar.cpp
+++ b/Source/WebCore/xml/XPathGrammar.cpp
-@@ -967,7 +967,7 @@
+@@ -966,7 +966,7 @@ int yydebug;
#if YYERROR_VERBOSE
# ifndef yystrlen
@@ -131,7 +134,7 @@ https://gitweb.gentoo.org/proj/musl.git/tree/net-libs/webkit-gtk/files/webkit-gt
# define yystrlen strlen
# else
/* Return the length of YYSTR. */
-@@ -990,7 +990,7 @@
+@@ -989,7 +989,7 @@ yystrlen (yystr)
# endif
# ifndef yystpcpy
@@ -139,4 +142,4 @@ https://gitweb.gentoo.org/proj/musl.git/tree/net-libs/webkit-gtk/files/webkit-gt
+# if defined __linux__ && defined _STRING_H && defined _GNU_SOURCE
# define yystpcpy stpcpy
# else
- /* Copy YYSRC to YYDEST, returning the address of the terminating '\0' in
+ /* Copy YYSRC to YYDEST, returning the address of the terminating '\0' in