aboutsummaryrefslogtreecommitdiffstats
path: root/community/xapian-core
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2016-11-01 06:25:24 +0000
committerTimo Teräs <timo.teras@iki.fi>2016-11-01 06:25:24 +0000
commit1978b648be9378b50268ecc2535ea76a35d99a7c (patch)
tree5f15400e40bc10964a48577b29e8ad548ede2c9f /community/xapian-core
parent44c3a3f6c1325a9d1e6c1fd31102e3dc93fa193b (diff)
downloadaports-1978b648be9378b50268ecc2535ea76a35d99a7c.tar.bz2
aports-1978b648be9378b50268ecc2535ea76a35d99a7c.tar.xz
community/xapian-core: simplify apkbuild
no packaging changes.
Diffstat (limited to 'community/xapian-core')
-rw-r--r--community/xapian-core/APKBUILD25
1 files changed, 8 insertions, 17 deletions
diff --git a/community/xapian-core/APKBUILD b/community/xapian-core/APKBUILD
index 8fa478a827..1f65b95f08 100644
--- a/community/xapian-core/APKBUILD
+++ b/community/xapian-core/APKBUILD
@@ -15,34 +15,25 @@ subpackages="$pkgname-dev $pkgname-doc libxapian"
source="http://oligarchy.co.uk/xapian/$pkgver/$pkgname-$pkgver.tar.xz
timeval-t.patch"
-_builddir="$srcdir"/$pkgname-$pkgver
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
+builddir="$srcdir"/$pkgname-$pkgver
build() {
- cd "$_builddir"
+ cd "$builddir"
./configure --prefix=/usr || return 1
make || return 1
}
package() {
- cd "$_builddir"
+ cd "$builddir"
make DESTDIR="$pkgdir" install || return 1
}
libxapian() {
- arch="all"
- cd "$_builddir"
- pkgdesc="Xapian search engine library"
- install -d "$subpkgdir"/usr/lib
- mv "$pkgdir"/usr/lib/$subpkgname* "$subpkgdir"/usr/lib
+ pkgdesc="Xapian search engine library"
+
+ cd "$builddir"
+ install -d "$subpkgdir"/usr/lib
+ mv "$pkgdir"/usr/lib/$subpkgname* "$subpkgdir"/usr/lib
}
md5sums="5308261e78337604bd8f845dd6b4aafc xapian-core-1.4.0.tar.xz