aboutsummaryrefslogtreecommitdiffstats
path: root/community/xbps
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2017-04-15 01:21:10 +0200
committerJakub Jirutka <jakub@jirutka.cz>2017-04-15 01:21:35 +0200
commit6020727d4b626472aac1a38a7ca0ed6959f9a85f (patch)
treee57be71eaf26b849eb4c9963a56744c688b727ca /community/xbps
parent50cf88b61df8a5172b3731f8def875301bbb18d7 (diff)
downloadaports-6020727d4b626472aac1a38a7ca0ed6959f9a85f.tar.bz2
aports-6020727d4b626472aac1a38a7ca0ed6959f9a85f.tar.xz
community/xbps: move from testing
Diffstat (limited to 'community/xbps')
-rw-r--r--community/xbps/APKBUILD68
-rw-r--r--community/xbps/configure-fix-vasprintf-test.patch32
-rw-r--r--community/xbps/fix-build-with-misleading-indentation.patch44
-rw-r--r--community/xbps/moving-_unused-macro-to-_unused_attr.patch443
4 files changed, 587 insertions, 0 deletions
diff --git a/community/xbps/APKBUILD b/community/xbps/APKBUILD
new file mode 100644
index 0000000000..c4eeca802c
--- /dev/null
+++ b/community/xbps/APKBUILD
@@ -0,0 +1,68 @@
+# Contributor: André Klitzing <aklitzing@gmail.com>
+# Maintainer: André Klitzing <aklitzing@gmail.com>
+pkgname=xbps
+pkgver=0.51
+pkgrel=0
+pkgdesc="The X Binary Package System"
+arch="all"
+url="https://github.com/voidlinux/xbps"
+license="BSD"
+depends="ca-certificates"
+makedepends="zlib-dev libarchive-dev libressl-dev"
+subpackages="$pkgname-dev $pkgname-doc
+ $pkgname-bash-completion:bashcomp:noarch
+ $pkgname-zsh-completion:zshcomp:noarch"
+options="!check"
+source="$pkgname-$pkgver.tar.gz::https://github.com/voidlinux/$pkgname/archive/$pkgver.tar.gz
+ fix-build-with-misleading-indentation.patch
+ configure-fix-vasprintf-test.patch
+ moving-_unused-macro-to-_unused_attr.patch"
+builddir="$srcdir/$pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+
+ ./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --bindir=/usr/bin \
+ --localstatedir=/var/lib/xbps
+ make
+}
+
+package() {
+ cd "$builddir"
+
+ make DESTDIR="$pkgdir/" install
+
+ install -D -m 644 COPYING "$pkgdir/usr/share/licenses/$pkgname/COPYING"
+ install -D -m 644 COPYING.3RDPARTY \
+ "$pkgdir/usr/share/licenses/$pkgname/COPYING.3RDPARTY"
+}
+
+bashcomp() {
+ pkgdesc="Bash completions for $pkgname"
+ depends=""
+ install_if="$pkgname=$pkgver-r$pkgrel bash-completion"
+
+ _submv usr/share/bash-completion/completions
+}
+
+zshcomp() {
+ pkgdesc="ZSH completions for $pkgname"
+ depends=""
+ install_if="$pkgname=$pkgver-r$pkgrel zsh"
+
+ _submv usr/share/zsh/site-functions
+}
+
+_submv() {
+ local path="$1"
+ mkdir -p "$subpkgdir"/${path%/*}
+ mv "$pkgdir"/$path "$subpkgdir"/${path%/*}/
+}
+
+sha512sums="243dbef97bd94b05af1a79605f20050d00c6dfaffa8dbc56ea0b3b2d218a627fb45f157f9f82b6eb080f58a7445de9e7bf75d669f0be4caae262af5c5ac92262 xbps-0.51.tar.gz
+1e3e07152bbef6e7b10a462012c517beb2da207887ff1148c0b1509973efc520924236fd1e9ce9d5c0904cd403984caa52b5612f9037c1e24008711b68690221 fix-build-with-misleading-indentation.patch
+2de97a2fc9041ee456e58798d302028d428770fde775c21564a8ae8a7ba57393d7ff5e64680f8c62456a377df7528249278197030708050bb776470570e28416 configure-fix-vasprintf-test.patch
+f4048531c35f86b08c85348b8e684edc576302f2da78a53214194532fada3246ba8310c19bf8bcc139da7c29843363c77002ccb37cd529e566be2ed39b484d6e moving-_unused-macro-to-_unused_attr.patch"
diff --git a/community/xbps/configure-fix-vasprintf-test.patch b/community/xbps/configure-fix-vasprintf-test.patch
new file mode 100644
index 0000000000..fcb99a8370
--- /dev/null
+++ b/community/xbps/configure-fix-vasprintf-test.patch
@@ -0,0 +1,32 @@
+From 58107bf76ad1310abf52d44d36fc165f2efd629d Mon Sep 17 00:00:00 2001
+From: Natanael Copa <ncopa@alpinelinux.org>
+Date: Fri, 24 Mar 2017 10:19:36 +0100
+Subject: [PATCH] configure: fix vasprintf test
+
+Fix the test for vasprintf function which failed with musl libc and
+fortify-headers on aarch64:
+
+_vasprintf.c:4:24: error: incompatible type for argument 3 of 'vasprintf'
+ vasprintf(NULL, NULL, NULL);
+ ^~~~
+---
+ configure | 3 ++-
+ 1 file changed, 2 insertions(+), 1 deletion(-)
+
+diff --git a/configure b/configure
+index 861a67d0..b043dab0 100755
+--- a/configure
++++ b/configure
+@@ -390,7 +390,8 @@ else
+ #define _GNU_SOURCE
+ #include <stdio.h>
+ int main(void) {
+- vasprintf(NULL, NULL, NULL);
++ va_list ap;
++ vasprintf(NULL, NULL, ap);
+ return 0;
+ }
+ EOF
+--
+2.12.1
+
diff --git a/community/xbps/fix-build-with-misleading-indentation.patch b/community/xbps/fix-build-with-misleading-indentation.patch
new file mode 100644
index 0000000000..7fb8bfdb78
--- /dev/null
+++ b/community/xbps/fix-build-with-misleading-indentation.patch
@@ -0,0 +1,44 @@
+From 46744c412dca9ca2efc0df8ba1473ffd9145ddac Mon Sep 17 00:00:00 2001
+From: Michael Gehring <mg@ebfe.org>
+Date: Fri, 3 Jun 2016 20:23:52 +0200
+Subject: [PATCH] lib/fetch/common.c: fix build with
+ -Werror=misleading-indentation
+
+Fixes #179
+---
+ lib/fetch/common.c | 22 +++++++++++-----------
+ 1 file changed, 11 insertions(+), 11 deletions(-)
+
+diff --git a/lib/fetch/common.c b/lib/fetch/common.c
+index 77ffb7b..dd98a88 100644
+--- a/lib/fetch/common.c
++++ b/lib/fetch/common.c
+@@ -754,17 +754,17 @@ fetch_ssl_verify_cn(X509_NAME *subject, const char *host,
+ NID_commonName, lastpos)) != -1)
+ loc = lastpos;
+
+- if (loc > -1) {
+- nameentry = X509_NAME_get_entry(subject, loc);
+- namedata = X509_NAME_ENTRY_get_data(nameentry);
+- cnlen = ASN1_STRING_to_UTF8(&cn, namedata);
+- if (ip == NULL &&
+- fetch_ssl_hname_match(host, strlen(host), (const char *)cn, cnlen))
+- ret = 1;
+- else if (ip != NULL && fetch_ssl_ipaddr_match(ip, (const char *)cn, cnlen))
+- ret = 1;
+- OPENSSL_free(cn);
+- }
++ if (loc > -1) {
++ nameentry = X509_NAME_get_entry(subject, loc);
++ namedata = X509_NAME_ENTRY_get_data(nameentry);
++ cnlen = ASN1_STRING_to_UTF8(&cn, namedata);
++ if (ip == NULL &&
++ fetch_ssl_hname_match(host, strlen(host), (const char *)cn, cnlen))
++ ret = 1;
++ else if (ip != NULL && fetch_ssl_ipaddr_match(ip, (const char *)cn, cnlen))
++ ret = 1;
++ OPENSSL_free(cn);
++ }
+ return (ret);
+ }
+
diff --git a/community/xbps/moving-_unused-macro-to-_unused_attr.patch b/community/xbps/moving-_unused-macro-to-_unused_attr.patch
new file mode 100644
index 0000000000..d6f33dd972
--- /dev/null
+++ b/community/xbps/moving-_unused-macro-to-_unused_attr.patch
@@ -0,0 +1,443 @@
+From 84545a020ceaa499b8220ae6426325e0f12ce463 Mon Sep 17 00:00:00 2001
+From: Breno Leitao <breno.leitao@gmail.com>
+Date: Tue, 4 Apr 2017 19:20:02 +0000
+Subject: [PATCH] Moving _unused macro to _unused_attr
+
+Currently xbps package fails to build using musl libc because the signal.h
+header includes a struct field called _unused, that becomes defined as an
+function attribute due to the a CFLAG -D macro definition. This cause the
+build to fail.
+
+This patch just rename _unused macro to _unused_attr in order to avoid the
+names being clashed.
+
+Signed-off-by: Breno Leitao <breno.leitao@gmail.com>
+
+Index: xbps-0.51/bin/xbps-alternatives/main.c
+===================================================================
+--- xbps-0.51.orig/bin/xbps-alternatives/main.c
++++ xbps-0.51/bin/xbps-alternatives/main.c
+@@ -55,7 +55,7 @@ usage(bool fail)
+ }
+
+ static int
+-state_cb(const struct xbps_state_cb_data *xscd, void *cbd _unused)
++state_cb(const struct xbps_state_cb_data *xscd, void *cbd _unused_attr)
+ {
+ bool slog = false;
+
+Index: xbps-0.51/bin/xbps-create/main.c
+===================================================================
+--- xbps-0.51.orig/bin/xbps-create/main.c
++++ xbps-0.51/bin/xbps-create/main.c
+@@ -197,7 +197,7 @@ process_one_alternative(const char *altg
+
+
+ static void
+-process_dict_of_arrays(const char *key _unused, const char *val)
++process_dict_of_arrays(const char *key _unused_attr, const char *val)
+ {
+ char *altgrname, *args, *p, *saveptr;
+
+@@ -300,7 +300,7 @@ entry_is_conf_file(const char *file)
+ }
+
+ static int
+-ftw_cb(const char *fpath, const struct stat *sb, int type, struct FTW *ftwbuf _unused)
++ftw_cb(const char *fpath, const struct stat *sb, int type, struct FTW *ftwbuf _unused_attr)
+ {
+ struct xentry *xe = NULL;
+ const char *filep = NULL;
+Index: xbps-0.51/bin/xbps-install/main.c
+===================================================================
+--- xbps-0.51.orig/bin/xbps-install/main.c
++++ xbps-0.51/bin/xbps-install/main.c
+@@ -68,7 +68,7 @@ usage(bool fail)
+ }
+
+ static void
+-unpack_progress_cb(const struct xbps_unpack_cb_data *xpd, void *cbdata _unused)
++unpack_progress_cb(const struct xbps_unpack_cb_data *xpd, void *cbdata _unused_attr)
+ {
+ if (xpd->entry == NULL || xpd->entry_total_count <= 0)
+ return;
+@@ -80,7 +80,7 @@ unpack_progress_cb(const struct xbps_unp
+ }
+
+ static int
+-repo_import_key_cb(struct xbps_repo *repo, void *arg _unused, bool *done _unused)
++repo_import_key_cb(struct xbps_repo *repo, void *arg _unused_attr, bool *done _unused_attr)
+ {
+ int rv;
+
+Index: xbps-0.51/bin/xbps-install/state_cb.c
+===================================================================
+--- xbps-0.51.orig/bin/xbps-install/state_cb.c
++++ xbps-0.51/bin/xbps-install/state_cb.c
+@@ -32,7 +32,7 @@
+ #include "defs.h"
+
+ int
+-state_cb(const struct xbps_state_cb_data *xscd, void *cbdata _unused)
++state_cb(const struct xbps_state_cb_data *xscd, void *cbdata _unused_attr)
+ {
+ xbps_dictionary_t pkgd;
+ const char *instver, *newver;
+Index: xbps-0.51/bin/xbps-pkgdb/check.c
+===================================================================
+--- xbps-0.51.orig/bin/xbps-pkgdb/check.c
++++ xbps-0.51/bin/xbps-pkgdb/check.c
+@@ -36,11 +36,11 @@
+ #include "defs.h"
+
+ static int
+-pkgdb_cb(struct xbps_handle *xhp _unused,
++pkgdb_cb(struct xbps_handle *xhp _unused_attr,
+ xbps_object_t obj,
+- const char *key _unused,
++ const char *key _unused_attr,
+ void *arg,
+- bool *done _unused)
++ bool *done _unused_attr)
+ {
+ const char *pkgver;
+ char *pkgname;
+Index: xbps-0.51/bin/xbps-pkgdb/check_pkg_unneeded.c
+===================================================================
+--- xbps-0.51.orig/bin/xbps-pkgdb/check_pkg_unneeded.c
++++ xbps-0.51/bin/xbps-pkgdb/check_pkg_unneeded.c
+@@ -43,7 +43,7 @@
+ * and remove them if that was true.
+ */
+ int
+-check_pkg_unneeded(struct xbps_handle *xhp _unused, const char *pkgname, void *arg)
++check_pkg_unneeded(struct xbps_handle *xhp _unused_attr, const char *pkgname, void *arg)
+ {
+ xbps_array_t replaces;
+ xbps_dictionary_t pkgd = arg;
+Index: xbps-0.51/bin/xbps-query/list.c
+===================================================================
+--- xbps-0.51.orig/bin/xbps-query/list.c
++++ xbps-0.51/bin/xbps-query/list.c
+@@ -38,11 +38,11 @@ struct list_pkgver_cb {
+ };
+
+ int
+-list_pkgs_in_dict(struct xbps_handle *xhp _unused,
++list_pkgs_in_dict(struct xbps_handle *xhp _unused_attr,
+ xbps_object_t obj,
+- const char *key _unused,
++ const char *key _unused_attr,
+ void *arg,
+- bool *loop_done _unused)
++ bool *loop_done _unused_attr)
+ {
+ struct list_pkgver_cb *lpc = arg;
+ const char *pkgver, *short_desc, *state_str;
+@@ -88,11 +88,11 @@ list_pkgs_in_dict(struct xbps_handle *xh
+ }
+
+ int
+-list_manual_pkgs(struct xbps_handle *xhp _unused,
++list_manual_pkgs(struct xbps_handle *xhp _unused_attr,
+ xbps_object_t obj,
+- const char *key _unused,
+- void *arg _unused,
+- bool *loop_done _unused)
++ const char *key _unused_attr,
++ void *arg _unused_attr,
++ bool *loop_done _unused_attr)
+ {
+ const char *pkgver;
+ bool automatic = false;
+@@ -107,11 +107,11 @@ list_manual_pkgs(struct xbps_handle *xhp
+ }
+
+ int
+-list_hold_pkgs(struct xbps_handle *xhp _unused,
++list_hold_pkgs(struct xbps_handle *xhp _unused_attr,
+ xbps_object_t obj,
+- const char *key _unused,
+- void *arg _unused,
+- bool *loop_done _unused)
++ const char *key _unused_attr,
++ void *arg _unused_attr,
++ bool *loop_done _unused_attr)
+ {
+ const char *pkgver;
+
+@@ -153,7 +153,7 @@ list_pkgs_pkgdb(struct xbps_handle *xhp)
+ }
+
+ static int
+-repo_list_uri_cb(struct xbps_repo *repo, void *arg _unused, bool *done _unused)
++repo_list_uri_cb(struct xbps_repo *repo, void *arg _unused_attr, bool *done _unused_attr)
+ {
+ const char *signedby = NULL;
+ uint16_t pubkeysize = 0;
+@@ -201,11 +201,11 @@ struct fflongest {
+ };
+
+ static int
+-_find_longest_pkgver_cb(struct xbps_handle *xhp _unused,
++_find_longest_pkgver_cb(struct xbps_handle *xhp _unused_attr,
+ xbps_object_t obj,
+- const char *key _unused,
++ const char *key _unused_attr,
+ void *arg,
+- bool *loop_done _unused)
++ bool *loop_done _unused_attr)
+ {
+ struct fflongest *ffl = arg;
+ const char *pkgver;
+Index: xbps-0.51/bin/xbps-query/ownedby.c
+===================================================================
+--- xbps-0.51.orig/bin/xbps-query/ownedby.c
++++ xbps-0.51/bin/xbps-query/ownedby.c
+@@ -95,9 +95,9 @@ match_files_by_pattern(xbps_dictionary_t
+ static int
+ ownedby_pkgdb_cb(struct xbps_handle *xhp,
+ xbps_object_t obj,
+- const char *obj_key _unused,
++ const char *obj_key _unused_attr,
+ void *arg,
+- bool *done _unused)
++ bool *done _unused_attr)
+ {
+ xbps_dictionary_t pkgmetad;
+ xbps_array_t files_keys;
+@@ -127,9 +127,9 @@ ownedby_pkgdb_cb(struct xbps_handle *xhp
+ static int
+ repo_match_cb(struct xbps_handle *xhp,
+ xbps_object_t obj,
+- const char *key _unused,
++ const char *key _unused_attr,
+ void *arg,
+- bool *done _unused)
++ bool *done _unused_attr)
+ {
+ xbps_dictionary_t filesd;
+ xbps_array_t files_keys;
+@@ -161,7 +161,7 @@ repo_match_cb(struct xbps_handle *xhp,
+ }
+
+ static int
+-repo_ownedby_cb(struct xbps_repo *repo, void *arg, bool *done _unused)
++repo_ownedby_cb(struct xbps_repo *repo, void *arg, bool *done _unused_attr)
+ {
+ xbps_array_t allkeys;
+ struct ffdata *ffd = arg;
+Index: xbps-0.51/bin/xbps-query/search.c
+===================================================================
+--- xbps-0.51.orig/bin/xbps-query/search.c
++++ xbps-0.51/bin/xbps-query/search.c
+@@ -96,11 +96,11 @@ print_results(struct xbps_handle *xhp, s
+ }
+
+ static int
+-search_array_cb(struct xbps_handle *xhp _unused,
++search_array_cb(struct xbps_handle *xhp _unused_attr,
+ xbps_object_t obj,
+- const char *key _unused,
++ const char *key _unused_attr,
+ void *arg,
+- bool *done _unused)
++ bool *done _unused_attr)
+ {
+ xbps_object_t obj2;
+ struct search_data *sd = arg;
+@@ -212,7 +212,7 @@ search_array_cb(struct xbps_handle *xhp
+ }
+
+ static int
+-search_repo_cb(struct xbps_repo *repo, void *arg, bool *done _unused)
++search_repo_cb(struct xbps_repo *repo, void *arg, bool *done _unused_attr)
+ {
+ xbps_array_t allkeys;
+ struct search_data *sd = arg;
+Index: xbps-0.51/bin/xbps-reconfigure/main.c
+===================================================================
+--- xbps-0.51.orig/bin/xbps-reconfigure/main.c
++++ xbps-0.51/bin/xbps-reconfigure/main.c
+@@ -52,7 +52,7 @@ usage(bool fail)
+ }
+
+ static int
+-state_cb(const struct xbps_state_cb_data *xscd, void *cbd _unused)
++state_cb(const struct xbps_state_cb_data *xscd, void *cbd _unused_attr)
+ {
+ bool slog = false;
+
+Index: xbps-0.51/bin/xbps-remove/clean-cache.c
+===================================================================
+--- xbps-0.51.orig/bin/xbps-remove/clean-cache.c
++++ xbps-0.51/bin/xbps-remove/clean-cache.c
+@@ -38,8 +38,8 @@
+
+ static int
+ cleaner_cb(struct xbps_handle *xhp, xbps_object_t obj,
+- const char *key _unused, void *arg _unused,
+- bool *done _unused)
++ const char *key _unused_attr, void *arg _unused_attr,
++ bool *done _unused_attr)
+ {
+ xbps_dictionary_t repo_pkgd;
+ const char *binpkg, *rsha256;
+Index: xbps-0.51/bin/xbps-remove/main.c
+===================================================================
+--- xbps-0.51.orig/bin/xbps-remove/main.c
++++ xbps-0.51/bin/xbps-remove/main.c
+@@ -64,7 +64,7 @@ usage(bool fail)
+ }
+
+ static int
+-state_cb_rm(const struct xbps_state_cb_data *xscd, void *cbdata _unused)
++state_cb_rm(const struct xbps_state_cb_data *xscd, void *cbdata _unused_attr)
+ {
+ bool slog = false;
+
+Index: xbps-0.51/bin/xbps-rindex/index-clean.c
+===================================================================
+--- xbps-0.51.orig/bin/xbps-rindex/index-clean.c
++++ xbps-0.51/bin/xbps-rindex/index-clean.c
+@@ -43,9 +43,9 @@ static xbps_dictionary_t dest;
+ static int
+ idx_cleaner_cb(struct xbps_handle *xhp,
+ xbps_object_t obj,
+- const char *key _unused,
++ const char *key _unused_attr,
+ void *arg,
+- bool *done _unused)
++ bool *done _unused_attr)
+ {
+ const char *repourl = arg;
+ const char *arch, *pkgver, *sha256;
+Index: xbps-0.51/bin/xbps-rindex/remove-obsoletes.c
+===================================================================
+--- xbps-0.51.orig/bin/xbps-rindex/remove-obsoletes.c
++++ xbps-0.51/bin/xbps-rindex/remove-obsoletes.c
+@@ -65,7 +65,7 @@ remove_pkg(const char *repodir, const ch
+ }
+
+ static int
+-cleaner_cb(struct xbps_handle *xhp, xbps_object_t obj, const char *key _unused, void *arg, bool *done _unused)
++cleaner_cb(struct xbps_handle *xhp, xbps_object_t obj, const char *key _unused_attr, void *arg, bool *done _unused_attr)
+ {
+ struct xbps_repo *repo = arg;
+ const char *binpkg;
+Index: xbps-0.51/bin/xbps-uchroot/main.c
+===================================================================
+--- xbps-0.51.orig/bin/xbps-uchroot/main.c
++++ xbps-0.51/bin/xbps-uchroot/main.c
+@@ -109,8 +109,8 @@ die(const char *fmt, ...)
+ }
+
+ static int
+-ftw_cb(const char *fpath, const struct stat *sb _unused, int type,
+- struct FTW *ftwbuf _unused)
++ftw_cb(const char *fpath, const struct stat *sb _unused_attr, int type,
++ struct FTW *ftwbuf _unused_attr)
+ {
+ int sverrno = 0;
+
+Index: xbps-0.51/configure
+===================================================================
+--- xbps-0.51.orig/configure
++++ xbps-0.51/configure
+@@ -192,7 +192,7 @@ echo "CPPFLAGS += -DXBPS_SYSCONF_PATH=\\
+ echo "CPPFLAGS += -DXBPS_SYSDEFCONF_PATH=\\\"${SHAREDIR}/xbps.d\\\"" >>$CONFIG_MK
+ echo "CPPFLAGS += -DXBPS_VERSION=\\\"${VERSION}\\\"" >>$CONFIG_MK
+ echo "CPPFLAGS += -DXBPS_META_PATH=\\\"${DBDIR}\\\"" >>$CONFIG_MK
+-echo "CPPFLAGS += -D_unused=\"__attribute__((__unused__))\"" >>$CONFIG_MK
++echo "CPPFLAGS += -D_unused_attr=\"__attribute__((__unused__))\"" >>$CONFIG_MK
+
+ if [ -d .git ]; then
+ _gitrev=$(git rev-parse --short HEAD)
+Index: xbps-0.51/lib/package_orphans.c
+===================================================================
+--- xbps-0.51.orig/lib/package_orphans.c
++++ xbps-0.51/lib/package_orphans.c
+@@ -60,7 +60,7 @@
+ */
+
+ xbps_array_t
+-xbps_find_pkg_orphans(struct xbps_handle *xhp, xbps_array_t orphans_user _unused)
++xbps_find_pkg_orphans(struct xbps_handle *xhp, xbps_array_t orphans_user _unused_attr)
+ {
+ xbps_array_t rdeps, reqby, array = NULL;
+ xbps_dictionary_t pkgd, deppkgd;
+Index: xbps-0.51/lib/plist_fetch.c
+===================================================================
+--- xbps-0.51.orig/lib/plist_fetch.c
++++ xbps-0.51/lib/plist_fetch.c
+@@ -46,7 +46,7 @@ struct fetch_archive {
+ };
+
+ static int
+-fetch_archive_open(struct archive *a _unused, void *client_data)
++fetch_archive_open(struct archive *a _unused_attr, void *client_data)
+ {
+ struct fetch_archive *f = client_data;
+
+@@ -59,7 +59,7 @@ fetch_archive_open(struct archive *a _un
+ }
+
+ static ssize_t
+-fetch_archive_read(struct archive *a _unused, void *client_data, const void **buf)
++fetch_archive_read(struct archive *a _unused_attr, void *client_data, const void **buf)
+ {
+ struct fetch_archive *f = client_data;
+
+@@ -68,7 +68,7 @@ fetch_archive_read(struct archive *a _un
+ }
+
+ static int
+-fetch_archive_close(struct archive *a _unused, void *client_data)
++fetch_archive_close(struct archive *a _unused_attr, void *client_data)
+ {
+ struct fetch_archive *f = client_data;
+
+Index: xbps-0.51/lib/rpool.c
+===================================================================
+--- xbps-0.51.orig/lib/rpool.c
++++ xbps-0.51/lib/rpool.c
+@@ -120,7 +120,7 @@ xbps_rpool_get_repo(const char *url)
+ }
+
+ void
+-xbps_rpool_release(struct xbps_handle *xhp _unused)
++xbps_rpool_release(struct xbps_handle *xhp _unused_attr)
+ {
+ struct xbps_repo *repo;
+
+@@ -195,7 +195,7 @@ find_pkg_cb(struct xbps_repo *repo, void
+ }
+
+ static int
+-find_pkg_revdeps_cb(struct xbps_repo *repo, void *arg, bool *done _unused)
++find_pkg_revdeps_cb(struct xbps_repo *repo, void *arg, bool *done _unused_attr)
+ {
+ struct rpool_fpkg *rpf = arg;
+ xbps_array_t revdeps = NULL;
+@@ -216,7 +216,7 @@ find_pkg_revdeps_cb(struct xbps_repo *re
+ }
+
+ static int
+-find_best_pkg_cb(struct xbps_repo *repo, void *arg, bool *done _unused)
++find_best_pkg_cb(struct xbps_repo *repo, void *arg, bool *done _unused_attr)
+ {
+ struct rpool_fpkg *rpf = arg;
+ xbps_dictionary_t pkgd;
+Index: xbps-0.51/lib/transaction_conflicts.c
+===================================================================
+--- xbps-0.51.orig/lib/transaction_conflicts.c
++++ xbps-0.51/lib/transaction_conflicts.c
+@@ -148,7 +148,7 @@ pkg_conflicts_trans(struct xbps_handle *
+
+ static int
+ pkgdb_conflicts_cb(struct xbps_handle *xhp, xbps_object_t obj,
+- const char *key _unused, void *arg, bool *done _unused)
++ const char *key _unused_attr, void *arg, bool *done _unused_attr)
+ {
+ xbps_array_t pkg_cflicts, trans_cflicts, pkgs = arg;
+ xbps_dictionary_t pkgd;