aboutsummaryrefslogtreecommitdiffstats
path: root/community/xchat
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2016-10-07 07:46:11 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2016-10-10 12:04:34 +0000
commitea65d6046e138275012814e4490478ba64526279 (patch)
tree4fcfb64feb776b6e553095a5a4af32e503661eb6 /community/xchat
parentcc3fa43f44f2f6e9431fb2e5996f72e81b0e6d0a (diff)
downloadaports-ea65d6046e138275012814e4490478ba64526279.tar.bz2
aports-ea65d6046e138275012814e4490478ba64526279.tar.xz
community/xchat: move from main
Diffstat (limited to 'community/xchat')
-rw-r--r--community/xchat/APKBUILD68
-rw-r--r--community/xchat/libressl.patch20
-rw-r--r--community/xchat/link-gmodule.patch11
-rw-r--r--community/xchat/midori.patch15
-rw-r--r--community/xchat/xchat-2.8.8-glib-2.31.patch62
5 files changed, 176 insertions, 0 deletions
diff --git a/community/xchat/APKBUILD b/community/xchat/APKBUILD
new file mode 100644
index 0000000000..094e321636
--- /dev/null
+++ b/community/xchat/APKBUILD
@@ -0,0 +1,68 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=xchat
+pkgver=2.8.8
+pkgrel=11
+pkgdesc="A GTK+ based IRC client"
+url="http://www.xchat.org/"
+arch="all"
+license="GPL"
+subpackages="$pkgname-lang"
+makedepends="gtk+-dev libressl-dev dbus-glib-dev perl-dev
+ libxext-dev"
+source="http://www.$pkgname.org/files/source/2.8/$pkgname-$pkgver.tar.bz2
+ midori.patch
+ xchat-2.8.8-glib-2.31.patch
+ link-gmodule.patch
+ libressl.patch
+ "
+
+_builddir="$srcdir"/$pkgname-$pkgver
+prepare() {
+ cd "$_builddir"
+ update_config_sub || return 1
+ for i in $source; do
+ case $i in
+ *.patch) msg "$i"; patch -p1 -i "$srcdir"/$i || return 1 ;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --enable-openssl \
+ --enable-dbus \
+ --disable-textfe \
+ --disable-perl \
+ --disable-python \
+ --enable-ipv6 \
+ --enable-shm \
+ --enable-spell=static \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+md5sums="6775c44f38e84d06c06c336b32c4a452 xchat-2.8.8.tar.bz2
+759fd786be3a2546be33f7533632b5a2 midori.patch
+98f5c7b49a3e0bad4ef0b7871fdcd8b5 xchat-2.8.8-glib-2.31.patch
+6efe686e4747e1ea22c368cf83fb6ea2 link-gmodule.patch
+03d419af35a860e305dc5a80c2f809ba libressl.patch"
+sha256sums="0d6d69437b5e1e45f3e66270fe369344943de8a1190e498fafa5296315a27db0 xchat-2.8.8.tar.bz2
+9a06b649e5ab99428b8e838f8680ad62595c8eb068e37127436eea21998f1af9 midori.patch
+8406db6eb273595b6acb4da0ac4befa684f168e1e5c821d48096d508102d7a66 xchat-2.8.8-glib-2.31.patch
+332b691c69f6e11fb8fd13fa6328b8cebc64e53063923c406dcf590d964bb1cf link-gmodule.patch
+bd16634333265cb4c11dfc43694e9d7f14b669adc10a0fb3adf5421e1c6735f6 libressl.patch"
+sha512sums="70eddc15a8bb08283b94f4d7bb5225016d42dd7bb946ac30f8e53bb68b892d15dd2a77d8825e5872e47b6d55f15ae468db1a7466676cd548d0a05c571d76db2b xchat-2.8.8.tar.bz2
+cff2d877182dc653df6446efe5bd7f7f1365b9b1abaa42c4dc1ab8797ff2366e36878bbc3b3a5e5386da1edfe2339ea304d0b0f55b7ae3bff6120bc39c83dda5 midori.patch
+b22da471b424b5270733f1c676e46ad411a70d0f14cfa1b42abde270f36c7da8afbeca235e0aa3b504ff35c8177012439e02841e6192fb8947cf0f7c0060e1be xchat-2.8.8-glib-2.31.patch
+a67671bfd5afa600c7b19f3bce2ba32913f65f115f0beb9397aef28d9941b88d4a9e6fca12a8c78122a5d8379c614f19f7b9e1f4f4384ed2c94594ce0b6c8ade link-gmodule.patch
+d2dc08e57c1d9da8487fa8f4e62053b3ff13964e0015860b27bde67a2c1af6e6ad5c7fdd374735145d2b5bb26b4e33e518fbc401c940f7110ec97b1558f99e47 libressl.patch"
diff --git a/community/xchat/libressl.patch b/community/xchat/libressl.patch
new file mode 100644
index 0000000000..3a971735dd
--- /dev/null
+++ b/community/xchat/libressl.patch
@@ -0,0 +1,20 @@
+--- a/src/common/ssl.c.orig 2016-03-30 20:54:51.193579450 +0200
++++ b/src/common/ssl.c 2016-03-30 20:55:03.070579987 +0200
+@@ -70,7 +70,7 @@
+
+ SSLeay_add_ssl_algorithms ();
+ SSL_load_error_strings ();
+- ctx = SSL_CTX_new (server ? SSLv3_server_method() : SSLv3_client_method ());
++ ctx = SSL_CTX_new (server ? SSLv23_server_method() : SSLv23_client_method ());
+
+ SSL_CTX_set_session_cache_mode (ctx, SSL_SESS_CACHE_BOTH);
+ SSL_CTX_set_timeout (ctx, 300);
+@@ -281,7 +281,7 @@
+ __SSL_critical_error ("SSL_new");
+
+ SSL_set_fd (ssl, sd);
+- if (ctx->method == SSLv3_client_method())
++ if (ctx->method == SSLv23_client_method())
+ SSL_set_connect_state (ssl);
+ else
+ SSL_set_accept_state(ssl);
diff --git a/community/xchat/link-gmodule.patch b/community/xchat/link-gmodule.patch
new file mode 100644
index 0000000000..fbc1a50060
--- /dev/null
+++ b/community/xchat/link-gmodule.patch
@@ -0,0 +1,11 @@
+--- ./src/fe-gtk/Makefile.in.orig
++++ ./src/fe-gtk/Makefile.in
+@@ -150,7 +150,7 @@
+ GTK_CFLAGS = @GTK_CFLAGS@
+ GTK_LIBS = @GTK_LIBS@
+ GUI_CFLAGS = @GUI_CFLAGS@
+-GUI_LIBS = @GUI_LIBS@
++GUI_LIBS = @GUI_LIBS@ -lgmodule-2.0
+ HAVE_ASPRINTF = @HAVE_ASPRINTF@
+ HAVE_POSIX_PRINTF = @HAVE_POSIX_PRINTF@
+ HAVE_SNPRINTF = @HAVE_SNPRINTF@
diff --git a/community/xchat/midori.patch b/community/xchat/midori.patch
new file mode 100644
index 0000000000..a9b4a08a44
--- /dev/null
+++ b/community/xchat/midori.patch
@@ -0,0 +1,15 @@
+diff --git a/src/fe-gtk/fe-gtk.c b/src/fe-gtk/fe-gtk.c
+index 251a7d7..f427ad4 100644
+--- a/src/fe-gtk/fe-gtk.c
++++ b/src/fe-gtk/fe-gtk.c
+@@ -958,6 +958,10 @@ fe_open_url_inner (const char *url)
+ /* everything failed, what now? just try firefox */
+ if (try_browser ("firefox", NULL, url))
+ return;
++
++ /* try midori before giving up */
++ if (try_browser ("midori", NULL, url))
++ return;
+
+ /* fresh out of ideas... */
+ try_browser ("mozilla", NULL, url);
diff --git a/community/xchat/xchat-2.8.8-glib-2.31.patch b/community/xchat/xchat-2.8.8-glib-2.31.patch
new file mode 100644
index 0000000000..63f562ff83
--- /dev/null
+++ b/community/xchat/xchat-2.8.8-glib-2.31.patch
@@ -0,0 +1,62 @@
+Author: Dominique Leuenberger <dimstar@opensuse.org>
+
+http://sourceforge.net/tracker/?func=detail&aid=3446968&group_id=239&atid=100239
+
+glib got stricter in checking includes. Only glib.h (and a few exceptions)
+are to be included directly.
+
+Index: xchat-2.8.8/src/common/servlist.c
+===================================================================
+--- xchat-2.8.8.orig/src/common/servlist.c
++++ xchat-2.8.8/src/common/servlist.c
+@@ -24,7 +24,7 @@
+ #include <unistd.h>
+
+ #include "xchat.h"
+-#include <glib/ghash.h>
++#include <glib.h>
+
+ #include "cfgfiles.h"
+ #include "fe.h"
+Index: xchat-2.8.8/src/common/text.c
+===================================================================
+--- xchat-2.8.8.orig/src/common/text.c
++++ xchat-2.8.8/src/common/text.c
+@@ -28,7 +28,7 @@
+ #include <sys/mman.h>
+
+ #include "xchat.h"
+-#include <glib/ghash.h>
++#include <glib.h>
+ #include "cfgfiles.h"
+ #include "chanopt.h"
+ #include "plugin.h"
+Index: xchat-2.8.8/src/common/util.c
+===================================================================
+--- xchat-2.8.8.orig/src/common/util.c
++++ xchat-2.8.8/src/common/util.c
+@@ -39,7 +39,7 @@
+ #include <errno.h>
+ #include "xchat.h"
+ #include "xchatc.h"
+-#include <glib/gmarkup.h>
++#include <glib.h>
+ #include <ctype.h>
+ #include "util.h"
+ #include "../../config.h"
+Index: xchat-2.8.8/src/common/xchat.h
+===================================================================
+--- xchat-2.8.8.orig/src/common/xchat.h
++++ xchat-2.8.8/src/common/xchat.h
+@@ -1,10 +1,6 @@
+ #include "../../config.h"
+
+-#include <glib/gslist.h>
+-#include <glib/glist.h>
+-#include <glib/gutils.h>
+-#include <glib/giochannel.h>
+-#include <glib/gstrfuncs.h>
++#include <glib.h>
+ #include <time.h> /* need time_t */
+
+ #ifndef XCHAT_H