aboutsummaryrefslogtreecommitdiffstats
path: root/community/xdesktop/APKBUILD
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2017-01-13 15:18:35 +0100
committerNatanael Copa <ncopa@alpinelinux.org>2017-01-13 15:19:00 +0100
commitd3570043ddf71bc76596865a45651011ec75a7b8 (patch)
tree74808cb20b6d9ab6949cc807e33bfbe6d488bfdb /community/xdesktop/APKBUILD
parent08f8342c3aef359cf5089dd3aa217355f69cc6e9 (diff)
downloadaports-d3570043ddf71bc76596865a45651011ec75a7b8.tar.bz2
aports-d3570043ddf71bc76596865a45651011ec75a7b8.tar.xz
communit/xdesktop: move from testing
Diffstat (limited to 'community/xdesktop/APKBUILD')
-rw-r--r--community/xdesktop/APKBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/community/xdesktop/APKBUILD b/community/xdesktop/APKBUILD
new file mode 100644
index 0000000000..45e675723b
--- /dev/null
+++ b/community/xdesktop/APKBUILD
@@ -0,0 +1,30 @@
+# Contributor: Camille Scholtz <onodera@openmailbox.org>
+# Maintainer: Camille Scholtz <onodera@openmailbox.org>
+pkgname=xdesktop
+pkgver=0.3
+pkgrel=0
+pkgdesc="output and change X virtual desktop"
+url="https://github.com/onodera-punpun/xdesktop"
+arch="all"
+license="unlicense"
+depends=""
+depends_dev="xcb-util-wm-dev"
+makedepends="$depends_dev"
+install=""
+subpackages=""
+source="saveas-https://github.com/onodera-punpun/$pkgname/archive/$pkgver.tar.gz/$pkgname-$pkgver.tar.gz"
+
+builddir="$srcdir"/$pkgname-$pkgver
+build() {
+ cd "$builddir"
+ make || return 1
+}
+
+package() {
+ cd "$builddir"
+ make PREFIX=/usr DESTDIR="$pkgdir" install || return 1
+}
+
+md5sums="fbc59a158d93dcee518bd6298a2c3530 xdesktop-0.3.tar.gz"
+sha256sums="b2c9cd6aaae3b13c4fd8f61799b12454387be838df9078db6faf14dbfaef01ca xdesktop-0.3.tar.gz"
+sha512sums="125d880c0d2af5c847b74caf5fc51f32d597dc00f25dc334fa5a2664438b248da5989d3f4df2bbd7c5998511cdcf2144625ebc0653ad481dd88378551a7ae529 xdesktop-0.3.tar.gz"