aboutsummaryrefslogtreecommitdiffstats
path: root/community/xfburn
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2018-04-23 19:44:46 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2018-04-23 19:44:46 +0000
commit27d1e194717b1696b3169ad43df027876247b91a (patch)
tree8416dc507bc2aed5f47588d345abe1ef22a6c60f /community/xfburn
parent0090cfe5db52bd764631d9b1d55e6e74c7cf2ae8 (diff)
downloadaports-27d1e194717b1696b3169ad43df027876247b91a.tar.bz2
aports-27d1e194717b1696b3169ad43df027876247b91a.tar.xz
main/{xfce*} => community/
Move everything xfce to community
Diffstat (limited to 'community/xfburn')
-rw-r--r--community/xfburn/APKBUILD42
-rw-r--r--community/xfburn/fix_empty_dir_segfault.patch48
-rw-r--r--community/xfburn/xfburn-0.4.3-desktop-file.patch19
-rw-r--r--community/xfburn/xfburn-0.4.3-if-with-several-statements.patch54
4 files changed, 163 insertions, 0 deletions
diff --git a/community/xfburn/APKBUILD b/community/xfburn/APKBUILD
new file mode 100644
index 0000000000..24759f0f65
--- /dev/null
+++ b/community/xfburn/APKBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=xfburn
+pkgver=0.5.4
+pkgrel=0
+pkgdesc="a simple CD/DVD burning tool based on libburnia libraries"
+url="http://goodies.xfce.org/projects/applications/xfburn"
+arch="all"
+license="GPL-2.0"
+depends="desktop-file-utils hicolor-icon-theme"
+makedepends="libburn-dev libisofs-dev libxfce4ui-dev thunar-dev librsvg-dev
+ gst-plugins-base0.10-dev exo-dev"
+subpackages="$pkgname-doc $pkgname-lang"
+source="http://archive.xfce.org/src/apps/xfburn/${pkgver%.*}/xfburn-$pkgver.tar.bz2"
+
+builddir="$srcdir"/$pkgname-$pkgver
+prepare() {
+ default_prepare
+ cd "$_builddir"
+ # fix build issue
+ sed -i '1 i\
+ #include <glib-object.h>' \
+ xfburn/xfburn-settings.h
+}
+
+build () {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --enable-gstreamer \
+ --enable-thunar-vfs \
+ --enable-dbus
+ make
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="66bd82aa80fcd53d5d505b01a33cdbffdcf547a05a11bdbe688387420ee682a28564397acaf85a52852625909648c01cc18f289736ac54d2806725f46c875481 xfburn-0.5.4.tar.bz2"
diff --git a/community/xfburn/fix_empty_dir_segfault.patch b/community/xfburn/fix_empty_dir_segfault.patch
new file mode 100644
index 0000000000..93418ae413
--- /dev/null
+++ b/community/xfburn/fix_empty_dir_segfault.patch
@@ -0,0 +1,48 @@
+--- ./xfburn/xfburn-data-composition.c 2011-02-17 16:37:03.000000000 +0100
++++ ./xfburn/xfburn-data-composition_patched.c 2011-02-17 16:40:40.000000000 +0100
+@@ -1874,26 +1874,29 @@
+ g_error ("Failed adding %s as a node to the image: code %X!", src, r);
+ }
+
+- basename = g_path_get_basename (src);
++ /* Check names only for items not manually created (#613563) */
++ if (type != DATA_COMPOSITION_TYPE_DIRECTORY || src != NULL) {
++ basename = g_path_get_basename (src);
++
++ /* check if the file has been renamed */
++ if (strcmp (basename, name) != 0) {
++ /* rename the iso_node */
++ r = iso_node_set_name (node, name);
++
++ if (r == 0) {
++ /* The first string is the renamed name, the second one the original name */
++ xfce_warn (_("Duplicate filename '%s' for '%s'"), name, src);
++
++ g_free (basename);
++ g_free (name);
++ g_free (src);
+
+- /* check if the file has been renamed */
+- if (strcmp (basename, name) != 0) {
+- /* rename the iso_node */
+- r = iso_node_set_name (node, name);
+-
+- if (r == 0) {
+- /* The first string is the renamed name, the second one the original name */
+- xfce_warn (_("Duplicate filename '%s' for '%s'"), name, src);
+-
+- g_free (basename);
+- g_free (name);
+- g_free (src);
+-
+- continue;
++ continue;
++ }
+ }
++ g_free (basename);
+ }
+
+- g_free (basename);
+ g_free (name);
+ g_free (src);
+
diff --git a/community/xfburn/xfburn-0.4.3-desktop-file.patch b/community/xfburn/xfburn-0.4.3-desktop-file.patch
new file mode 100644
index 0000000000..7669b5fb8a
--- /dev/null
+++ b/community/xfburn/xfburn-0.4.3-desktop-file.patch
@@ -0,0 +1,19 @@
+--- xfburn-0.4.3.orig/xfburn.desktop.in 2009-08-13 01:12:26.000000000 +0200
++++ xfburn-0.4.3/xfburn.desktop.in 2012-09-28 22:12:14.840869423 +0200
+@@ -6,7 +6,7 @@
+ Exec=xfburn
+ TryExec=xfburn
+ Icon=media-cdrom
+-MimeType=application/x-cd-image
++MimeType=application/x-cd-image;
+ Terminal=false
+ Categories=X-XFCE;GTK;DiscBurning;Archiving;AudioVideo;
+ StartupNotify=true
+@@ -14,7 +14,6 @@
+ Actions=BurnImage;
+
+ [Desktop Action BurnImage]
+-MimeType=application/x-cd-image
+ Icon=media-cdrom
+ Exec=xfburn -i %f
+ _Name=Burn Image (xfburn)
diff --git a/community/xfburn/xfburn-0.4.3-if-with-several-statements.patch b/community/xfburn/xfburn-0.4.3-if-with-several-statements.patch
new file mode 100644
index 0000000000..18de28f589
--- /dev/null
+++ b/community/xfburn/xfburn-0.4.3-if-with-several-statements.patch
@@ -0,0 +1,54 @@
+same as http://git.xfce.org/apps/xfburn/commit/?id=e1d6bfc2 but against 0.4.3
+https://bugzilla.xfce.org/show_bug.cgi?id=7103
+
+diff -dur xfburn-0.4.3.orig/xfburn/xfburn-data-composition.c xfburn-0.4.3/xfburn/xfburn-data-composition.c
+--- xfburn-0.4.3.orig/xfburn/xfburn-data-composition.c 2009-12-04 08:46:43.000000000 +0100
++++ xfburn-0.4.3/xfburn/xfburn-data-composition.c 2012-09-28 21:59:01.975954901 +0200
+@@ -1075,7 +1075,9 @@
+
+ /* ensure that we can only drop on top of folders, not files */
+ if (insertion) {
++ gdk_threads_enter ();
+ gtk_tree_model_get (model, insertion, DATA_COMPOSITION_COLUMN_TYPE, &parent_type, -1);
++ gdk_threads_leave ();
+
+ if (parent_type == DATA_COMPOSITION_TYPE_FILE) {
+ DBG ("Parent is file, and we're dropping into %d", position);
+@@ -1116,9 +1118,7 @@
+ } else {
+ tree_path = gtk_tree_path_new_first ();
+ }
+- gdk_threads_leave ();
+
+- gdk_threads_enter ();
+ if (file_exists_on_same_level (model, tree_path, FALSE, name)) {
+ xfce_err (_("A file with the same name is already present in the composition."));
+
+@@ -1821,10 +1821,11 @@
+
+ if (thread_add_file_to_list (composition, model, full_path, &iter, &iter_where_insert, position)) {
+ if (position == GTK_TREE_VIEW_DROP_INTO_OR_BEFORE
+- || position == GTK_TREE_VIEW_DROP_INTO_OR_AFTER)
++ || position == GTK_TREE_VIEW_DROP_INTO_OR_AFTER) {
+ gdk_threads_enter ();
+ gtk_tree_view_expand_row (GTK_TREE_VIEW (widget), priv->path_where_insert, FALSE);
+ gdk_threads_leave ();
++ }
+ }
+
+ } else {
+diff -dur xfburn-0.4.3.orig/xfburn/xfburn-utils.h xfburn-0.4.3/xfburn/xfburn-utils.h
+--- xfburn-0.4.3.orig/xfburn/xfburn-utils.h 2009-12-04 08:30:28.000000000 +0100
++++ xfburn-0.4.3/xfburn/xfburn-utils.h 2012-09-28 21:59:01.976954907 +0200
+@@ -27,6 +27,11 @@
+
+ #include "xfburn-global.h"
+
++/*
++#define XFBURN_GDK_ENTER() { DBG("gdk-thread-enter"); gdk_threads_enter(); }
++#define XFBURN_GDK_LEAVE() { DBG("gdk-thread-leave"); gdk_threads_leave(); }
++*/
++
+ void xfburn_busy_cursor (GtkWidget *);
+ void xfburn_default_cursor (GtkWidget *);
+