aboutsummaryrefslogtreecommitdiffstats
path: root/community/xfce4-cpufreq-plugin
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2018-04-23 19:44:46 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2018-04-23 19:44:46 +0000
commit27d1e194717b1696b3169ad43df027876247b91a (patch)
tree8416dc507bc2aed5f47588d345abe1ef22a6c60f /community/xfce4-cpufreq-plugin
parent0090cfe5db52bd764631d9b1d55e6e74c7cf2ae8 (diff)
downloadaports-27d1e194717b1696b3169ad43df027876247b91a.tar.bz2
aports-27d1e194717b1696b3169ad43df027876247b91a.tar.xz
main/{xfce*} => community/
Move everything xfce to community
Diffstat (limited to 'community/xfce4-cpufreq-plugin')
-rw-r--r--community/xfce4-cpufreq-plugin/APKBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/community/xfce4-cpufreq-plugin/APKBUILD b/community/xfce4-cpufreq-plugin/APKBUILD
new file mode 100644
index 0000000000..3202c42130
--- /dev/null
+++ b/community/xfce4-cpufreq-plugin/APKBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=xfce4-cpufreq-plugin
+pkgver=1.1.3
+pkgrel=2
+pkgdesc="CPU frequency plugin for the Xfce4 panel"
+url="http://goodies.xfce.org/projects/panel-plugins/xfce4-cpufreq-plugin"
+arch="all"
+license="GPL-2.0"
+depends=
+makedepends="xfce4-panel-dev libxfce4ui-dev"
+install=
+subpackages="$pkgname-lang"
+source="http://archive.xfce.org/src/panel-plugins/xfce4-cpufreq-plugin/${pkgver%.*}/xfce4-cpufreq-plugin-${pkgver}.tar.bz2"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+
+build() {
+ cd "$_builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --libexecdir=/usr/lib/xfce4 \
+ --localstatedir=/var \
+ --disable-static \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install
+}
+md5sums="859122da0a8cd991ee2fbeee434bc948 xfce4-cpufreq-plugin-1.1.3.tar.bz2"
+sha256sums="74a162c7e101db0495d5da147aba1f404c33544f04e8c34d7d1d705668102d33 xfce4-cpufreq-plugin-1.1.3.tar.bz2"
+sha512sums="fe67abc120c0715b653258abbafab19386289ce0a373e5053e544484219c3b05aafe1e84a23721f6603043db5aac24dc1230f2e7d4974ec483d5120aca11ca25 xfce4-cpufreq-plugin-1.1.3.tar.bz2"