aboutsummaryrefslogtreecommitdiffstats
path: root/community/xfce4-notes-plugin/APKBUILD
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2018-04-23 19:44:46 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2018-04-23 19:44:46 +0000
commit27d1e194717b1696b3169ad43df027876247b91a (patch)
tree8416dc507bc2aed5f47588d345abe1ef22a6c60f /community/xfce4-notes-plugin/APKBUILD
parent0090cfe5db52bd764631d9b1d55e6e74c7cf2ae8 (diff)
downloadaports-27d1e194717b1696b3169ad43df027876247b91a.tar.bz2
aports-27d1e194717b1696b3169ad43df027876247b91a.tar.xz
main/{xfce*} => community/
Move everything xfce to community
Diffstat (limited to 'community/xfce4-notes-plugin/APKBUILD')
-rw-r--r--community/xfce4-notes-plugin/APKBUILD48
1 files changed, 48 insertions, 0 deletions
diff --git a/community/xfce4-notes-plugin/APKBUILD b/community/xfce4-notes-plugin/APKBUILD
new file mode 100644
index 0000000000..f7cd7ef57b
--- /dev/null
+++ b/community/xfce4-notes-plugin/APKBUILD
@@ -0,0 +1,48 @@
+# Contributor:
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=xfce4-notes-plugin
+pkgver=1.8.1
+pkgrel=0
+pkgdesc="Notes plugin for the Xfce4 desktop"
+url="http://goodies.xfce.org/projects/panel-plugins/xfce4-notes-plugin"
+arch="all"
+license="GPL"
+depends=
+makedepends="xfce4-panel-dev libunique-dev libxfce4ui-dev"
+install=
+subpackages="$pkgname-lang"
+source="http://archive.xfce.org/src/panel-plugins/xfce4-notes-plugin/${pkgver%.*}/xfce4-notes-plugin-$pkgver.tar.bz2
+ "
+
+_builddir="$srcdir"/$pkgname-$pkgver
+
+prepare() {
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p0 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+md5sums="31cb9520b01512a94344770b4befdb3b xfce4-notes-plugin-1.8.1.tar.bz2"
+sha256sums="07a4c3e71431c24f97d2e270452dd0fa51ff0bdb6219a13a20d0bfa8d9de54b2 xfce4-notes-plugin-1.8.1.tar.bz2"
+sha512sums="3e3f2513aaa5d26880d21ba31458aa8b79c1e01cac47141513d61002df9535e52ca2c14a8da6cddd54fcab3bcda6199c636cce045cea9bd4548f5fc763e069f3 xfce4-notes-plugin-1.8.1.tar.bz2"