aboutsummaryrefslogtreecommitdiffstats
path: root/community/xfce4-settings
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2018-04-23 19:44:46 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2018-04-23 19:44:46 +0000
commit27d1e194717b1696b3169ad43df027876247b91a (patch)
tree8416dc507bc2aed5f47588d345abe1ef22a6c60f /community/xfce4-settings
parent0090cfe5db52bd764631d9b1d55e6e74c7cf2ae8 (diff)
downloadaports-27d1e194717b1696b3169ad43df027876247b91a.tar.bz2
aports-27d1e194717b1696b3169ad43df027876247b91a.tar.xz
main/{xfce*} => community/
Move everything xfce to community
Diffstat (limited to 'community/xfce4-settings')
-rw-r--r--community/xfce4-settings/APKBUILD45
-rw-r--r--community/xfce4-settings/alpine-defaults.patch25
2 files changed, 70 insertions, 0 deletions
diff --git a/community/xfce4-settings/APKBUILD b/community/xfce4-settings/APKBUILD
new file mode 100644
index 0000000000..cabcbd7404
--- /dev/null
+++ b/community/xfce4-settings/APKBUILD
@@ -0,0 +1,45 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=xfce4-settings
+pkgver=4.12.1
+pkgrel=1
+pkgdesc="Settings manager for xfce"
+url="https://xfce.org/"
+arch="all"
+license="GPL-2.0-only"
+depends=
+subpackages="$pkgname-lang"
+makedepends="libxfce4ui-dev exo-dev libxi-dev libxrandr-dev libxklavier-dev
+ libnotify-dev libxcursor-dev garcon-dev upower-dev libcanberra-dev
+ xf86-input-libinput-dev"
+source="http://archive.xfce.org/src/xfce/${pkgname}/${pkgver%.*}/${pkgname}-${pkgver}.tar.bz2
+ alpine-defaults.patch
+ "
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --disable-static \
+ --enable-libxklavier \
+ --enable-xrandr \
+ --enable-sound-settings \
+ --enable-xorg-libinput
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="20aca9c6337433b0b7165acfb373bce14e13e368345844799cfe71bcf433a38c4d1f57d3ffe01eda347d167c3098f46ac77d0364b64a2a59bbe82e45d76a9623 xfce4-settings-4.12.1.tar.bz2
+e0efdee2eaf833ae1ff8c428e3b2925191bdd3dad8a747705295d7c8bf170725906f4a96b3b332ba9ef958c4b5899448de6461b97503e997747e91d800138f8b alpine-defaults.patch"
diff --git a/community/xfce4-settings/alpine-defaults.patch b/community/xfce4-settings/alpine-defaults.patch
new file mode 100644
index 0000000000..b791be802d
--- /dev/null
+++ b/community/xfce4-settings/alpine-defaults.patch
@@ -0,0 +1,25 @@
+--- ./xfsettingsd/xsettings.xml.orig
++++ ./xfsettingsd/xsettings.xml
+@@ -6,8 +6,8 @@
+ <?xml version="1.0" encoding="UTF-8"?>
+ <channel name="xsettings" version="1.0">
+ <property name="Net" type="empty">
+- <property name="ThemeName" type="empty"/>
+- <property name="IconThemeName" type="empty"/>
++ <property name="ThemeName" type="string" value="Greybird"/>
++ <property name="IconThemeName" type="string" value="Faenza"/>
+ <property name="DoubleClickTime" type="int" value="400"/>
+ <property name="DoubleClickDistance" type="int" value="5"/>
+ <property name="DndDragThreshold" type="int" value="8"/>
+@@ -19,9 +19,9 @@
+ </property>
+ <property name="Xft" type="empty">
+ <property name="DPI" type="empty"/>
+- <property name="Antialias" type="int" value="-1"/>
++ <property name="Antialias" type="int" value="1"/>
+ <property name="Hinting" type="int" value="-1"/>
+- <property name="HintStyle" type="string" value="hintnone"/>
++ <property name="HintStyle" type="string" value="hintfull"/>
+ <property name="RGBA" type="string" value="none"/>
+ <!-- <property name="Lcdfilter" type="string" value="none"/> -->
+ </property>