aboutsummaryrefslogtreecommitdiffstats
path: root/community/xfce4-volumed
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2018-04-23 19:44:46 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2018-04-23 19:44:46 +0000
commit27d1e194717b1696b3169ad43df027876247b91a (patch)
tree8416dc507bc2aed5f47588d345abe1ef22a6c60f /community/xfce4-volumed
parent0090cfe5db52bd764631d9b1d55e6e74c7cf2ae8 (diff)
downloadaports-27d1e194717b1696b3169ad43df027876247b91a.tar.bz2
aports-27d1e194717b1696b3169ad43df027876247b91a.tar.xz
main/{xfce*} => community/
Move everything xfce to community
Diffstat (limited to 'community/xfce4-volumed')
-rw-r--r--community/xfce4-volumed/APKBUILD43
1 files changed, 43 insertions, 0 deletions
diff --git a/community/xfce4-volumed/APKBUILD b/community/xfce4-volumed/APKBUILD
new file mode 100644
index 0000000000..7a19456fb0
--- /dev/null
+++ b/community/xfce4-volumed/APKBUILD
@@ -0,0 +1,43 @@
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=xfce4-volumed
+pkgver=0.1.13
+pkgrel=1
+pkgdesc="Daemon to add additional functionality to the volume keys of the keyboard"
+url="https://launchpad.net/xfce4-volumed"
+arch="all"
+license="GPL-3.0-or-later"
+depends="xfce4-mixer"
+makedepends="xfconf-dev libnotify-dev gst-plugins-base0.10-dev keybinder-dev"
+install=""
+subpackages=""
+source="http://archive.xfce.org/src/apps/xfce4-volumed/0.1/xfce4-volumed-$pkgver.tar.bz2"
+
+_builddir="$srcdir"/xfce4-volumed-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --localstatedir=/var \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+sha512sums="7241b53f88b44e18a7501e775498701fe622c35b9304e883159dd98fc76745d50f23a192bb0416ccf301ddf393af7a3dc10c3057d77898c8e13d11fd058c801e xfce4-volumed-0.1.13.tar.bz2"