aboutsummaryrefslogtreecommitdiffstats
path: root/community/xfconf
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2018-04-23 19:44:46 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2018-04-23 19:44:46 +0000
commit27d1e194717b1696b3169ad43df027876247b91a (patch)
tree8416dc507bc2aed5f47588d345abe1ef22a6c60f /community/xfconf
parent0090cfe5db52bd764631d9b1d55e6e74c7cf2ae8 (diff)
downloadaports-27d1e194717b1696b3169ad43df027876247b91a.tar.bz2
aports-27d1e194717b1696b3169ad43df027876247b91a.tar.xz
main/{xfce*} => community/
Move everything xfce to community
Diffstat (limited to 'community/xfconf')
-rw-r--r--community/xfconf/APKBUILD43
1 files changed, 43 insertions, 0 deletions
diff --git a/community/xfconf/APKBUILD b/community/xfconf/APKBUILD
new file mode 100644
index 0000000000..cd298da73c
--- /dev/null
+++ b/community/xfconf/APKBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=xfconf
+pkgver=4.12.1
+pkgrel=2
+pkgdesc="Hierarchical configuration system for Xfce"
+url="https://xfce.org/"
+arch="all"
+license="GPL-2.0"
+options="!check" # Requires running dbus daemon.
+subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
+depends=
+makedepends="libxfce4util-dev intltool gtk-doc glib-dev dbus-dev dbus-glib-dev"
+source="http://archive.xfce.org/src/xfce/$pkgname/${pkgver%.*}/$pkgname-$pkgver.tar.bz2"
+
+
+builddir="$srcdir"/$pkgname-$pkgver
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --libexecdir=/usr/lib \
+ --localstatedir=/var \
+ --disable-static \
+ --enable-gtk-doc
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+md5sums="20dc8d2bfd80ba136bf4964021b32757 xfconf-4.12.1.tar.bz2"
+sha256sums="35f48564e5694faa54fdc180cd3268e16fc2352946a89a3c2fc12cbe400ada36 xfconf-4.12.1.tar.bz2"
+sha512sums="114dba6a78d43b25eebfd9ef78beec75391b0c77e736e66ae2b04fe97dc281f93d05467ddfdd63a5067f44de135347564fe55928ae7de72f0984339db411d77f xfconf-4.12.1.tar.bz2"