aboutsummaryrefslogtreecommitdiffstats
path: root/community/xkcdpass
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2017-12-26 13:34:28 +0000
committerJakub Jirutka <jakub@jirutka.cz>2017-12-28 01:16:13 +0100
commit31177453b771f023fb0a1dbb0edbea80eb142332 (patch)
tree4e67a22885932fc7d36773f718a34c29b3bef34e /community/xkcdpass
parent73a212fce0121a68d9bb22b67900d715b80c0645 (diff)
downloadaports-31177453b771f023fb0a1dbb0edbea80eb142332.tar.bz2
aports-31177453b771f023fb0a1dbb0edbea80eb142332.tar.xz
community/xkcdpass: upgrade to 1.14.3
Diffstat (limited to 'community/xkcdpass')
-rw-r--r--community/xkcdpass/APKBUILD8
-rw-r--r--community/xkcdpass/fix-bin-name.patch11
2 files changed, 3 insertions, 16 deletions
diff --git a/community/xkcdpass/APKBUILD b/community/xkcdpass/APKBUILD
index bfd65de8fb..1920c2f6e3 100644
--- a/community/xkcdpass/APKBUILD
+++ b/community/xkcdpass/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
pkgname=xkcdpass
-pkgver=1.14.2
+pkgver=1.14.3
pkgrel=0
pkgdesc="Generate secure multiword passwords/passphrases"
url="https://github.com/redacted/XKCD-password-generator"
@@ -10,8 +10,7 @@ license="BSD-3"
depends="py3-xkcdpass"
makedepends="python3-dev"
subpackages="py3-$pkgname:py3"
-source="https://files.pythonhosted.org/packages/source/${pkgname:0:1}/$pkgname/$pkgname-$pkgver.tar.gz
- fix-bin-name.patch"
+source="https://files.pythonhosted.org/packages/source/${pkgname:0:1}/$pkgname/$pkgname-$pkgver.tar.gz"
builddir="$srcdir"/$pkgname-$pkgver
build() {
@@ -36,5 +35,4 @@ py3() {
mv "$pkgdir"/usr/lib/python* "$subpkgdir"/usr/lib/
}
-sha512sums="3097cafb53fa4e9a1ae0c067ef8254660e73527653b32294ae5a7f61dec94382da088bace59406b9ae5ef47028320536746299ea3fb55eeede3286d60b52cb56 xkcdpass-1.14.2.tar.gz
-06a4f5c5384e64ed79eebfa3f5e679bcfd9d7d6b31f960fdad6bbe433c68e174e06edeed5ed542c1f7cd8e05e760bb55a29914019f957764f5d8ebc1ab6ea562 fix-bin-name.patch"
+sha512sums="51379601c88d2f6bd023f5e1be8ae00f4b24904171793726fb97b69a78701e59c513654963982de44821fad85916ae123867f2cdeee3c691fb7d813e49de6ac6 xkcdpass-1.14.3.tar.gz"
diff --git a/community/xkcdpass/fix-bin-name.patch b/community/xkcdpass/fix-bin-name.patch
deleted file mode 100644
index ad96945700..0000000000
--- a/community/xkcdpass/fix-bin-name.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- xkcdpass-1.14.2/tests/test_xkcdpass.py
-+++ xkcdpass-1.14.2/tests/test_xkcdpass.py.new
-@@ -32,7 +32,7 @@
- def test_commandlineCount(self):
- count = 5
- result = subprocess.check_output(
-- ["python", "xkcdpass/xkcd_password.py", "-w", WORDFILE,
-+ ["python3", "xkcdpass/xkcd_password.py", "-w", WORDFILE,
- "-c", str(count)])
- self.assertTrue(result.count(b"\n"), count)
-