aboutsummaryrefslogtreecommitdiffstats
path: root/community/xkcdpass
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2017-11-20 17:37:16 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2017-11-28 17:09:32 +0000
commit5d21bf5945f2ea2647aaa7f9daf8df7bc0e4ba39 (patch)
tree9f573b3ffee4e9d99d5932204a32bf31949b86a6 /community/xkcdpass
parent4f00e352fdfa2efb763e8ea314283a2cc1214ecf (diff)
downloadaports-5d21bf5945f2ea2647aaa7f9daf8df7bc0e4ba39.tar.bz2
aports-5d21bf5945f2ea2647aaa7f9daf8df7bc0e4ba39.tar.xz
community/xkcdpass: upgrade to 1.14.2
Diffstat (limited to 'community/xkcdpass')
-rw-r--r--community/xkcdpass/APKBUILD18
-rw-r--r--community/xkcdpass/fix-bin-name.patch11
2 files changed, 20 insertions, 9 deletions
diff --git a/community/xkcdpass/APKBUILD b/community/xkcdpass/APKBUILD
index 5f737d6417..bfd65de8fb 100644
--- a/community/xkcdpass/APKBUILD
+++ b/community/xkcdpass/APKBUILD
@@ -1,17 +1,17 @@
# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
pkgname=xkcdpass
-pkgver=1.14.1
+pkgver=1.14.2
pkgrel=0
pkgdesc="Generate secure multiword passwords/passphrases"
url="https://github.com/redacted/XKCD-password-generator"
arch="noarch"
license="BSD-3"
-options="!check"
depends="py3-xkcdpass"
makedepends="python3-dev"
subpackages="py3-$pkgname:py3"
-source="https://files.pythonhosted.org/packages/source/${pkgname:0:1}/$pkgname/$pkgname-$pkgver.tar.gz"
+source="https://files.pythonhosted.org/packages/source/${pkgname:0:1}/$pkgname/$pkgname-$pkgver.tar.gz
+ fix-bin-name.patch"
builddir="$srcdir"/$pkgname-$pkgver
build() {
@@ -19,11 +19,10 @@ build() {
python3 setup.py build
}
-# Will be ready with the next release
-#check() {
-# cd "$builddir"
-# python3 -m unittest tests/
-#}
+check() {
+ cd "$builddir"
+ python3 setup.py test
+}
package() {
cd "$builddir"
@@ -37,4 +36,5 @@ py3() {
mv "$pkgdir"/usr/lib/python* "$subpkgdir"/usr/lib/
}
-sha512sums="9a0c4c4b46c0d60a3ea59103c01d615c3660bc0b62f3f172a83a9acb4f9a066105b38f33cba7b0d2f7af93ba5da368a035066891ff0e5f3dca8cef90d2d50f85 xkcdpass-1.14.1.tar.gz"
+sha512sums="3097cafb53fa4e9a1ae0c067ef8254660e73527653b32294ae5a7f61dec94382da088bace59406b9ae5ef47028320536746299ea3fb55eeede3286d60b52cb56 xkcdpass-1.14.2.tar.gz
+06a4f5c5384e64ed79eebfa3f5e679bcfd9d7d6b31f960fdad6bbe433c68e174e06edeed5ed542c1f7cd8e05e760bb55a29914019f957764f5d8ebc1ab6ea562 fix-bin-name.patch"
diff --git a/community/xkcdpass/fix-bin-name.patch b/community/xkcdpass/fix-bin-name.patch
new file mode 100644
index 0000000000..ad96945700
--- /dev/null
+++ b/community/xkcdpass/fix-bin-name.patch
@@ -0,0 +1,11 @@
+--- xkcdpass-1.14.2/tests/test_xkcdpass.py
++++ xkcdpass-1.14.2/tests/test_xkcdpass.py.new
+@@ -32,7 +32,7 @@
+ def test_commandlineCount(self):
+ count = 5
+ result = subprocess.check_output(
+- ["python", "xkcdpass/xkcd_password.py", "-w", WORDFILE,
++ ["python3", "xkcdpass/xkcd_password.py", "-w", WORDFILE,
+ "-c", str(count)])
+ self.assertTrue(result.count(b"\n"), count)
+