aboutsummaryrefslogtreecommitdiffstats
path: root/community/xkcdpass
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2017-11-12 08:53:17 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2017-11-13 11:38:09 +0000
commita2ea39651c45e9d2dda1099d4bd414ebe7631cc6 (patch)
tree11c7c8a10314367c0f1708f9461fb57feba314eb /community/xkcdpass
parent82f0232422801814719b13b5423812ce62f850c7 (diff)
downloadaports-a2ea39651c45e9d2dda1099d4bd414ebe7631cc6.tar.bz2
aports-a2ea39651c45e9d2dda1099d4bd414ebe7631cc6.tar.xz
community/xkcdpass: upgrade to 1.14.1
Diffstat (limited to 'community/xkcdpass')
-rw-r--r--community/xkcdpass/APKBUILD13
1 files changed, 10 insertions, 3 deletions
diff --git a/community/xkcdpass/APKBUILD b/community/xkcdpass/APKBUILD
index 4a39c15711..5f737d6417 100644
--- a/community/xkcdpass/APKBUILD
+++ b/community/xkcdpass/APKBUILD
@@ -1,12 +1,13 @@
# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
pkgname=xkcdpass
-pkgver=1.13.0
+pkgver=1.14.1
pkgrel=0
pkgdesc="Generate secure multiword passwords/passphrases"
url="https://github.com/redacted/XKCD-password-generator"
arch="noarch"
license="BSD-3"
+options="!check"
depends="py3-xkcdpass"
makedepends="python3-dev"
subpackages="py3-$pkgname:py3"
@@ -15,9 +16,15 @@ builddir="$srcdir"/$pkgname-$pkgver
build() {
cd "$builddir"
- python3 setup.py build || return 1
+ python3 setup.py build
}
+# Will be ready with the next release
+#check() {
+# cd "$builddir"
+# python3 -m unittest tests/
+#}
+
package() {
cd "$builddir"
python3 setup.py install --prefix=/usr --root="$pkgdir"
@@ -30,4 +37,4 @@ py3() {
mv "$pkgdir"/usr/lib/python* "$subpkgdir"/usr/lib/
}
-sha512sums="ac86559a7b6198786b75868e70452ca9a1e99c8cd6d13d82e47ef07f26e34928c293dffbcf092dd5c463e03c7eb85f7eac287205ac55f17ead9d1eb52056ba70 xkcdpass-1.13.0.tar.gz"
+sha512sums="9a0c4c4b46c0d60a3ea59103c01d615c3660bc0b62f3f172a83a9acb4f9a066105b38f33cba7b0d2f7af93ba5da368a035066891ff0e5f3dca8cef90d2d50f85 xkcdpass-1.14.1.tar.gz"