aboutsummaryrefslogtreecommitdiffstats
path: root/community/xkcdpass
diff options
context:
space:
mode:
authortcely <tcely@users.noreply.github.com>2018-04-12 13:21:20 -0400
committerTimo Teräs <timo.teras@iki.fi>2018-04-13 05:55:49 +0000
commitba23ae80f663874ded2f9cc7f18fa2179021f394 (patch)
tree64eabc6ed4e05628a081123ec91716446bfca301 /community/xkcdpass
parent228a7af4a5f9814dad4ac638df9a1842ab091535 (diff)
downloadaports-ba23ae80f663874ded2f9cc7f18fa2179021f394.tar.bz2
aports-ba23ae80f663874ded2f9cc7f18fa2179021f394.tar.xz
community/xkcdpass: upgrade to 1.16.5
Diffstat (limited to 'community/xkcdpass')
-rw-r--r--community/xkcdpass/APKBUILD8
-rw-r--r--community/xkcdpass/python-to-python3.patch24
2 files changed, 5 insertions, 27 deletions
diff --git a/community/xkcdpass/APKBUILD b/community/xkcdpass/APKBUILD
index 120d32ce64..52cd02b1ca 100644
--- a/community/xkcdpass/APKBUILD
+++ b/community/xkcdpass/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
pkgname=xkcdpass
-pkgver=1.16.3
-pkgrel=1
+pkgver=1.16.5
+pkgrel=0
pkgdesc="Generate secure multiword passwords/passphrases"
url="https://github.com/redacted/XKCD-password-generator"
arch="noarch"
@@ -37,5 +37,5 @@ py3() {
mv "$pkgdir"/usr/lib/python* "$subpkgdir"/usr/lib/
}
-sha512sums="cc216244bc1fa75e286369432c9d3dd92ad150a752d8d58bcf461bf2f1eaf535054b8c92259b66217fad0ec1030e53b52429721c8d2b920a23813e9737955fe3 xkcdpass-1.16.3.tar.gz
-ad0e4973c5622405f4002181c1678e9c71b03fb2833256423007fa2cd7a2068591124c31ff1e091411fe029646bb01c2a4c3b6b2a068e3530e6db57671df9968 python-to-python3.patch"
+sha512sums="dc0ffdb0b651f5f0fb1eb3276d3e3d849d0d63f9a9b18fe4f5eaa87eab3e90d1292d411e3909c881621b3e330b5a3ac5f9905b27ad048ab33d84c3fdc8428087 xkcdpass-1.16.5.tar.gz
+23a7c50a96e7d854bdbfdb87852229b147d1f892d05f9d64d899199c0eb7276638c908f8dee17880cf4f611a17565ce1c117c5dfaca9117379ce1e7655f30808 python-to-python3.patch"
diff --git a/community/xkcdpass/python-to-python3.patch b/community/xkcdpass/python-to-python3.patch
index 6f7ca186e7..a80109612f 100644
--- a/community/xkcdpass/python-to-python3.patch
+++ b/community/xkcdpass/python-to-python3.patch
@@ -8,30 +8,8 @@ index 069fb6e..057ea30 100755
import fileinput
import random
import sys
-diff --git a/tests/test_xkcdpass.py b/tests/test_xkcdpass.py
-index 88579fd..6821d1f 100755
---- a/tests/test_xkcdpass.py
-+++ b/tests/test_xkcdpass.py
-@@ -50,7 +50,7 @@ class XkcdPasswordTests(unittest.TestCase):
- def test_separator(self):
- count = 3
- result = subprocess.check_output(
-- ["python", "xkcdpass/xkcd_password.py",
-+ ["python3", "xkcdpass/xkcd_password.py",
- "--count", str(count),
- "--delimiter", "|",
- "--separator", " "])
-@@ -60,7 +60,7 @@ class XkcdPasswordTests(unittest.TestCase):
- "Pipe output to other program. e.g. `xkcdpass -c 1 -s "" | xsel -b`"
- count = 1
- result = subprocess.check_output(
-- ["python", "xkcdpass/xkcd_password.py",
-+ ["python3", "xkcdpass/xkcd_password.py",
- "--count", str(count),
- "--separator", ""])
- self.assertEqual(result.find(b"\n"), -1)
diff --git a/xkcdpass/xkcd_password.py b/xkcdpass/xkcd_password.py
-index 78b0b69..07cc7b6 100755
+index fe4d8a8..31274ef 100755
--- a/xkcdpass/xkcd_password.py
+++ b/xkcdpass/xkcd_password.py
@@ -1,4 +1,4 @@