aboutsummaryrefslogtreecommitdiffstats
path: root/community/xkcdpass
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2016-11-10 17:47:43 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2017-06-06 17:54:26 +0000
commitedbcb0df53514c0698f4c291efa5822be61620f9 (patch)
treeb7754ef219be2c6e19d560857c7e10271ce131d3 /community/xkcdpass
parent1507bba511919838fd1e5d5f74694c0316fd5160 (diff)
downloadaports-edbcb0df53514c0698f4c291efa5822be61620f9.tar.bz2
aports-edbcb0df53514c0698f4c291efa5822be61620f9.tar.xz
testing/xkcdpass: move to community
Diffstat (limited to 'community/xkcdpass')
-rw-r--r--community/xkcdpass/APKBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/community/xkcdpass/APKBUILD b/community/xkcdpass/APKBUILD
new file mode 100644
index 0000000000..5804c77edf
--- /dev/null
+++ b/community/xkcdpass/APKBUILD
@@ -0,0 +1,35 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=xkcdpass
+pkgver=1.9.0
+pkgrel=0
+pkgdesc="Generate secure multiword passwords/passphrases"
+url="https://github.com/redacted/XKCD-password-generator"
+arch="noarch"
+license="BSD"
+depends="py3-xkcdpass"
+makedepends="python3-dev"
+subpackages="py3-$pkgname:py3"
+source="https://files.pythonhosted.org/packages/source/${pkgname:0:1}/$pkgname/$pkgname-$pkgver.tar.gz"
+builddir="$srcdir"/$pkgname-$pkgver
+
+build() {
+ cd "$builddir"
+ python3 setup.py build || return 1
+}
+
+package() {
+ cd "$builddir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+py3() {
+ pkgdesc="Python library for $pkgname"
+ depends="python3"
+ mkdir -p "$subpkgdir"/usr/lib
+ mv "$pkgdir"/usr/lib/python* "$subpkgdir"/usr/lib/
+}
+
+md5sums="e660c17fff2682b97ce7f878f5ee11ec xkcdpass-1.9.0.tar.gz"
+sha256sums="5b143156c4cff9684e6885be3cfa028622424724af0dc6ca688eb930f2999b7f xkcdpass-1.9.0.tar.gz"
+sha512sums="6b5d59a98e8b9b2c8f92814ab13581473477991354bf8e13d2b66c5d6b7b32c49352082cd4d234a9606c223e03427f099fbd49dc0c79140cca18027157dac5c6 xkcdpass-1.9.0.tar.gz"