aboutsummaryrefslogtreecommitdiffstats
path: root/community/yaml-cpp
diff options
context:
space:
mode:
authorRoberto Oliveira <robertoguimaraes8@gmail.com>2018-04-30 10:44:10 +0000
committerRoberto Oliveira <robertoguimaraes8@gmail.com>2018-04-30 10:44:10 +0000
commit4d291283ad8aec3f813a2bbbe098e5c0c917dfaa (patch)
treed1788e9cb38f9bec24ee62eb52ccc97016a61800 /community/yaml-cpp
parent1b358127ecf53f2c51d56da95735a1de3af882e1 (diff)
downloadaports-4d291283ad8aec3f813a2bbbe098e5c0c917dfaa.tar.bz2
aports-4d291283ad8aec3f813a2bbbe098e5c0c917dfaa.tar.xz
community/yaml-cpp: add check
Diffstat (limited to 'community/yaml-cpp')
-rw-r--r--community/yaml-cpp/APKBUILD8
1 files changed, 6 insertions, 2 deletions
diff --git a/community/yaml-cpp/APKBUILD b/community/yaml-cpp/APKBUILD
index 39a0ee665b..23c69c1aa8 100644
--- a/community/yaml-cpp/APKBUILD
+++ b/community/yaml-cpp/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
pkgname=yaml-cpp
pkgver=0.6.2
-pkgrel=0
+pkgrel=1
pkgdesc="YAML parser and emitter in C++ matching YAML 1.2 spec"
url="https://github.com/jbeder/yaml-cpp"
arch="all"
@@ -10,7 +10,6 @@ license="MIT"
depends=""
makedepends="cmake"
subpackages="$pkgname-dev"
-options="!check"
source="https://github.com/jbeder/yaml-cpp/archive/yaml-cpp-$pkgver.tar.gz"
builddir="$srcdir/$pkgname-$pkgname-$pkgver"
@@ -23,6 +22,11 @@ build() {
make
}
+check() {
+ cd "$builddir"/build
+ make test
+}
+
package() {
cd "$builddir"/build
make DESTDIR="$pkgdir" install