aboutsummaryrefslogtreecommitdiffstats
path: root/community/yaml-cpp
diff options
context:
space:
mode:
authorRoberto Oliveira <robertoguimaraes8@gmail.com>2018-03-21 10:05:34 +0000
committerRoberto Oliveira <robertoguimaraes8@gmail.com>2018-03-21 12:03:06 +0000
commit85d99b975dad3a195062c87217a94facf5d76e4d (patch)
tree819724ed1c5b77ceb7970de55142899bc7a8466b /community/yaml-cpp
parentb48236284f7c74dcfd833a5d0a35c8350e9a91d2 (diff)
downloadaports-85d99b975dad3a195062c87217a94facf5d76e4d.tar.bz2
aports-85d99b975dad3a195062c87217a94facf5d76e4d.tar.xz
community/yaml-cpp: upgrade to 0.6.2
Remove boost dependency that is no more needed
Diffstat (limited to 'community/yaml-cpp')
-rw-r--r--community/yaml-cpp/APKBUILD11
1 files changed, 4 insertions, 7 deletions
diff --git a/community/yaml-cpp/APKBUILD b/community/yaml-cpp/APKBUILD
index 7043cb4b1a..39a0ee665b 100644
--- a/community/yaml-cpp/APKBUILD
+++ b/community/yaml-cpp/APKBUILD
@@ -1,16 +1,14 @@
# Contributor: Mark Riedesel <mark@klowner.com>
# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
pkgname=yaml-cpp
-pkgver=0.5.3
-pkgrel=4
+pkgver=0.6.2
+pkgrel=0
pkgdesc="YAML parser and emitter in C++ matching YAML 1.2 spec"
url="https://github.com/jbeder/yaml-cpp"
arch="all"
license="MIT"
depends=""
-# Note: dependency on boost-dev is planned to be removed in next release (0.6).
-depends_dev="boost-dev"
-makedepends="$depends_dev cmake"
+makedepends="cmake"
subpackages="$pkgname-dev"
options="!check"
source="https://github.com/jbeder/yaml-cpp/archive/yaml-cpp-$pkgver.tar.gz"
@@ -18,7 +16,6 @@ builddir="$srcdir/$pkgname-$pkgname-$pkgver"
build() {
cd "$builddir"
-
mkdir -p build && cd build
cmake .. \
-DCMAKE_INSTALL_PREFIX=/usr \
@@ -31,4 +28,4 @@ package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="fb8683e2b9847dac7e222185816637ccbec3b429abe8965169349ca9a10983692f1d78fd03c522490efd29962157cd3df25cd4f2e2fec2149d28d0df8e136dd3 yaml-cpp-0.5.3.tar.gz"
+sha512sums="fea8ce0a20a00cbc75023d1db442edfcd32d0ac57a3c41b32ec8d56f87cc1d85d7dd7a923ce662f5d3a315f91a736d6be0d649997acd190915c1d68cc93795e4 yaml-cpp-0.6.2.tar.gz"