aboutsummaryrefslogtreecommitdiffstats
path: root/community/yaml-cpp
diff options
context:
space:
mode:
authorLeonardo Arena <rnalrd@alpinelinux.org>2017-04-21 15:13:12 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2017-04-21 15:13:12 +0000
commitf94cf087913dbb8078047a2b0ddece29fdb82dde (patch)
treef0ec349456da2ff3e685ae9c08cbcf326456f8ad /community/yaml-cpp
parentbb35f683a2b742f42657e61b28f981e209231104 (diff)
downloadaports-f94cf087913dbb8078047a2b0ddece29fdb82dde.tar.bz2
aports-f94cf087913dbb8078047a2b0ddece29fdb82dde.tar.xz
community/yaml-cpp: moved from testing
Diffstat (limited to 'community/yaml-cpp')
-rw-r--r--community/yaml-cpp/APKBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/community/yaml-cpp/APKBUILD b/community/yaml-cpp/APKBUILD
new file mode 100644
index 0000000000..f1ed8f30e5
--- /dev/null
+++ b/community/yaml-cpp/APKBUILD
@@ -0,0 +1,34 @@
+# Contributor: Mark Riedesel <mark@klowner.com>
+# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
+pkgname=yaml-cpp
+pkgver=0.5.3
+pkgrel=3
+pkgdesc="YAML parser and emitter in C++ matching YAML 1.2 spec"
+url="https://github.com/jbeder/yaml-cpp"
+arch="all"
+license="MIT"
+depends=""
+# Note: dependency on boost-dev is planned to be removed in next release (0.6).
+depends_dev="boost-dev"
+makedepends="$depends_dev cmake"
+subpackages="$pkgname-dev"
+options="!check"
+source="https://github.com/jbeder/yaml-cpp/archive/yaml-cpp-$pkgver.tar.gz"
+builddir="$srcdir/$pkgname-$pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+
+ mkdir -p build && cd build
+ cmake .. \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DBUILD_SHARED_LIBS=ON
+ make
+}
+
+package() {
+ cd "$builddir"/build
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="cb11acccc5261e4513b597becf6be5d7fef05ef89a11eda3fc7db9e513adf953a2ec9c1bf70b91277076d793f0c65a496c7243d9b4a4240623e5f7034f8d4ad3 yaml-cpp-0.5.3.tar.gz"