aboutsummaryrefslogtreecommitdiffstats
path: root/community/yelp-xsl
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2015-11-19 14:50:33 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2015-11-19 15:12:33 +0000
commit6956d360f25458ab11442058c0c793c5529898e2 (patch)
tree8da4074dee42059a3da5174c875e39391f3797b9 /community/yelp-xsl
parent66aaa088a428332cd4b26ffcbbce63adc21fe5a9 (diff)
downloadaports-6956d360f25458ab11442058c0c793c5529898e2.tar.bz2
aports-6956d360f25458ab11442058c0c793c5529898e2.tar.xz
community/yelp-*: move from main
Diffstat (limited to 'community/yelp-xsl')
-rw-r--r--community/yelp-xsl/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/community/yelp-xsl/APKBUILD b/community/yelp-xsl/APKBUILD
new file mode 100644
index 0000000000..29ac8cd141
--- /dev/null
+++ b/community/yelp-xsl/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: Alan Lacerda <alacerda@alpinelinux.org>
+# Maintainer: Alan Lacerda <alacerda@alpinelinux.org>
+pkgname=yelp-xsl
+pkgver=3.16.1
+pkgrel=0
+pkgdesc="A collection of programs and data files to help you build,maintain, and distribute documentation."
+url="https://wiki.gnome.org/Apps/Yelp"
+arch="noarch"
+license="GPL/LGPL/MIT"
+depends=""
+depends_dev=""
+makedepends="intltool libxslt itstool"
+install=""
+subpackages=""
+source="http://ftp.gnome.org/pub/gnome/sources/$pkgname/3.16/$pkgname-$pkgver.tar.xz"
+
+_builddir="$srcdir/$pkgname-$pkgver"
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="${pkgdir}" install || return 1
+}
+
+md5sums="92871729425199f9a4374b8035f60a03 yelp-xsl-3.16.1.tar.xz"
+sha256sums="3295eecc4b03d2a239f7a1bdf4a1311d34c46c3055e6535c1f72bb5a49b4174a yelp-xsl-3.16.1.tar.xz"
+sha512sums="a4a51cbb036d93ffd8884218bd659cc634c632399ec70409c6128627a0c854a5b0a33a5f584614106fa3600dca674a24b18a06a6752ee93c130bf261580a1ccc yelp-xsl-3.16.1.tar.xz"