aboutsummaryrefslogtreecommitdiffstats
path: root/community/you-get
diff options
context:
space:
mode:
authorIvan Tham <pickfire@riseup.net>2017-05-24 22:43:01 +0800
committerLeonardo Arena <rnalrd@alpinelinux.org>2017-05-30 06:17:48 +0000
commiteec9f61606531c72d3c5f4c9b4985ba8af0668d5 (patch)
treebcac1df23aca7405f1f18e8d5f555737d6ce1bc3 /community/you-get
parent4d0c50eaa0cd0ec122e4d50d5e8c39dc88f48436 (diff)
downloadaports-eec9f61606531c72d3c5f4c9b4985ba8af0668d5.tar.bz2
aports-eec9f61606531c72d3c5f4c9b4985ba8af0668d5.tar.xz
testing/you-get: upgrade to 0.4.750 and move from testing
Diffstat (limited to 'community/you-get')
-rw-r--r--community/you-get/APKBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/community/you-get/APKBUILD b/community/you-get/APKBUILD
new file mode 100644
index 0000000000..b58d34a58f
--- /dev/null
+++ b/community/you-get/APKBUILD
@@ -0,0 +1,31 @@
+# Contributor: Ivan Tham <pickfire@riseup.net>
+# Maintainer: Ivan Tham <pickfire@riseup.net>
+pkgname=you-get
+pkgver=0.4.750
+pkgrel=0
+pkgdesc="Tiny command line utility to download media contents"
+url="https://you-get.org/"
+arch="noarch"
+license="MIT"
+depends="python3"
+makedepends="python3-dev"
+subpackages=""
+source="https://files.pythonhosted.org/packages/source/${pkgname:0:1}/$pkgname/$pkgname-$pkgver.tar.gz"
+builddir="$srcdir/"$pkgname-$pkgver
+
+build() {
+ cd "$builddir"
+ python3 setup.py build
+}
+
+check() {
+ cd "$builddir"
+ python3 setup.py check
+}
+
+package() {
+ cd "$builddir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="3d328ecca33d2c2a376056aec22af742922fdfa57eee5a504e8741ba54e3ff8cb3499c2bc6c7689c11a5b2aa4bcbb37d8dc434a116875ff041adaf831e146419 you-get-0.4.750.tar.gz"