aboutsummaryrefslogtreecommitdiffstats
path: root/community/z3
diff options
context:
space:
mode:
authorMike Sullivan <mksully22@gmail.com>2018-07-31 23:23:34 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2018-08-03 14:30:35 +0000
commitf95c00756f52d0622e918118b412406dea8a4ee4 (patch)
treed65088a9fb17d26dd178987d42c70784f2a86bce /community/z3
parente697372910202d55c446edd4d65c42fbe0ed88ff (diff)
downloadaports-f95c00756f52d0622e918118b412406dea8a4ee4.tar.bz2
aports-f95c00756f52d0622e918118b412406dea8a4ee4.tar.xz
community/z3: fix ppc64le by setting proper ptr width
Diffstat (limited to 'community/z3')
-rw-r--r--community/z3/APKBUILD10
-rw-r--r--community/z3/fix-ppc64le-ptr-size.patch11
2 files changed, 17 insertions, 4 deletions
diff --git a/community/z3/APKBUILD b/community/z3/APKBUILD
index 7772fa03e6..4ac0546e8a 100644
--- a/community/z3/APKBUILD
+++ b/community/z3/APKBUILD
@@ -2,16 +2,17 @@
# Maintainer: Sören Tempel <soeren+alpine@soeren-tempel.net>
pkgname=z3
pkgver=4.7.1
-pkgrel=0
+pkgrel=1
pkgdesc="Theorem prover from Microsoft Research"
url="https://github.com/Z3Prover/z3"
-arch="all !s390x !ppc64le !aarch64"
+arch="all !s390x !aarch64"
license="MIT"
depends=""
makedepends="cmake python3"
install=""
subpackages="$pkgname-dev py3-$pkgname:py3:noarch"
-source="https://github.com/Z3Prover/$pkgname/archive/$pkgname-$pkgver.tar.gz"
+source="https://github.com/Z3Prover/$pkgname/archive/$pkgname-$pkgver.tar.gz
+ fix-ppc64le-ptr-size.patch"
builddir="$srcdir/$pkgname-$pkgname-$pkgver"
build() {
@@ -53,4 +54,5 @@ py3() {
"$subpkgdir"/usr/lib/
}
-sha512sums="4c8c856691134298c4b5e465d6fadfe446532dfcd8c92aed7c9a6bbfc8557074a45cd7316dbfa5045824e2504db159afeb8ff676d4bfc942496623cf31d11aa0 z3-4.7.1.tar.gz"
+sha512sums="4c8c856691134298c4b5e465d6fadfe446532dfcd8c92aed7c9a6bbfc8557074a45cd7316dbfa5045824e2504db159afeb8ff676d4bfc942496623cf31d11aa0 z3-4.7.1.tar.gz
+3d019959a104b5fd5f72eeb3738cacbdb145764ad4844eeb2539b36fa3a8228ffa062a0899465d4881b6c226301aa09b129ef06a798744b2eec9f943e0d9d366 fix-ppc64le-ptr-size.patch"
diff --git a/community/z3/fix-ppc64le-ptr-size.patch b/community/z3/fix-ppc64le-ptr-size.patch
new file mode 100644
index 0000000000..cdf5e2156f
--- /dev/null
+++ b/community/z3/fix-ppc64le-ptr-size.patch
@@ -0,0 +1,11 @@
+--- a/src/util/machine.h
++++ b/src/util/machine.h
+@@ -20,7 +20,7 @@
+ #ifndef MACHINE_H_
+ #define MACHINE_H_
+
+-#ifdef _AMD64_
++#if defined(_AMD64_) || defined(__powerpc64__)
+ #define PTR_ALIGNMENT 3
+ #else
+ #define PTR_ALIGNMENT 2