aboutsummaryrefslogtreecommitdiffstats
path: root/community/zabbix
diff options
context:
space:
mode:
authorSergey Kuritsin <am813nt@gmail.com>2018-08-01 23:37:54 +0300
committerShiz <hi@shiz.me>2018-08-05 18:36:11 +0200
commit8f5a2d8751af57b7946298d80778d295b09d2d1f (patch)
treed8deb6fd0c8aad0ffe5764a2733f281744d6f8da /community/zabbix
parent0733fa4c8e86a872fd4518e9c268da1b811026ec (diff)
downloadaports-8f5a2d8751af57b7946298d80778d295b09d2d1f.tar.bz2
aports-8f5a2d8751af57b7946298d80778d295b09d2d1f.tar.xz
community/zabbix: pass --export-dynamic to the linker
Diffstat (limited to 'community/zabbix')
-rw-r--r--community/zabbix/APKBUILD9
1 files changed, 6 insertions, 3 deletions
diff --git a/community/zabbix/APKBUILD b/community/zabbix/APKBUILD
index 22a369188b..4f79cfb367 100644
--- a/community/zabbix/APKBUILD
+++ b/community/zabbix/APKBUILD
@@ -4,7 +4,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=zabbix
pkgver=3.4.12
-pkgrel=0
+pkgrel=1
pkgdesc="Enterprise-class open source distributed monitoring"
url="http://www.zabbix.com"
arch="all"
@@ -73,8 +73,11 @@ build() {
--with-ssh2 \
--with-gnutls
"
- # we run build for each db type
- # make sure prepare is same for each db
+ # pass --export-dynamic to the linker
+ # to make zabbix loadable modules work
+ LDFLAGS="$LDFLAGS -Wl,--export-dynamic"
+ # we run build for each db type
+ # make sure prepare is same for each db
for db in postgresql mysql sqlite3; do
cd "$srcdir"
msg "Building for $db"