aboutsummaryrefslogtreecommitdiffstats
path: root/community/zabbix
diff options
context:
space:
mode:
authorLeonardo Arena <rnalrd@alpinelinux.org>2017-09-27 14:47:58 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2017-09-27 14:59:12 +0000
commitc443ff3188ddc6e72ce25bfca5ed757dd562a3d7 (patch)
tree13afaa8ad1a5e33b00812d02107d5e6a405c18bf /community/zabbix
parentbf25fdd49a7e9cf429c31be3752cb4ce6dcd506e (diff)
downloadaports-c443ff3188ddc6e72ce25bfca5ed757dd562a3d7.tar.bz2
aports-c443ff3188ddc6e72ce25bfca5ed757dd562a3d7.tar.xz
community/zabbix: re-enable sqlite as proxy backend
Diffstat (limited to 'community/zabbix')
-rw-r--r--community/zabbix/APKBUILD34
1 files changed, 23 insertions, 11 deletions
diff --git a/community/zabbix/APKBUILD b/community/zabbix/APKBUILD
index a83cbeb88a..69397c4786 100644
--- a/community/zabbix/APKBUILD
+++ b/community/zabbix/APKBUILD
@@ -4,7 +4,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=zabbix
pkgver=3.4.1
-pkgrel=0
+pkgrel=1
pkgdesc="Enterprise-class open source distributed monitoring"
url="http://www.zabbix.com"
arch="all"
@@ -21,7 +21,7 @@ makedepends="postgresql-dev curl-dev net-snmp-dev libevent-dev pcre-dev
install="$pkgname.pre-install"
pkgusers="zabbix"
pkggroups="zabbix"
-subpackages="$pkgname-doc $pkgname-agent $pkgname-pgsql $pkgname-mysql
+subpackages="$pkgname-doc $pkgname-agent $pkgname-pgsql $pkgname-mysql $pkgname-sqlite
$pkgname-webif::noarch $pkgname-utils $pkgname-setup::noarch"
source="http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.gz
zabbix-server.initd
@@ -76,7 +76,6 @@ build() {
--sysconfdir=/etc/zabbix \
--mandir=/usr/share/man \
--infodir=/usr/share/info \
- --enable-server \
--enable-agent \
--enable-proxy \
--enable-ipv6 \
@@ -90,17 +89,28 @@ build() {
"
# we run build for each db type
# make sure prepare is same for each db
- for db in postgresql mysql; do
+ for db in postgresql mysql sqlite3; do
cd "$srcdir"
msg "Building for $db"
cp -r "$pkgname-$pkgver" "$pkgname-$pkgver-$db"
cd "$_builddir-$db"
- ./configure \
- --build=$CBUILD \
- --host=$CHOST \
- --with-$db \
- $_configure \
+ case $db in
+ sqlite3)
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --with-$db \
+ $_configure \
+ ;;
+ *)
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --enable-server \
+ --with-$db \
+ $_configure \
|| return 1
+ esac
make || return 1
done
}
@@ -139,8 +149,10 @@ _do_db() {
depends="$pkgname $2"
local i=
mkdir -p "$subpkgdir"/usr/sbin
- mv "$_builddir-$1"/src/zabbix_server/zabbix_server \
- "$subpkgdir"/usr/sbin/ || return 1
+ if [ "$1" != "sqlite3" ]; then
+ mv "$_builddir-$1"/src/zabbix_server/zabbix_server \
+ "$subpkgdir"/usr/sbin/ || return 1
+ fi
mv "$_builddir-$1"/src/zabbix_proxy/zabbix_proxy \
"$subpkgdir"/usr/sbin/ || return 1
install -D -m0644 "$_builddir"/conf/zabbix_proxy.conf \