aboutsummaryrefslogtreecommitdiffstats
path: root/community/zsh-autosuggestions
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2018-04-29 00:22:06 +0200
committerJakub Jirutka <jakub@jirutka.cz>2018-04-29 00:22:06 +0200
commit0e6b66fe398f3c1f5e9e2cd44ba6562c645ceb77 (patch)
tree8f21449f12e43fb38d91f1e72e539caca26884ba /community/zsh-autosuggestions
parent44805dbed3dbd1038a9b6d3ee6032c956f741754 (diff)
downloadaports-0e6b66fe398f3c1f5e9e2cd44ba6562c645ceb77.tar.bz2
aports-0e6b66fe398f3c1f5e9e2cd44ba6562c645ceb77.tar.xz
community/zsh-autosuggestions: move from testing
Diffstat (limited to 'community/zsh-autosuggestions')
-rw-r--r--community/zsh-autosuggestions/APKBUILD22
1 files changed, 22 insertions, 0 deletions
diff --git a/community/zsh-autosuggestions/APKBUILD b/community/zsh-autosuggestions/APKBUILD
new file mode 100644
index 0000000000..0654b99ac5
--- /dev/null
+++ b/community/zsh-autosuggestions/APKBUILD
@@ -0,0 +1,22 @@
+# Contributor: Jakub Jirutka <jakub@jirutka.cz>
+# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
+pkgname=zsh-autosuggestions
+pkgver=0.4.2
+pkgrel=0
+pkgdesc="Fish-like autosuggestions for Zsh"
+url="https://github.com/zsh-users/zsh-autosuggestions"
+arch="noarch"
+license="MIT"
+depends="zsh"
+source="$pkgname-$pkgver.tar.gz::https://github.com/zsh-users/$pkgname/archive/v$pkgver.tar.gz"
+builddir="$srcdir/$pkgname-$pkgver"
+
+package() {
+ local destdir="$pkgdir/usr/share/zsh/plugins/$pkgname"
+ cd "$builddir"
+
+ mkdir -p "$destdir"
+ cp $pkgname.zsh $pkgname.plugin.zsh "$destdir"/
+}
+
+sha512sums="67aae94211e6666d3a0f539509142d94b03ceb3d171e92b26fbf1a5a86185af515af07b9c244e258da321f1116624e6ed85eb77df73bd89e76246d415a18852b zsh-autosuggestions-0.4.2.tar.gz"