aboutsummaryrefslogtreecommitdiffstats
path: root/community/zsh-syntax-highlighting
diff options
context:
space:
mode:
authorDawid Dziurla <dawidd0811@gmail.com>2018-04-03 13:18:32 +0200
committerTimo Teräs <timo.teras@iki.fi>2018-04-05 06:18:46 +0000
commit10f67ef27f4489e83f31d62c2e5ba237373fb619 (patch)
treed1a4e2ca2607fe1731500d21d61ff466e464417a /community/zsh-syntax-highlighting
parent3604adfc20376f43c65831700e459109afa05389 (diff)
downloadaports-10f67ef27f4489e83f31d62c2e5ba237373fb619.tar.bz2
aports-10f67ef27f4489e83f31d62c2e5ba237373fb619.tar.xz
testing/zsh-syntax-highlighting: move to community
Diffstat (limited to 'community/zsh-syntax-highlighting')
-rw-r--r--community/zsh-syntax-highlighting/APKBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/community/zsh-syntax-highlighting/APKBUILD b/community/zsh-syntax-highlighting/APKBUILD
new file mode 100644
index 0000000000..36479b966c
--- /dev/null
+++ b/community/zsh-syntax-highlighting/APKBUILD
@@ -0,0 +1,31 @@
+# Contributor: Dawid Dziurla <dawidd0811@gmail.com>
+# Maintainer: Dawid Dziurla <dawidd0811@gmail.com>
+pkgname=zsh-syntax-highlighting
+pkgver=0.6.0
+pkgrel=0
+pkgdesc="Fish shell like syntax highlighting for Zsh"
+url="https://github.com/zsh-users/zsh-syntax-highlighting"
+arch="noarch"
+license="BSD-3-Clause"
+depends="zsh"
+subpackages="$pkgname-doc"
+source="$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz"
+builddir="$srcdir/$pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ make
+}
+
+check() {
+ cd "$builddir"
+ make test
+}
+
+package() {
+ cd "$builddir"
+ make install DESTDIR="$pkgdir" PREFIX="/usr" \
+ SHARE_DIR="$pkgdir/usr/share/zsh/plugins/$pkgname"
+}
+
+sha512sums="bb83f41336e9010aa78ee5adc9a216ee53f3b4347041d1b273083940d9db4d0e4acd960150b28c41f6e5e8d00b029f00fca6f9a46955892e4547a9f2345e3b85 zsh-syntax-highlighting-0.6.0.tar.gz"