aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
authortmpfile <tmpfile@users.noreply.github.com>2017-05-13 14:00:58 -0300
committerShiz <hi@shiz.me>2017-05-14 03:31:53 +0200
commit0e4c80b2ad9016e8158f37c4481dd6921582707f (patch)
treedfafb4ae2d62ccb929c49f9eb4c801a57296e939 /community
parentf6afaa861224ce3d821a888f83fbf119cc4b5d34 (diff)
downloadaports-0e4c80b2ad9016e8158f37c4481dd6921582707f.tar.bz2
aports-0e4c80b2ad9016e8158f37c4481dd6921582707f.tar.xz
community/heirloom-mailx: modernize abuild
Diffstat (limited to 'community')
-rw-r--r--community/heirloom-mailx/APKBUILD39
1 files changed, 6 insertions, 33 deletions
diff --git a/community/heirloom-mailx/APKBUILD b/community/heirloom-mailx/APKBUILD
index ff6e22c420..50907ad359 100644
--- a/community/heirloom-mailx/APKBUILD
+++ b/community/heirloom-mailx/APKBUILD
@@ -7,9 +7,7 @@ pkgdesc="A free clone of SysV mailx"
url="http://heirloom.sourceforge.net/mailx.html"
arch="all"
license="BSD"
-depends=""
makedepends="libressl-dev krb5-dev"
-install=""
subpackages="$pkgname-doc"
source="http://sourceforge.net/projects/heirloom/files/heirloom-mailx/$pkgver/mailx-$pkgver.tar.bz2
12.4-to-12.5pre.patch
@@ -21,45 +19,20 @@ source="http://sourceforge.net/projects/heirloom/files/heirloom-mailx/$pkgver/ma
libressl.patch
"
-_builddir="$srcdir"/mailx-$pkgver
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
+builddir="$srcdir"/mailx-$pkgver
build() {
- cd "$_builddir"
- make || return 1
+ cd "$builddir"
+ make
}
package() {
- cd "$_builddir"
- make DESTDIR="$pkgdir" install || return 1
- install -Dm 0644 COPYING "$pkgdir"/usr/share/licenses/"$pkgname"/COPYING || return 1
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+ install -Dm 0644 COPYING "$pkgdir"/usr/share/licenses/"$pkgname"/COPYING
cd "$pkgdir"/usr/share/man/man1/ && mv mailx.1 "$pkgname".1
}
-md5sums="0c93759e34200eb56a0e7c464680a54a mailx-12.4.tar.bz2
-a4a91391ada32a7b87ff5255d2f06c47 12.4-to-12.5pre.patch
-75abf9efc9fabee598d5500951073cb6 makevars.patch
-268353d063e6c962f02672ecec9cb77b 0001-outof-Introduce-expandaddr-flag.patch
-011a9c9a7d208b363bd548b84c710fa4 0002-unpack-Disable-option-processing-for-email-addresses.patch
-7455da8174ac31a3d1c5afd1a37d7f2d 0003-fio_c-Unconditionally-require-wordexp-support.patch
-19eaa6ee08c45db17b48d65b3eaca78b 0004-globname-Invoke-wordexp-with-WRDE_NOCMD-CVE-2004-277.patch
-141a6433b4f72755472946f3f1f90232 libressl.patch"
-sha256sums="92201e769fe346bc0364c87437a330ef3c97ab3e9d7b2235b93f509e85e5716a mailx-12.4.tar.bz2
-d3629782c2b4d676aadea823335a57c8ed5f86e6d6fde31b18313b9c070727bc 12.4-to-12.5pre.patch
-5df76dc08562bf12ab0c2ac1e32fe70f137c18258af29284448448f0b5848ace makevars.patch
-70c268a40d32215392c08f88c841a2125572879f954f4e165bbc8fe6ca1beff8 0001-outof-Introduce-expandaddr-flag.patch
-8bf07ea359daee7477765f1e4f4d7ba6d923a6937743f097a1940b87fe1bdd73 0002-unpack-Disable-option-processing-for-email-addresses.patch
-6902e1fb2c71b24d15db527e10e0bf6bc7e63a3048b7851174693cde92dddbc2 0003-fio_c-Unconditionally-require-wordexp-support.patch
-538285fabe1ede7f62013ced05b00b28e86b8c1543f6de73ee3b1c05a9c2ecec 0004-globname-Invoke-wordexp-with-WRDE_NOCMD-CVE-2004-277.patch
-bfc08cf380b919918b8aaeedce94124908aa4305a9af80c9f6685b8ee9c25fef libressl.patch"
sha512sums="a0e29972f552bd630ce1a14f70e61661815118520bcd4a00b6cad53f3270d3d08c835ff6982ba8800eb380a5b46f54eb6e60fb7533b5f41c916af45d29605af8 mailx-12.4.tar.bz2
c2435c18b3e972a77bbaa1b915cae567cafcd65cba1710cd78e7b934d33662361aa1e72fb99d0f109945c603ec847552345a4a5c3ec64dbc307cbb811a6d74d0 12.4-to-12.5pre.patch
b831544e92b0262b6d5276cb7e78427cb33fd09bc3cb2ffc398cb3f930f05764bcecc8e5b1743554dadc5e0bd791d56b4a72b7a05089db7170437dd5254b9080 makevars.patch