aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
authorSören Tempel <soeren+git@soeren-tempel.net>2018-09-24 18:18:09 +0200
committerSören Tempel <soeren+git@soeren-tempel.net>2018-10-07 18:52:21 +0200
commit270f7916d1c070541dbc3c79197b7e03f467f6f7 (patch)
treee2a0817c316c53c04d2c4a200a087bb4018b312f /community
parent09c3c53f2535fb31b14c4c079aa575396435d022 (diff)
downloadaports-270f7916d1c070541dbc3c79197b7e03f467f6f7.tar.bz2
aports-270f7916d1c070541dbc3c79197b7e03f467f6f7.tar.xz
community/go: partially enable the test suite
Still better than compiling and running a 'Hello World' example.
Diffstat (limited to 'community')
-rw-r--r--community/go/APKBUILD14
1 files changed, 8 insertions, 6 deletions
diff --git a/community/go/APKBUILD b/community/go/APKBUILD
index 006ca2c832..596038903e 100644
--- a/community/go/APKBUILD
+++ b/community/go/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=go
pkgver=1.11
-pkgrel=3
+pkgrel=4
pkgdesc="Go programming language compiler"
url="http://www.golang.org/"
arch="all"
@@ -24,6 +24,10 @@ source="https://golang.org/dl/go${pkgver/_/}.src.tar.gz
# NOTE: building go for x86 with grsec kernel requires:
# sysctl -w kernel.modify_ldt=1
+# The following tests fail currently, most of them fail due to linking
+# errors likely related to `default-buildmode-pie.patch` or musl libc.
+_brokentests="runtime debug/gosym cmd/.* cgo.* ^test.*"
+
if [ "$CBUILD" = "$CTARGET" ]; then
makedepends="go-bootstrap $makedepends"
provides="go-bootstrap=$pkgver-r$pkgrel"
@@ -80,14 +84,12 @@ build() {
rm -rf "../pkg/${gohostos}_${gohostarch}"* "../pkg/tool/${gohostos}_${gohostarch}"*
rm -rf ../pkg/bootstrap ../pkg/obj
fi
-
- # FIXME some tests fail:
- # PATH="$GOROOT/bin:$PATH" ./run.bash -no-rebuild
}
check() {
- cd "$builddir"
- ./bin/go run doc/play/hello.go
+ cd "$builddir/src"
+ PATH="$builddir/bin:$PATH" ./run.bash -no-rebuild \
+ -run "!($(echo "$_brokentests" | tr " " "|"))$"
}
package() {