aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2017-05-18 12:46:15 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2017-05-18 12:46:15 +0000
commit2ef23635a7f6cbdb54c363a3970362879e28e7f4 (patch)
tree672a1e5c35522acc4d14cc22e34ce38856ced35b /community
parenta6ab10233809343b51e87d7c5fe83291e81f3454 (diff)
downloadaports-2ef23635a7f6cbdb54c363a3970362879e28e7f4.tar.bz2
aports-2ef23635a7f6cbdb54c363a3970362879e28e7f4.tar.xz
community/openjdk8: fix build on armhf
since icedtea 3.4 the configure script will select aarch32 hotspot build due to better performace. Our patches does not apply to this so for now we use the default hotspot, even if it is slower on armhf. http://blog.fuseyism.com/index.php/2017/05/17/security-icedtea-3-4-0-for-openjdk-8-armed-and-ready-released/
Diffstat (limited to 'community')
-rw-r--r--community/openjdk8/APKBUILD1
1 files changed, 1 insertions, 0 deletions
diff --git a/community/openjdk8/APKBUILD b/community/openjdk8/APKBUILD
index a231946a62..2de62adcfd 100644
--- a/community/openjdk8/APKBUILD
+++ b/community/openjdk8/APKBUILD
@@ -135,6 +135,7 @@ build() {
--disable-dependency-tracking \
--disable-downloading \
--with-parallel-jobs=${JOBS:-2} \
+ --with-hotspot-build=default \
--with-openjdk-src-zip="$srcdir/openjdk-$_dropsver.tar.xz" \
--with-hotspot-src-zip="$srcdir/hotspot-$_dropsver.tar.xz" \
--with-corba-src-zip="$srcdir/corba-$_dropsver.tar.xz" \