aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
authorRoberto Oliveira <robertoguimaraes8@gmail.com>2017-07-01 01:44:31 +0000
committerJakub Jirutka <jakub@jirutka.cz>2017-07-03 13:50:02 +0200
commit2fff0ac077756a2b12102db0871566b6da292eb9 (patch)
tree37c4fa0a912a12d350b7f41cc6a4a7c51faa8a08 /community
parente4565a2b41b0ebe92503aeef6df3588dd1951cd3 (diff)
downloadaports-2fff0ac077756a2b12102db0871566b6da292eb9.tar.bz2
aports-2fff0ac077756a2b12102db0871566b6da292eb9.tar.xz
community/lablgtk: enable build on ppc64le
Enable build on ppc64le as ocaml is now available. Also use make -j1 for now due to failure when using parallelism.
Diffstat (limited to 'community')
-rw-r--r--community/lablgtk/APKBUILD8
1 files changed, 4 insertions, 4 deletions
diff --git a/community/lablgtk/APKBUILD b/community/lablgtk/APKBUILD
index d820aba609..eea5ad5e1f 100644
--- a/community/lablgtk/APKBUILD
+++ b/community/lablgtk/APKBUILD
@@ -6,7 +6,7 @@ pkgrel=3
pkgdesc="LablGtk - an OCaml interface to GTK+ 2.x"
url="http://lablgtk.forge.ocamlcore.org/"
# ocaml is not built for x86, armhf
-arch="x86_64"
+arch="x86_64 ppc64le"
license="GPL"
depends_dev="lablgtk gtk+-dev gtkspell-dev librsvg-dev gtksourceview2-dev"
depends="ocaml-findlib camlp4 ocaml"
@@ -15,14 +15,14 @@ subpackages="$pkgname-doc $pkgname-dev"
source="https://forge.ocamlcore.org/frs/download.php/1627/lablgtk-$pkgver.tar.gz"
builddir="$srcdir/lablgtk-$pkgver"
-options="!check"
+options="!check textrels"
build() {
cd "$builddir"
./configure --prefix=/usr
- make world
- make opt
+ make -j1 world
+ make -j1 opt
make doc
}