aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2017-05-16 19:48:26 +0200
committerJakub Jirutka <jakub@jirutka.cz>2017-05-16 19:48:26 +0200
commit574f356f2a8bf85032e619b9bf53e15fda2aa070 (patch)
tree5a94374a83582b5095ace49f6ae53920cacd9822 /community
parent6ab306e75dc45d6d134376660bb575939c0dd4d4 (diff)
downloadaports-574f356f2a8bf85032e619b9bf53e15fda2aa070.tar.bz2
aports-574f356f2a8bf85032e619b9bf53e15fda2aa070.tar.xz
community/glances: disable check, tests fail on builders
============================================================================== INFO: [TEST_012] Check IP stats...... ====================================================================== FAIL: test_000_update (__main__.TestGlances) Update stats (mandatory step for all the stats). ---------------------------------------------------------------------- Traceback (most recent call last): File "unitest.py", line 67, in test_000_update self.assertTrue(False) AssertionError: False is not true ====================================================================== FAIL: test_002_cpu (__main__.TestGlances) Check SYSTEM plugin. ---------------------------------------------------------------------- Traceback (most recent call last): File "unitest.py", line 92, in test_002_cpu self.assertTrue(stat in stats_grab, msg='Cannot find key: %s' % stat) AssertionError: Cannot find key: hostname ====================================================================== FAIL: test_003_cpu (__main__.TestGlances) Check CPU plugin. ---------------------------------------------------------------------- Traceback (most recent call last): File "unitest.py", line 102, in test_003_cpu self.assertTrue(stat in stats_grab, msg='Cannot find key: %s' % stat) AssertionError: Cannot find key: system ====================================================================== FAIL: test_005_mem (__main__.TestGlances) Check MEM plugin. ---------------------------------------------------------------------- Traceback (most recent call last): File "unitest.py", line 128, in test_005_mem self.assertTrue(stat in stats_grab, msg='Cannot find key: %s' % stat) AssertionError: Cannot find key: available ====================================================================== FAIL: test_010_processes (__main__.TestGlances) Check Process plugin. ---------------------------------------------------------------------- Traceback (most recent call last): File "unitest.py", line 173, in test_010_processes self.assertTrue(type(stats_grab) is dict, msg='Process count stats is not a dict') AssertionError: Process count stats is not a dict ---------------------------------------------------------------------- Ran 18 tests in 0.005s FAILED (failures=5)
Diffstat (limited to 'community')
-rw-r--r--community/glances/APKBUILD1
1 files changed, 1 insertions, 0 deletions
diff --git a/community/glances/APKBUILD b/community/glances/APKBUILD
index df3859d5e1..476a067811 100644
--- a/community/glances/APKBUILD
+++ b/community/glances/APKBUILD
@@ -14,6 +14,7 @@ makedepends="python2-dev py-setuptools"
subpackages="$pkgname-doc"
source="$pkgname-$pkgver.tar.gz::https://github.com/nicolargo/$pkgname/archive/v$pkgver.tar.gz"
builddir="$srcdir/$pkgname-$pkgver"
+options="!check" # tests fail on builder infra due to env. limitations
build() {
cd "$builddir"