aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2018-05-15 13:16:08 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2018-05-15 13:16:08 +0000
commitc96ade24bf43dff6e34a2351c6f0d18070a6807a (patch)
tree0a1b49612915eabe3dfb6fd8a4abb20a1d5ecefc /community
parent4637ce754d3fedd6906307cd327e7569f5673126 (diff)
downloadaports-c96ade24bf43dff6e34a2351c6f0d18070a6807a.tar.bz2
aports-c96ade24bf43dff6e34a2351c6f0d18070a6807a.tar.xz
community/vlc: upgrade to 3.0.2
Diffstat (limited to 'community')
-rw-r--r--community/vlc/APKBUILD8
-rw-r--r--community/vlc/fix-missing-asm.S-for-arm.patch45
2 files changed, 3 insertions, 50 deletions
diff --git a/community/vlc/APKBUILD b/community/vlc/APKBUILD
index 701ea2d886..8fa89422c9 100644
--- a/community/vlc/APKBUILD
+++ b/community/vlc/APKBUILD
@@ -2,8 +2,8 @@
# Contributor: Leonardo Arena <rnalrd@alpinelinux.org>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=vlc
-pkgver=3.0.1
-pkgrel=1
+pkgver=3.0.2
+pkgrel=0
pkgdesc="A multi-platform MPEG, VCD/DVD, and DivX player"
triggers="vlc-libs.trigger=/usr/lib/vlc/plugins"
pkgusers="vlc"
@@ -116,7 +116,6 @@ source="http://get.videolan.org/vlc/$pkgver/$pkgname-$pkgver.tar.xz
check-headless.patch
disable-sub-autodetect-fuzzy-1-test.patch
test-s390x.patch
- fix-missing-asm.S-for-arm.patch
vlc-libs.trigger"
builddir="$srcdir/$pkgname-$pkgver"
@@ -328,10 +327,9 @@ plugins_video_filter() { _mv_plugins video_filter; }
plugins_video_output() { _mv_plugins video_output; }
plugins_visualization() { _mv_plugins visualization; }
-sha512sums="f2ba7586e8fb8c04484e62809265ec998e875b1eff03262bbf463370277a318816cbb8d260901c774e59443393b16b040cb714019c80e051578008abbf91b13c vlc-3.0.1.tar.xz
+sha512sums="907a999dfa00fbc378e46689b2c32a09ea324b47a92b2183f2a1ade2c2c1ec205517580000a3c615d17b15d6885ee0ac51894944b90077968cb30ff58745497f vlc-3.0.2.tar.xz
e13e398b7bfd977f6e099bcb6cf8dc5cd5bad6dea3eff715881826246dc4329468846084aff2576de2b7fd28d3f06e7c327a6e4511a28d22e5cd198a81146c89 omxil-rpi-codecs.patch
22d80df599b8b65a5439cefbb7140af8e9530f326d54945da3769af65f37518b99ec2cc8647aafd2763324a0698280915afe043cc87e5720c4694881ed35bffa check-headless.patch
e214b407235cb3afb8bec93f20c9b42957b57e6fd3960679d3d4235e77762e03e64d03c01f00ef63d589e7c85aaad02ce6abbeeccd66b1867bc92451a5b5e9b0 disable-sub-autodetect-fuzzy-1-test.patch
c0107655249687655846a9547ca1a5670b9207443180600e7a149c69ffb96d7226787c19b018d4033db9b284c1a5faa8d7d42188ed40c3b8bb051256febf11c5 test-s390x.patch
-cc625c382cc80cfae9c0dd6fe55a634e4ca4f0be0a83e8355721eae9447cb815af6a6000aeb6ae3667554d1670590fa2df6c635124bef85738d01609f65c9935 fix-missing-asm.S-for-arm.patch
b67b6e21e9d4027aef1006e6057f9ba8e65ce3895b08f7b911b1675cff9bc423f64ee2c187c584860e9e5d4635a30408a7781add9694d9bba753eac37f357406 vlc-libs.trigger"
diff --git a/community/vlc/fix-missing-asm.S-for-arm.patch b/community/vlc/fix-missing-asm.S-for-arm.patch
deleted file mode 100644
index 5b363fa1e9..0000000000
--- a/community/vlc/fix-missing-asm.S-for-arm.patch
+++ /dev/null
@@ -1,45 +0,0 @@
-diff --git a/modules/arm_neon/asm.S b/modules/arm_neon/asm.S
-new file mode 100644
-index 0000000..728391e
---- /dev/null
-+++ b/modules/arm_neon/asm.S
-@@ -0,0 +1,39 @@
-+/*
-+ * Copyright (c) 2018 Janne Grunau <janne-libav@jannau.net>
-+ *
-+ * This program is free software; you can redistribute it and/or
-+ * modify it under the terms of the GNU Lesser General Public
-+ * License as published by the Free Software Foundation; either
-+ * version 2.1 of the License, or (at your option) any later version.
-+ *
-+ * This program is distributed in the hope that it will be useful,
-+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
-+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
-+ * Lesser General Public License for more details.
-+ *
-+ * You should have received a copy of the GNU Lesser General Public
-+ * License along with this program; if not, write to the Free Software
-+ * Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA
-+ */
-+
-+#ifdef __APPLE__
-+# define EXTERN_ASM _
-+#else
-+# define EXTERN_ASM
-+#endif
-+
-+#if defined(__APPLE__) || defined(_WIN32)
-+# define HAVE_AS_ARCH_DIRECTIVE 0
-+# define HAVE_AS_FPU_DIRECTIVE 0
-+#else
-+# define HAVE_AS_ARCH_DIRECTIVE 1
-+# define HAVE_AS_FPU_DIRECTIVE 1
-+#endif
-+
-+.macro function name
-+ .globl EXTERN_ASM\name
-+#ifdef __ELF__
-+ .type EXTERN_ASM\name, %function
-+#endif
-+EXTERN_ASM\name:
-+.endm