aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2017-03-22 12:47:44 +0100
committerCarlo Landmeter <clandmeter@gmail.com>2017-03-22 12:47:44 +0100
commite8914b31ece81d0c019052a64ff765af7d1ea96c (patch)
treee7f8aa7b82cbedf0f6c5e78a3294ae1bc007dd25 /community
parentddbab0e9f9139b8383da25e826dd400b1faa46b6 (diff)
downloadaports-e8914b31ece81d0c019052a64ff765af7d1ea96c.tar.bz2
aports-e8914b31ece81d0c019052a64ff765af7d1ea96c.tar.xz
community/gitea: add working initd
Diffstat (limited to 'community')
-rw-r--r--community/gitea/APKBUILD2
-rw-r--r--community/gitea/gitea.confd2
-rw-r--r--community/gitea/gitea.initd9
3 files changed, 5 insertions, 8 deletions
diff --git a/community/gitea/APKBUILD b/community/gitea/APKBUILD
index 0b0f36ba70..3d2e5b84e3 100644
--- a/community/gitea/APKBUILD
+++ b/community/gitea/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: 7heo <7heo@mail.com>
pkgname=gitea
pkgver=1.1.0
-pkgrel=0
+pkgrel=1
pkgdesc="A self-hosted Git service written in Go"
url="http://gitea.io/"
arch="all"
diff --git a/community/gitea/gitea.confd b/community/gitea/gitea.confd
deleted file mode 100644
index 347fc5ab63..0000000000
--- a/community/gitea/gitea.confd
+++ /dev/null
@@ -1,2 +0,0 @@
-GITEA_CUSTOM="/etc/gitea"
-GITEA_USER="gitea"
diff --git a/community/gitea/gitea.initd b/community/gitea/gitea.initd
index 3b18678b6b..b72224217e 100644
--- a/community/gitea/gitea.initd
+++ b/community/gitea/gitea.initd
@@ -1,12 +1,11 @@
#!/sbin/openrc-run
name=gitea
-conffile="$GITEA_CUSTOM/conf/app.ini"
command="/usr/bin/gitea"
-command_args="web -c $conffile"
-start_stop_daemon_args="${GITEA_USER:+--user} $GITEA_USER --env GITEA_CUSTOM=$GITEA_CUSTOM"
-pidfile="/var/run/gitea.pid"
-command_background="yes"
+command_args="web"
+start_stop_daemon_args="--user ${GITEA_USER:-gitea} --env GITEA_CUSTOM=${GITEA_CUSTOM:-/var/lib/gitea} --chdir ${GITEA_CUSTOM:-/var/lib/gitea}"
+command_background=yes
+pidfile="/run/gitea.pid"
depend() {
use logger dns