aboutsummaryrefslogtreecommitdiffstats
path: root/main/avahi
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2013-07-30 08:51:11 +0000
committerTimo Teräs <timo.teras@iki.fi>2013-07-30 08:54:53 +0000
commit5c904717322f8113870abf48cc93c3c8b00ab4e8 (patch)
treee077e5c3afa20630fd6e96db5872f03d622d639e /main/avahi
parenta879839450737e3cbdb64415af42347c97ccfa28 (diff)
downloadaports-5c904717322f8113870abf48cc93c3c8b00ab4e8.tar.bz2
aports-5c904717322f8113870abf48cc93c3c8b00ab4e8.tar.xz
[all autotools packages]: normalize ./configure
Diffstat (limited to 'main/avahi')
-rw-r--r--main/avahi/APKBUILD8
1 files changed, 6 insertions, 2 deletions
diff --git a/main/avahi/APKBUILD b/main/avahi/APKBUILD
index 05b9a54098..bad49f3f6d 100644
--- a/main/avahi/APKBUILD
+++ b/main/avahi/APKBUILD
@@ -33,7 +33,10 @@ build ()
{
cd "$srcdir/$pkgname-$pkgver"
# we dont build autoipd since dhcpcd does same job
- ./configure --prefix=/usr \
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
--sysconfdir=/etc \
--localstatedir=/var \
--disable-autoipd \
@@ -47,7 +50,8 @@ build ()
--enable-compat-libdns_sd \
--enable-compat-howl \
--with-distro="gentoo" \
- --with-systemdsystemunitdir=/lib/systemd/system
+ --with-systemdsystemunitdir=/lib/systemd/system \
+ || return 1
make
}