aboutsummaryrefslogtreecommitdiffstats
path: root/main/avahi
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2012-11-05 13:46:16 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2012-11-05 13:46:16 +0000
commit5db039da57de8cc35955533b364cf9c36e3e7af8 (patch)
tree8daddb9814b39910533f3a07188b22c0407524a7 /main/avahi
parentee2f0898662cbc1731b865f5e218d952fed5d044 (diff)
downloadaports-5db039da57de8cc35955533b364cf9c36e3e7af8.tar.bz2
aports-5db039da57de8cc35955533b364cf9c36e3e7af8.tar.xz
main/avahi: fixi init script
- replace 'opts' with 'extra_started_commands' - start avahi after hostname is set fixes #1461
Diffstat (limited to 'main/avahi')
-rw-r--r--main/avahi/APKBUILD12
-rw-r--r--main/avahi/initscripts.patch32
2 files changed, 43 insertions, 1 deletions
diff --git a/main/avahi/APKBUILD b/main/avahi/APKBUILD
index 5ba1f0cd1c..05b9a54098 100644
--- a/main/avahi/APKBUILD
+++ b/main/avahi/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=avahi
pkgver=0.6.31
-pkgrel=1
+pkgrel=2
pkgdesc="A multicast/unicast DNS-SD framework"
url="http://www.avahi.org/"
arch="all"
@@ -16,10 +16,19 @@ pkggroups="avahi"
subpackages="$pkgname-dev $pkgname-doc $pkgname-tools $pkgname-ui-tools:uitools
$pkgname-glib $pkgname-ui $pkgname-libs $pkgname-compat-howl:howl
$pkgname-compat-libdns_sd:lidns_sd $pkgname-lang"
+patches="initscripts.patch"
source="http://www.avahi.org/download/avahi-$pkgver.tar.gz
+ $patches
gnome-nettool.png"
_builddir="$srcdir"/$pkgname-$pkgver
+prepare() {
+ cd "$_builddir"
+ for i in $patches; do
+ patch -p1 -i "$srcdir"/$i || return 1
+ done
+}
+
build ()
{
cd "$srcdir/$pkgname-$pkgver"
@@ -116,4 +125,5 @@ lidns_sd() {
}
md5sums="2f22745b8f7368ad5a0a3fddac343f2d avahi-0.6.31.tar.gz
+0f8cd64789585731adbeb3e3efd55b21 initscripts.patch
42c2905307c7a5dc6ac4b75f4c3d65a3 gnome-nettool.png"
diff --git a/main/avahi/initscripts.patch b/main/avahi/initscripts.patch
new file mode 100644
index 0000000000..157c195708
--- /dev/null
+++ b/main/avahi/initscripts.patch
@@ -0,0 +1,32 @@
+diff --git a/initscript/gentoo/avahi-daemon.in b/initscript/gentoo/avahi-daemon.in
+index 02eefe6..a430eb5 100644
+--- a/initscript/gentoo/avahi-daemon.in
++++ b/initscript/gentoo/avahi-daemon.in
+@@ -2,12 +2,12 @@
+ # Copyright 1999-2007 Gentoo Foundation
+ # Distributed under the terms of the GNU General Public License v2
+
+-opts="reload"
++extra_started_commands="reload"
+
+ depend() {
+ before netmount nfsmount
+ use net
+- need dbus
++ need dbus hostname
+ }
+
+ start() {
+diff --git a/initscript/gentoo/avahi-dnsconfd.in b/initscript/gentoo/avahi-dnsconfd.in
+index 376067e..dff914c 100644
+--- a/initscript/gentoo/avahi-dnsconfd.in
++++ b/initscript/gentoo/avahi-dnsconfd.in
+@@ -2,7 +2,7 @@
+ # Copyright 1999-2007 Gentoo Foundation
+ # Distributed under the terms of the GNU General Public License v2
+
+-opts="reload"
++extra_started_commands="reload"
+
+ depend() {
+ need avahi-daemon