aboutsummaryrefslogtreecommitdiffstats
path: root/main/avahi
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2016-05-24 10:45:02 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2016-05-24 10:45:02 +0000
commite087b83a98429d2a3ea05ecdfcc67adce8ff934b (patch)
tree7a66c1f30b851aa0f9fc60d63b5f2270b41dbda3 /main/avahi
parent1a01b3e741cfb6ded12e8ee32521fb080a1f3180 (diff)
downloadaports-e087b83a98429d2a3ea05ecdfcc67adce8ff934b.tar.bz2
aports-e087b83a98429d2a3ea05ecdfcc67adce8ff934b.tar.xz
main/avahi: upgrade to 0.6.32
Diffstat (limited to 'main/avahi')
-rw-r--r--main/avahi/APKBUILD39
-rw-r--r--main/avahi/libintl.patch13
-rw-r--r--main/avahi/musl-fix.patch65
3 files changed, 32 insertions, 85 deletions
diff --git a/main/avahi/APKBUILD b/main/avahi/APKBUILD
index d4142b9417..5a88fdc25f 100644
--- a/main/avahi/APKBUILD
+++ b/main/avahi/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=avahi
-pkgver=0.6.31
-pkgrel=8
+pkgver=0.6.32
+pkgrel=0
pkgdesc="A multicast/unicast DNS-SD framework"
url="http://www.avahi.org/"
arch="all"
@@ -9,7 +9,8 @@ license="LGPL2+"
depends=""
depends_dev="gdbm-dev"
makedepends="py-dbus-dev intltool gobject-introspection-dev expat-dev
- libdaemon-dev glib-dev dbus-dev libcap-dev gdbm-dev py-gdbm"
+ libdaemon-dev glib-dev dbus-dev libcap-dev gdbm-dev py-gdbm
+ gettext-dev autoconf automake libtool"
install="$pkgname.pre-install"
pkgusers="avahi"
pkggroups="avahi"
@@ -17,23 +18,24 @@ subpackages="$pkgname-dev $pkgname-doc $pkgname-tools $pkgname-glib
$pkgname-libs $pkgname-compat-howl:howl
$pkgname-compat-libdns_sd:lidns_sd $pkgname-lang
py-avahi:py"
-patches="initscripts.patch
- musl-fix.patch"
+patches="
+ libintl.patch
+ "
source="http://www.avahi.org/download/avahi-$pkgver.tar.gz
$patches
"
-_builddir="$srcdir"/$pkgname-$pkgver
+builddir="$srcdir"/$pkgname-$pkgver
prepare() {
- cd "$_builddir"
- update_config_sub || return 1
+ cd "$builddir"
for i in $patches; do
- patch -p1 -i "$srcdir"/$i || return 1
+ msg $i; patch -p1 -i "$srcdir"/$i || return 1
done
+ autoreconf -vif
}
build() {
- cd "$_builddir"
+ cd "$builddir"
# we dont build autoipd since dhcpcd does same job
./configure \
--build=$CBUILD \
@@ -61,7 +63,7 @@ build() {
}
package() {
- cd "$_builddir"
+ cd "$builddir"
make DESTDIR="$pkgdir" install || return 1
install -d -o avahi -g avahi "$pkgdir"/var/run/avahi-daemon
ln -s avahi-compat-howl.pc "$pkgdir"/usr/lib/pkgconfig/howl.pc
@@ -121,12 +123,9 @@ py() {
}
-md5sums="2f22745b8f7368ad5a0a3fddac343f2d avahi-0.6.31.tar.gz
-0f8cd64789585731adbeb3e3efd55b21 initscripts.patch
-9557450128d0e4324405af2c625dc8c7 musl-fix.patch"
-sha256sums="8372719b24e2dd75de6f59bb1315e600db4fd092805bd1201ed0cb651a2dab48 avahi-0.6.31.tar.gz
-a3c9ace33195393b078b7dae2f7e133795012304aaea5541e8c00ba62975d40d initscripts.patch
-c43a60cf9cddb3cc8c88c13d78dbf0c6a7f1e3ff1f73e1305d465547cadd6a58 musl-fix.patch"
-sha512sums="53eb00d570a274d841e1e6ad07da077950089ae39b4f7aa21fcd21cc5320b30b506b43e7e57e56198e155cc7bd289b779a48b2b2fc002dc6194a946110451858 avahi-0.6.31.tar.gz
-31e1c7f469c80f537672880989eeef6493fa8b667965ca2d5b88dc58ba0e9a156aaf6531a85a0688ced0f6c9865cddf5195fe1b7f678bad4527f4d8ea990b445 initscripts.patch
-09ae19b3c8641cdbeaabf1af69852e297d7445dfaf259b43d9de8a04c5d31722ecb2fb921feb44925a5364e69bd514c47be90f532493b087879abf9f53a8fe11 musl-fix.patch"
+md5sums="22b5e705d3eabb31d26f2e1e7b074013 avahi-0.6.32.tar.gz
+918faa4ca39766621c426235ff797b77 libintl.patch"
+sha256sums="d54991185d514a0aba54ebeb408d7575b60f5818a772e28fa0e18b98bc1db454 avahi-0.6.32.tar.gz
+c4292324a9d596a411f12403708bf9f67f3aa5731e55e6cfc5ae4c196f28c22a libintl.patch"
+sha512sums="6f8d0a64292439cbb989c531a4ba2f25a53ee9cf7ad9df04dedf73149489a92612f3b5955e10aa4b1c76496c34b90ad75590e8aa49468249508267c1c8b899ee avahi-0.6.32.tar.gz
+06d8e9078cfba1c3bcc45094c6f69c74e3edbac8e1e65d6cda5a67460992323d245f6cea5c43ec4a012d9300328503f962cb23e4b391ec2dbe12664a00858b07 libintl.patch"
diff --git a/main/avahi/libintl.patch b/main/avahi/libintl.patch
new file mode 100644
index 0000000000..f0f8d46c10
--- /dev/null
+++ b/main/avahi/libintl.patch
@@ -0,0 +1,13 @@
+diff --git a/avahi-utils/Makefile.am b/avahi-utils/Makefile.am
+index 66c4cc6..0fff465 100644
+--- a/avahi-utils/Makefile.am
++++ b/avahi-utils/Makefile.am
+@@ -28,7 +28,7 @@ bin_PROGRAMS = avahi-browse avahi-resolve avahi-publish avahi-set-host-name
+
+ avahi_browse_SOURCES = avahi-browse.c sigint.c sigint.h
+ avahi_browse_CFLAGS = $(AM_CFLAGS)
+-avahi_browse_LDADD = $(AM_LDADD) ../avahi-client/libavahi-client.la ../avahi-common/libavahi-common.la
++avahi_browse_LDADD = $(AM_LDADD) $(INTLLIBS) ../avahi-client/libavahi-client.la ../avahi-common/libavahi-common.la
+
+ if HAVE_GDBM
+ avahi_browse_SOURCES += stdb.h stdb.c
diff --git a/main/avahi/musl-fix.patch b/main/avahi/musl-fix.patch
deleted file mode 100644
index a331e6453c..0000000000
--- a/main/avahi/musl-fix.patch
+++ /dev/null
@@ -1,65 +0,0 @@
-diff --git a/avahi-common/simple-watch.c b/avahi-common/simple-watch.c
-index 8df18dd..08d8090 100644
---- a/avahi-common/simple-watch.c
-+++ b/avahi-common/simple-watch.c
-@@ -21,7 +21,7 @@
- #include <config.h>
- #endif
-
--#include <sys/poll.h>
-+#include <poll.h>
- #include <assert.h>
- #include <string.h>
- #include <errno.h>
-diff --git a/avahi-common/simple-watch.h b/avahi-common/simple-watch.h
-index 72c1905..db87122 100644
---- a/avahi-common/simple-watch.h
-+++ b/avahi-common/simple-watch.h
-@@ -22,7 +22,7 @@
-
- /** \file simple-watch.h Simple poll() based main loop implementation */
-
--#include <sys/poll.h>
-+#include <poll.h>
- #include <avahi-common/cdecl.h>
- #include <avahi-common/watch.h>
-
-diff --git a/avahi-common/thread-watch.c b/avahi-common/thread-watch.c
-index c0cadeb..ecb202b 100644
---- a/avahi-common/thread-watch.c
-+++ b/avahi-common/thread-watch.c
-@@ -21,7 +21,7 @@
- #include <config.h>
- #endif
-
--#include <sys/poll.h>
-+#include <poll.h>
- #include <assert.h>
- #include <string.h>
- #include <errno.h>
-diff --git a/avahi-common/thread-watch.h b/avahi-common/thread-watch.h
-index dec0cf3..1b44ccb 100644
---- a/avahi-common/thread-watch.h
-+++ b/avahi-common/thread-watch.h
-@@ -22,7 +22,7 @@
-
- /** \file thread-watch.h Threaded poll() based main loop implementation */
-
--#include <sys/poll.h>
-+#include <poll.h>
- #include <avahi-common/cdecl.h>
- #include <avahi-common/watch.h>
-
-diff --git a/avahi-common/watch.h b/avahi-common/watch.h
-index 86e63d3..eea12ec 100644
---- a/avahi-common/watch.h
-+++ b/avahi-common/watch.h
-@@ -22,7 +22,7 @@
-
- /** \file watch.h Simplistic main loop abstraction */
-
--#include <sys/poll.h>
-+#include <poll.h>
- #include <sys/time.h>
-
- #include <avahi-common/cdecl.h>