aboutsummaryrefslogtreecommitdiffstats
path: root/main/binutils/APKBUILD
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2014-05-07 06:44:21 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2014-05-07 06:44:59 +0000
commitb8cb931e312b5590897c310b0e3bc3f90d6ef809 (patch)
tree235fea219a56b8bd2645915d6e3f77bc875351f6 /main/binutils/APKBUILD
parentd11cc2706ced5459189b035e1afdf00703f96f80 (diff)
downloadaports-b8cb931e312b5590897c310b0e3bc3f90d6ef809.tar.bz2
aports-b8cb931e312b5590897c310b0e3bc3f90d6ef809.tar.xz
main/binutils: remove bash dependency
found patch: http://git.proteanos.com/pkg/gdb.git/plain/patches/02_fix-opcodes-configure-bfd-version-on-busybox-ash.patch
Diffstat (limited to 'main/binutils/APKBUILD')
-rw-r--r--main/binutils/APKBUILD21
1 files changed, 15 insertions, 6 deletions
diff --git a/main/binutils/APKBUILD b/main/binutils/APKBUILD
index 072da2ebb8..a85e84b065 100644
--- a/main/binutils/APKBUILD
+++ b/main/binutils/APKBUILD
@@ -1,11 +1,11 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=binutils
pkgver=2.24
-pkgrel=1
+pkgrel=2
pkgdesc="Tools necessary to build programs"
url="http://www.gnu.org/software/binutils/"
depends=""
-makedepends="bison flex texinfo zlib-dev bash"
+makedepends="bison flex texinfo zlib-dev"
arch="all"
license="GPL2 GPL3+ LGPL2 BSD"
subpackages="$pkgname-doc $pkgname-libs"
@@ -17,7 +17,10 @@ if [ "$CHOST" != "$CTARGET" ] && [ -n "$CHOST" -a -n "$CTARGET" ]; then
fi
source="http://ftp.gnu.org/gnu/binutils/binutils-$pkgver.tar.bz2
- binutils-ld-fix-static-linking.patch"
+ binutils-ld-fix-static-linking.patch
+ 02_fix-opcodes-configure-bfd-version-on-busybox-ash.patch
+ bfd-version.patch
+ "
_builddir="$srcdir/$pkgname-$pkgver"
prepare() {
@@ -80,8 +83,14 @@ libs() {
}
md5sums="e0f71a7b2ddab0f8612336ac81d9636b binutils-2.24.tar.bz2
-c9f308494b87c243f121a56d58f2da87 binutils-ld-fix-static-linking.patch"
+c9f308494b87c243f121a56d58f2da87 binutils-ld-fix-static-linking.patch
+26210092adc0e0d7b236eb464dea543a 02_fix-opcodes-configure-bfd-version-on-busybox-ash.patch
+56c179892fa33cd0bac127761834e5d9 bfd-version.patch"
sha256sums="e5e8c5be9664e7f7f96e0d09919110ab5ad597794f5b1809871177a0f0f14137 binutils-2.24.tar.bz2
-d5c5581d0ba04ef2e3690f6fb57435bf7ce343f2376fe972a2a693c5429eec9c binutils-ld-fix-static-linking.patch"
+d5c5581d0ba04ef2e3690f6fb57435bf7ce343f2376fe972a2a693c5429eec9c binutils-ld-fix-static-linking.patch
+0bbd84e3e761e482e5a78ca126964b2af3b492dad66f49b62603f653bb795ea5 02_fix-opcodes-configure-bfd-version-on-busybox-ash.patch
+79cea3abac2fc544494853b03a5fbf92489969397286d201b25706359e0862bb bfd-version.patch"
sha512sums="5ec95ad47d49b12c4558a8db0ca2109d3ee1955e3776057f3330c4506f8f4d1cf5e505fbf8a16b98403a0fcdeaaf986fe0a22be6456247dbdace63ce1f776b12 binutils-2.24.tar.bz2
-ecee33b0e435aa704af1c334e560f201638ff79e199aa11ed78a72f7c9b46f85fbb227af5748e735fd681d1965fcc42ac81b0c8824e540430ce0c706c81e8b49 binutils-ld-fix-static-linking.patch"
+ecee33b0e435aa704af1c334e560f201638ff79e199aa11ed78a72f7c9b46f85fbb227af5748e735fd681d1965fcc42ac81b0c8824e540430ce0c706c81e8b49 binutils-ld-fix-static-linking.patch
+f7c2d19c4fce831d5f2791e4daadde70a1286bcf27074e24e635224fc9f39f47b6d95cbf2860eea1be1362f995e348fca0a0c2d9fe2d491dfe5d674c82f83bfb 02_fix-opcodes-configure-bfd-version-on-busybox-ash.patch
+2fce2bbb667e643d090898d221f896ef7c192e858edbda3d460cb2067b130ce6d44730a47e332cae4c7bacf1a858dcc33715246fd209c7d98d2eda4aeb3f5b6c bfd-version.patch"