aboutsummaryrefslogtreecommitdiffstats
path: root/main/busybox
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2015-12-15 15:06:57 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2015-12-16 07:59:52 +0000
commitf4da9c887bad3a8d602373d1ed7d2c411230cc67 (patch)
tree8cd533d531ceeeb373513fd9f8e56295edb555f7 /main/busybox
parent7cc079a4b2b751e45ef4cc0471df24fc92ad9035 (diff)
downloadaports-f4da9c887bad3a8d602373d1ed7d2c411230cc67.tar.bz2
aports-f4da9c887bad3a8d602373d1ed7d2c411230cc67.tar.xz
main/busybox: add /etc/securetty
Diffstat (limited to 'main/busybox')
-rw-r--r--main/busybox/APKBUILD17
1 files changed, 16 insertions, 1 deletions
diff --git a/main/busybox/APKBUILD b/main/busybox/APKBUILD
index 131dbc93f7..aea23e6555 100644
--- a/main/busybox/APKBUILD
+++ b/main/busybox/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=busybox
pkgver=1.24.1
-pkgrel=6
+pkgrel=7
pkgdesc="Size optimized toolbox of many common UNIX utilities"
url=http://busybox.net
arch="all"
@@ -123,6 +123,21 @@ package() {
mkdir -p "$pkgdir"/var/lib/udhcpd || return 1
install -Dm644 "$_sdir"/examples/udhcp/udhcpd.conf \
"$pkgdir"/etc/udhcpd.conf || return 1
+ cat >"$pkgdir"/etc/securetty <<EOF
+console
+tty1
+tty2
+tty3
+tty4
+tty5
+tty6
+tty7
+tty8
+tty9
+tty10
+tty11
+EOF
+
}
suid() {