aboutsummaryrefslogtreecommitdiffstats
path: root/main/cadaver
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2016-10-04 16:01:57 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2016-10-10 12:04:05 +0000
commitb6536da4caebb87a77c15f7e7505ee540a0004c6 (patch)
treed3cba94b1e178ca9c19a9e259e3cd372a4f477aa /main/cadaver
parent72a86cdf3767b87277feb4dbc275198fdf3825b3 (diff)
downloadaports-b6536da4caebb87a77c15f7e7505ee540a0004c6.tar.bz2
aports-b6536da4caebb87a77c15f7e7505ee540a0004c6.tar.xz
main/cadaver: use neon and disable nls
Diffstat (limited to 'main/cadaver')
-rw-r--r--main/cadaver/APKBUILD27
-rw-r--r--main/cadaver/disable-nls.patch17
-rw-r--r--main/cadaver/neon.patch43
3 files changed, 79 insertions, 8 deletions
diff --git a/main/cadaver/APKBUILD b/main/cadaver/APKBUILD
index ea95dbfd7b..7af40db8a0 100644
--- a/main/cadaver/APKBUILD
+++ b/main/cadaver/APKBUILD
@@ -2,17 +2,19 @@
# Maintainer: ScrumpyJack <scrumpyjack@st.ilet.to>
pkgname=cadaver
pkgver=0.23.3
-pkgrel=1
+pkgrel=2
pkgdesc="Cadaver is a command line webDAV client for Linux"
url="http://webdav.org/cadaver/"
arch="all"
license="GPL"
depends=""
depends_dev=""
-makedepends="gettext-dev libproxy-dev openssl-dev"
+makedepends="libproxy-dev libressl-dev neon-dev expat-dev"
install=""
-subpackages="$pkgname-lang $pkgname-doc"
-source="http://webdav.org/cadaver/${pkgname}-${pkgver}.tar.gz"
+subpackages="$pkgname-doc"
+source="http://webdav.org/cadaver/${pkgname}-${pkgver}.tar.gz
+ neon.patch
+ disable-nls.patch"
_builddir=${srcdir}/${pkgname}-${pkgver}
prepare() {
@@ -32,7 +34,10 @@ build() {
--build=$CBUILD \
--host=$CHOST \
--prefix=/usr \
- --with-ssl=openssl \
+ --with-ssl \
+ --with-expat \
+ --with-neon \
+ --disable-nls \
|| return 1
make
}
@@ -42,6 +47,12 @@ package() {
make prefix=$pkgdir/usr install
}
-md5sums="502ecd601e467f8b16056d2acca39a6f cadaver-0.23.3.tar.gz"
-sha256sums="fd4ce68a3230ba459a92bcb747fc6afa91e46d803c1d5ffe964b661793c13fca cadaver-0.23.3.tar.gz"
-sha512sums="48fe0a266be0ca7239f325377e5e2a8dc57a5d60466c7160e36c060ad24c09a50727695b9fa931844b1e66e173ebbb838f390d6c60fd07b614bd3b636cd4dd41 cadaver-0.23.3.tar.gz"
+md5sums="502ecd601e467f8b16056d2acca39a6f cadaver-0.23.3.tar.gz
+68729682dd854945fc20c32709be873e neon.patch
+f0f9c9ca1508ee7eee447b98bb49095e disable-nls.patch"
+sha256sums="fd4ce68a3230ba459a92bcb747fc6afa91e46d803c1d5ffe964b661793c13fca cadaver-0.23.3.tar.gz
+7042a16981f660cd0df6f1d21004dcebe7cdd23eea1d4c0b6a925f8dafaac222 neon.patch
+51981dc5d272f294872af3a825c34c5a559eb7cb17d0801398747a1ebec406fc disable-nls.patch"
+sha512sums="48fe0a266be0ca7239f325377e5e2a8dc57a5d60466c7160e36c060ad24c09a50727695b9fa931844b1e66e173ebbb838f390d6c60fd07b614bd3b636cd4dd41 cadaver-0.23.3.tar.gz
+dba57c355afda9552a890d53b32343f4532c441d7d654ea09b8ee6533a4d3a455a02327b393cf98228c4989622962d92b929a4c674919434b72ac285e5ced68c neon.patch
+58982830b63c9bf4c27455e2d0403489bfdda82e4d236841c877d49c7501865edb3438cdddfb77ef7e525c4a5edb34083d3af69824f0ba2dc7d5c3f7f69b50e5 disable-nls.patch"
diff --git a/main/cadaver/disable-nls.patch b/main/cadaver/disable-nls.patch
new file mode 100644
index 0000000000..41e723973c
--- /dev/null
+++ b/main/cadaver/disable-nls.patch
@@ -0,0 +1,17 @@
+Fix building with --disable-nls.
+--- a/src/cadaver.c.~1~ 2007-08-22 14:17:27.000000000 +0200
++++ b/src/cadaver.c 2008-03-29 08:58:57.248793293 +0100
+@@ -838,11 +838,12 @@
+
+ progname = argv[0];
+
++#ifdef ENABLE_NLS
++
+ #ifdef HAVE_SETLOCALE
+ setlocale(LC_ALL, "");
+ #endif
+
+-#ifdef ENABLE_NLS
+ bindtextdomain(PACKAGE_NAME, LOCALEDIR);
+ textdomain(PACKAGE_NAME);
+ #endif /* ENABLE_NLS */
diff --git a/main/cadaver/neon.patch b/main/cadaver/neon.patch
new file mode 100644
index 0000000000..10a581a574
--- /dev/null
+++ b/main/cadaver/neon.patch
@@ -0,0 +1,43 @@
+$OpenBSD: patch-configure,v 1.4 2014/09/08 06:51:48 ajacoutot Exp $
+--- a/configure.orig Mon Sep 8 08:49:16 2014
++++ b/configure Mon Sep 8 08:49:47 2014
+@@ -9595,7 +9595,7 @@ fi
+ $as_echo "$ne_cv_lib_neon" >&6; }
+ if test "$ne_cv_lib_neon" = "yes"; then
+ ne_cv_lib_neonver=no
+- for v in 27 28 29; do
++ for v in 27 28 29 30; do
+ case $ne_libver in
+ 0.$v.*) ne_cv_lib_neonver=yes ;;
+ esac
+@@ -10242,8 +10242,8 @@ _ACEOF
+ fi
+
+ else
+- { $as_echo "$as_me:$LINENO: incompatible neon library version $ne_libver: wanted 0.27 28 29" >&5
+-$as_echo "$as_me: incompatible neon library version $ne_libver: wanted 0.27 28 29" >&6;}
++ { $as_echo "$as_me:$LINENO: incompatible neon library version $ne_libver: wanted 0.27 28 29 30" >&5
++$as_echo "$as_me: incompatible neon library version $ne_libver: wanted 0.27 28 29 30" >&6;}
+ neon_got_library=no
+ fi
+
+@@ -10328,7 +10328,7 @@ fi
+ $as_echo "$ne_cv_lib_neon" >&6; }
+ if test "$ne_cv_lib_neon" = "yes"; then
+ ne_cv_lib_neonver=no
+- for v in 27 28 29; do
++ for v in 27 28 29 30; do
+ case $ne_libver in
+ 0.$v.*) ne_cv_lib_neonver=yes ;;
+ esac
+@@ -10975,8 +10975,8 @@ _ACEOF
+ fi
+
+ else
+- { $as_echo "$as_me:$LINENO: incompatible neon library version $ne_libver: wanted 0.27 28 29" >&5
+-$as_echo "$as_me: incompatible neon library version $ne_libver: wanted 0.27 28 29" >&6;}
++ { $as_echo "$as_me:$LINENO: incompatible neon library version $ne_libver: wanted 0.27 28 29 30" >&5
++$as_echo "$as_me: incompatible neon library version $ne_libver: wanted 0.27 28 29 30" >&6;}
+ neon_got_library=no
+ fi
+