aboutsummaryrefslogtreecommitdiffstats
path: root/main/chrony
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2012-05-30 16:26:57 +0300
committerTimo Teräs <timo.teras@iki.fi>2012-05-30 16:27:52 +0300
commite00d6745ffc1fc9417559809c1770e340495b50e (patch)
treea5a91a5e38aad17115eab57fdd0e89181d8b8c23 /main/chrony
parent12d8fbaf1947587969d5e88154a0bdce4808320c (diff)
downloadaports-e00d6745ffc1fc9417559809c1770e340495b50e.tar.bz2
aports-e00d6745ffc1fc9417559809c1770e340495b50e.tar.xz
main/chrony: improve behaviour if network is unavailable at startup
main uclibc related workaround, but also reduce the delays between name resolution attempts.
Diffstat (limited to 'main/chrony')
-rw-r--r--main/chrony/0001-uclibc-res-do-not-call-res_init.patch26
-rw-r--r--main/chrony/0002-ntp_sources-decrease-maximum-re-resolving-delay.patch26
-rw-r--r--main/chrony/APKBUILD6
3 files changed, 57 insertions, 1 deletions
diff --git a/main/chrony/0001-uclibc-res-do-not-call-res_init.patch b/main/chrony/0001-uclibc-res-do-not-call-res_init.patch
new file mode 100644
index 0000000000..bbd18255cc
--- /dev/null
+++ b/main/chrony/0001-uclibc-res-do-not-call-res_init.patch
@@ -0,0 +1,26 @@
+From 6908e8eedf5232519a1f85942249040051e48fa8 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Timo=20Ter=C3=A4s?= <timo.teras@iki.fi>
+Date: Wed, 30 May 2012 16:23:50 +0300
+Subject: [PATCH 1/2] uclibc/res: do not call res_init
+
+it prevents rereading of resolv.conf in uclibc, but enables that
+for glibc.
+---
+ nameserv.c | 1 -
+ 1 file changed, 1 deletion(-)
+
+diff --git a/nameserv.c b/nameserv.c
+index 1770845..9ecf1d9 100644
+--- a/nameserv.c
++++ b/nameserv.c
+@@ -177,7 +177,6 @@ DNS_IPAddress2Name(IPAddr *ip_addr, char *name, int len)
+ void
+ DNS_Reload(void)
+ {
+- res_init();
+ }
+
+ /* ================================================== */
+--
+1.7.10.2
+
diff --git a/main/chrony/0002-ntp_sources-decrease-maximum-re-resolving-delay.patch b/main/chrony/0002-ntp_sources-decrease-maximum-re-resolving-delay.patch
new file mode 100644
index 0000000000..99610563dc
--- /dev/null
+++ b/main/chrony/0002-ntp_sources-decrease-maximum-re-resolving-delay.patch
@@ -0,0 +1,26 @@
+From 895b93933ef885df69ceda763fb3d1616e8e4370 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Timo=20Ter=C3=A4s?= <timo.teras@iki.fi>
+Date: Wed, 30 May 2012 16:24:38 +0300
+Subject: [PATCH 2/2] ntp_sources: decrease maximum re-resolving delay
+
+From approximately an hour to 7.5 minutes.
+---
+ ntp_sources.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/ntp_sources.c b/ntp_sources.c
+index 43a5d91..9c26bda 100644
+--- a/ntp_sources.c
++++ b/ntp_sources.c
+@@ -250,7 +250,7 @@ resolve_sources(void *arg)
+
+ if (unresolved_sources) {
+ /* Try again later */
+- if (resolving_interval < 9)
++ if (resolving_interval < 6)
+ resolving_interval++;
+ resolving_id = SCH_AddTimeoutByDelay(7 * (1 << resolving_interval), resolve_sources, NULL);
+ } else {
+--
+1.7.10.2
+
diff --git a/main/chrony/APKBUILD b/main/chrony/APKBUILD
index 32a74e00fe..a9ef2d3bd7 100644
--- a/main/chrony/APKBUILD
+++ b/main/chrony/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=chrony
pkgver=1.26
-pkgrel=0
+pkgrel=1
pkgdesc="NTP client and server programs"
url="http://chrony.tuxfamily.org/"
arch="all"
@@ -10,6 +10,8 @@ depends="logrotate"
makedepends="texinfo"
subpackages="$pkgname-doc"
source="http://download.tuxfamily.org/chrony/$pkgname-$pkgver.tar.gz
+ 0001-uclibc-res-do-not-call-res_init.patch
+ 0002-ntp_sources-decrease-maximum-re-resolving-delay.patch
chronyd.confd
chronyd.initd
chrony.logrotate
@@ -55,6 +57,8 @@ package() {
install -m644 "$srcdir"/chrony.conf "$pkgdir"/etc/chrony/chrony.conf
}
md5sums="ad6dd619ff1986e4ff780363c64e2246 chrony-1.26.tar.gz
+c479553205e2dfe1409c7924b0d0f81b 0001-uclibc-res-do-not-call-res_init.patch
+1f72a2805160dfa653866e0963256f7f 0002-ntp_sources-decrease-maximum-re-resolving-delay.patch
d62521b4c8837e15262c47ac88359307 chronyd.confd
f0c73948224cc1706cf9c94e4d2d7b69 chronyd.initd
468eaf2b5465d60b3ee021ce3f948ab1 chrony.logrotate