aboutsummaryrefslogtreecommitdiffstats
path: root/main/cjdns
diff options
context:
space:
mode:
authorBartłomiej Piotrowski <b@bpiotrowski.pl>2016-08-03 22:19:27 +0200
committerBartłomiej Piotrowski <b@bpiotrowski.pl>2016-08-03 22:19:27 +0200
commit7670ab2037c66d586a1d8b8f8ff35792874540dd (patch)
tree64e60a398be2799ae9e8ea355e350497f40bb36f /main/cjdns
parent74e83c00d524411a362cf8e1391e05b94edf3c83 (diff)
downloadaports-7670ab2037c66d586a1d8b8f8ff35792874540dd.tar.bz2
aports-7670ab2037c66d586a1d8b8f8ff35792874540dd.tar.xz
testing/cjdns: move to main
Diffstat (limited to 'main/cjdns')
-rw-r--r--main/cjdns/APKBUILD45
-rw-r--r--main/cjdns/cjdns.post-install5
2 files changed, 50 insertions, 0 deletions
diff --git a/main/cjdns/APKBUILD b/main/cjdns/APKBUILD
new file mode 100644
index 0000000000..6f0b761099
--- /dev/null
+++ b/main/cjdns/APKBUILD
@@ -0,0 +1,45 @@
+# Maintainer: Bartłomiej Piotrowski <bpiotrowski@alpinelinux.org>
+
+pkgname=cjdns
+pkgver=17.4
+pkgrel=1
+pkgdesc='A routing engine designed for security, scalability, speed and ease of use'
+url='https://github.com/cjdelisle/cjdns'
+arch='x86_64 armhf'
+license='GPL3'
+depends=
+makedepends='bash nodejs-lts python linux-headers libseccomp-dev'
+install="$pkgname.post-install"
+subpackages="$pkgname-doc"
+source="${pkgname}-${pkgver}.tar.gz::https://github.com/cjdelisle/${pkgname}/archive/cjdns-v${pkgver}.tar.gz"
+
+builddir="$srcdir/$pkgname-$pkgname-v$pkgver"
+
+build() {
+ cd "$builddir"
+ CJDNS_RELEASE_VERSION="${pkgver}" bash 'do'
+}
+
+package() {
+ cd "$builddir"
+ install -Dm755 cjdroute "$pkgdir/usr/sbin/cjdroute"
+ install -Dm755 contrib/openrc/cjdns "$pkgdir/etc/init.d/cjdns"
+
+ install -Dm644 doc/man/cjdroute.conf.5 \
+ "${pkgdir}/usr/share/man/man5/cjdroute.conf.5"
+ install -Dm 644 README.md "${pkgdir}/usr/share/doc/${pkgname}/README.md"
+ install -Dm644 -t "${pkgdir}/usr/share/doc/${pkgname}" \
+ doc/admin-api.md \
+ doc/configure.md \
+ doc/djc_layer_model.md \
+ doc/nat-gateway.md \
+ doc/network-services.md \
+ doc/non-root-user.md \
+ doc/security_specification.md \
+ doc/shorewall_and_vpn_gateway_howto.md \
+ doc/tunnel.md
+}
+
+md5sums="e74f25941879e807086a8b70771fcf60 cjdns-17.4.tar.gz"
+sha256sums="2f30aa4d2cc96a6c1f00e873df19b7b213cca1af716d74a091f59aa98b5758c4 cjdns-17.4.tar.gz"
+sha512sums="16f13d39b09b8388a2814e234c1f866d87c6699d215cce78885258224c9a5969720e436f960b8b160d47eb403622d81947234323c8b4734a9cc68de247b314de cjdns-17.4.tar.gz"
diff --git a/main/cjdns/cjdns.post-install b/main/cjdns/cjdns.post-install
new file mode 100644
index 0000000000..0e091e941c
--- /dev/null
+++ b/main/cjdns/cjdns.post-install
@@ -0,0 +1,5 @@
+#!/bin/sh
+
+umask 007
+[ ! -f /etc/cjdroute.conf ] && \
+ cjdroute --genconf > /etc/cjdroute.conf