aboutsummaryrefslogtreecommitdiffstats
path: root/main/cmocka
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2017-06-19 22:37:54 +0200
committerJakub Jirutka <jakub@jirutka.cz>2017-06-19 22:37:54 +0200
commit0e7c25ab34dffbbd532ab36ab35ebf51cbe767b2 (patch)
tree515b12147b76bcf8f994b96ed1f4bf2c114b255d /main/cmocka
parent0d58bfe80474cfc69e8651a66c8519d334950ad8 (diff)
downloadaports-0e7c25ab34dffbbd532ab36ab35ebf51cbe767b2.tar.bz2
aports-0e7c25ab34dffbbd532ab36ab35ebf51cbe767b2.tar.xz
main/cmocka: disable on aarch64 due to failing tests
The following tests FAILED: 38 - calculator_test (Failed) 42 - customer_database_test (Failed) 44 - product_database_test (Failed) 45 - waiter_test_wrap (Failed) test 38 Start 38: calculator_test 38: Test command: /home/buildozer/aports/main/cmocka/src/cmocka-1.1.1/build/example/calculator_test 38: Test timeout computed to be: 1500 38: [==========] Running 22 test(s). 38: [ RUN ] test_add 38: [ OK ] test_add 38: [ RUN ] test_subtract 38: [ OK ] test_subtract 38: [ RUN ] test_multiply 38: [ OK ] test_multiply 38: [ RUN ] test_divide 38: [ OK ] test_divide 38: [ RUN ] test_divide_by_zero 38: Expected assertion b occurred 38: [ OK ] test_divide_by_zero 38: [ RUN ] test_find_operator_function_by_string_null_functions 38: Expected assertion !number_of_operator_functions || operator_functions occurred 38: [ OK ] test_find_operator_function_by_string_null_functions 38: [ RUN ] test_find_operator_function_by_string_null_string 38: Expected assertion operator_string != NULL occurred 38: [ OK ] test_find_operator_function_by_string_null_string 38: [ RUN ] test_find_operator_function_by_string_valid_null_functions 38: [ OK ] test_find_operator_function_by_string_valid_null_functions 38: [ RUN ] test_find_operator_function_by_string_not_found 38: [ OK ] test_find_operator_function_by_string_not_found 38: [ RUN ] test_find_operator_function_by_string_found 38: [ OK ] test_find_operator_function_by_string_found 38: [ RUN ] test_perform_operation_null_args 38: Expected assertion !number_of_arguments || arguments occurred 38: [ OK ] test_perform_operation_null_args 38: [ RUN ] test_perform_operation_null_operator_functions 38: Expected assertion !number_of_operator_functions || operator_functions occurred 38: [ OK ] test_perform_operation_null_operator_functions 38: [ RUN ] test_perform_operation_null_number_of_intermediate_values 38: Expected assertion number_of_intermediate_values != NULL occurred 38: [ OK ] test_perform_operation_null_number_of_intermediate_values 38: [ RUN ] test_perform_operation_null_intermediate_values 38: Expected assertion intermediate_values != NULL occurred 38: [ OK ] test_perform_operation_null_intermediate_values 38: [ RUN ] test_perform_operation_no_arguments 38: [ OK ] test_perform_operation_no_arguments 38: [ RUN ] test_perform_operation_first_arg_not_integer 38: [ ERROR ] --- Test failed with exception: Segmentation fault(11) 38: [ FAILED ] test_perform_operation_first_arg_not_integer 38: [ RUN ] test_perform_operation_unknown_operator 38: [ ERROR ] --- Test failed with exception: Segmentation fault(11) 38: [ FAILED ] test_perform_operation_unknown_operator 38: [ RUN ] test_perform_operation_missing_argument 38: [ ERROR ] --- Test failed with exception: Segmentation fault(11) 38: [ FAILED ] test_perform_operation_missing_argument 38: [ RUN ] test_perform_operation_no_integer_after_operator 38: [ ERROR ] --- Test failed with exception: Segmentation fault(11) 38: [ FAILED ] test_perform_operation_no_integer_after_operator 38: [ RUN ] test_perform_operation 38: [ OK ] test_perform_operation 38: [ RUN ] test_example_main_no_args 38: [ OK ] test_example_main_no_args 38: [ RUN ] test_example_main 38: [ ERROR ] --- Test failed with exception: Segmentation fault(11) 38: [ FAILED ] test_example_main 38: [==========] 22 test(s) run. 38: [ PASSED ] 17 test(s). 38: [ FAILED ] 5 test(s), listed below: 38: [ FAILED ] test_perform_operation_first_arg_not_integer 38: [ FAILED ] test_perform_operation_unknown_operator 38: [ FAILED ] test_perform_operation_missing_argument 38: [ FAILED ] test_perform_operation_no_integer_after_operator 38: [ FAILED ] test_example_main 38: 38: 5 FAILED TEST(S) 1/4 Test #38: calculator_test ..................***Failed 0.00 sec test 42 Start 42: customer_database_test 42: Test command: /home/buildozer/aports/main/cmocka/src/cmocka-1.1.1/build/example/customer_database_test 42: Test timeout computed to be: 1500 42: [==========] Running 2 test(s). 42: [ RUN ] test_connect_to_customer_database 42: [ OK ] test_connect_to_customer_database 42: [ RUN ] test_get_customer_id_by_name 42: [ ERROR ] --- Test failed with exception: Segmentation fault(11) 42: [ FAILED ] test_get_customer_id_by_name 42: [==========] 2 test(s) run. 42: [ PASSED ] 1 test(s). 42: [ FAILED ] 1 test(s), listed below: 42: [ FAILED ] test_get_customer_id_by_name 42: 42: 1 FAILED TEST(S) 2/4 Test #42: customer_database_test ...........***Failed 0.00 sec test 44 Start 44: product_database_test 44: Test command: /home/buildozer/aports/main/cmocka/src/cmocka-1.1.1/build/example/product_database_test 44: Test timeout computed to be: 1500 44: [==========] Running 3 test(s). 44: [ RUN ] test_connect_to_product_database 44: [ ERROR ] --- Test failed with exception: Segmentation fault(11) 44: [ FAILED ] test_connect_to_product_database 44: [ RUN ] test_connect_to_product_database_bad_url 44: [ ERROR ] --- Test failed with exception: Segmentation fault(11) 44: [ FAILED ] test_connect_to_product_database_bad_url 44: [ RUN ] test_connect_to_product_database_missing_parameter 44: [ ERROR ] --- Test failed with exception: Segmentation fault(11) 44: [ FAILED ] test_connect_to_product_database_missing_parameter 44: [==========] 3 test(s) run. 44: [ PASSED ] 0 test(s). 44: [ FAILED ] 3 test(s), listed below: 44: [ FAILED ] test_connect_to_product_database 44: [ FAILED ] test_connect_to_product_database_bad_url 44: [ FAILED ] test_connect_to_product_database_missing_parameter 44: 44: 3 FAILED TEST(S) 3/4 Test #44: product_database_test ............***Failed Required regular expression not found.Regex=[\[ FAILED \] 2 test ] 0.00 sec test 45 Start 45: waiter_test_wrap 45: Test command: /home/buildozer/aports/main/cmocka/src/cmocka-1.1.1/build/example/chef_wrap/waiter_test_wrap 45: Test timeout computed to be: 1500 45: [==========] Running 2 test(s). 45: [ RUN ] test_order_hotdog 45: [ ERROR ] --- Test failed with exception: Segmentation fault(11) 45: [ FAILED ] test_order_hotdog 45: [ RUN ] test_bad_dish 45: [ ERROR ] --- Test failed with exception: Segmentation fault(11) 45: [ FAILED ] test_bad_dish 45: [==========] 2 test(s) run. 45: [ PASSED ] 0 test(s). 45: [ FAILED ] 2 test(s), listed below: 45: [ FAILED ] test_order_hotdog 45: [ FAILED ] test_bad_dish 45: 45: 2 FAILED TEST(S) 4/4 Test #45: waiter_test_wrap .................***Failed 0.00 sec
Diffstat (limited to 'main/cmocka')
-rw-r--r--main/cmocka/APKBUILD2
1 files changed, 1 insertions, 1 deletions
diff --git a/main/cmocka/APKBUILD b/main/cmocka/APKBUILD
index 836a8efdff..f4a33c6149 100644
--- a/main/cmocka/APKBUILD
+++ b/main/cmocka/APKBUILD
@@ -5,7 +5,7 @@ pkgver=1.1.1
pkgrel=0
pkgdesc="An elegant unit testing framework for C with support for mock objects"
url="https://cmocka.org/"
-arch="all"
+arch="all !aarch64"
license="ASL-2.0"
depends=""
makedepends="cmake"