aboutsummaryrefslogtreecommitdiffstats
path: root/main/cunit
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2017-09-08 12:27:06 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2017-09-08 12:27:28 +0000
commitc3db9cef255232c447e66f8c63c4fa138d6cf024 (patch)
tree6d6c652c9c5d02c0da6975682a21947c5e35acb1 /main/cunit
parent6103234f35b1554a4ca8f584535e5b05918b31ed (diff)
downloadaports-c3db9cef255232c447e66f8c63c4fa138d6cf024.tar.bz2
aports-c3db9cef255232c447e66f8c63c4fa138d6cf024.tar.xz
main/cunit: move from community
libdrm needs it for check
Diffstat (limited to 'main/cunit')
-rw-r--r--main/cunit/APKBUILD59
-rw-r--r--main/cunit/path-makefile.patch31
2 files changed, 90 insertions, 0 deletions
diff --git a/main/cunit/APKBUILD b/main/cunit/APKBUILD
new file mode 100644
index 0000000000..902129812e
--- /dev/null
+++ b/main/cunit/APKBUILD
@@ -0,0 +1,59 @@
+# Contributor: Francesco Colista <fcolista@alpinelinux.org>
+# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
+pkgname=cunit
+_pkgname=CUnit
+pkgver=2.1.3
+_pkgver=${pkgver%.*}-${pkgver##*.}
+pkgrel=1
+pkgdesc="Automated testing framework for C"
+url="http://cunit.sourceforge.net/"
+arch="all"
+license="GPL2"
+makedepends="automake autoconf libtool bash"
+subpackages="$pkgname-dev $pkgname-doc"
+source="https://downloads.sourceforge.net/project/$pkgname/$_pkgname/$_pkgver/$_pkgname-$_pkgver.tar.bz2
+ path-makefile.patch"
+builddir="$srcdir/$_pkgname-$_pkgver"
+
+prepare() {
+ default_prepare
+ cd "$builddir"
+ libtoolize --force --copy
+ aclocal
+ autoheader
+ automake --add-missing --include-deps --copy
+ autoconf
+}
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --prefix=/usr \
+ --includedir=/usr/include \
+ --datarootdir=/usr/share \
+ --libdir=/usr/lib \
+ --enable-debug \
+ --enable-examples \
+ --enable-automated \
+ --enable-basic \
+ --enable-test \
+ --disable-static
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+md5sums="b5f1a9f6093869c070c6e4a9450cc10c CUnit-2.1-3.tar.bz2
+975cfef465755b6cc5b946afb8dfcdd0 path-makefile.patch"
+sha256sums="f5b29137f845bb08b77ec60584fdb728b4e58f1023e6f249a464efa49a40f214 CUnit-2.1-3.tar.bz2
+229dc40fdbbd918a9349f8c8bd49e0962de32ab6e249776c30661424a363c5f4 path-makefile.patch"
+sha512sums="547b417109332446dfab8fda17bf4ccd2da841dc93f824dc90a20635bcf1fb80fb2176500d8a0906940f3f3d3e2f77b2d70a71090c9ab84ad9af43f3582bc487 CUnit-2.1-3.tar.bz2
+94b9ef959ff9808c6adb2022a8c085232bc3ca0d5023584a13c35c6cb17b98674b7cc252d65d53a5b3db085f82853463ade7f9b910b564befe1d7b1e868de105 path-makefile.patch"
diff --git a/main/cunit/path-makefile.patch b/main/cunit/path-makefile.patch
new file mode 100644
index 0000000000..a55bcd1dc8
--- /dev/null
+++ b/main/cunit/path-makefile.patch
@@ -0,0 +1,31 @@
+diff --git a/doc/Makefile.am b/doc/Makefile.am
+index a864d46..1c15fc0 100644
+--- a/doc/Makefile.am
++++ b/doc/Makefile.am
+@@ -1,6 +1,6 @@
+ ## Process this file with automake to produce Makefile.in
+
+-docdir = $(prefix)/doc/@PACKAGE@
++docdir = $(datarootdir)/doc/@PACKAGE@
+
+ doc_DATA = \
+ CUnit_doc.css \
+@@ -13,4 +13,4 @@ doc_DATA = \
+ test_registry.html \
+ writing_tests.html
+
+-SUBDIRS = headers
+\ No newline at end of file
++SUBDIRS = headers
+diff --git a/doc/headers/Makefile.am b/doc/headers/Makefile.am
+index 9926e8b..3c5f1ba 100644
+--- a/doc/headers/Makefile.am
++++ b/doc/headers/Makefile.am
+@@ -1,6 +1,6 @@
+ ## Process this file with automake to produce Makefile.in
+
+-dochdrdir = $(prefix)/doc/@PACKAGE@/headers
++dochdrdir = $(includedir)/@PACKAGE@/headers
+
+ INCLUDE_FILES = \
+ Automated.h \